[问题]崩溃+郁闷,ati radeon xpress 200m series

为当前最终发行版之前的所有版本提供支持
回复
wolfjiao
帖子: 32
注册时间: 2006-11-06 14:01
送出感谢: 0
接收感谢: 0
联系:

[问题]崩溃+郁闷,ati radeon xpress 200m series

#1

帖子 wolfjiao » 2006-11-27 19:41

我的lg笔记本显卡是ati radeon xpress 200m series,想体验一下xgl,可惜屡战屡败。
现把问题描述一下。
1.在ubuntu 6.06,6.1上遇到的主要问题是,显卡驱动安装上以后,系统不稳定,5分钟内死机。
经过网上查找原因,是ati radeon xpress 200m series 驱动最后一个稳定版本是8.24.8
ati-driver-installer-8.24.8-x86.run
经过千辛万苦,总算下载到这个驱动,但是在6.06上确装不上,原因是8.24.8只能在xorg6.8.x上安装,dapper上的xorg版本是7.0。也许有其他办法解决这个问题,但是我不会。
只好装ubuntu 5.1,显卡驱动终于能装上了,系统稳定,但是安装xgl时有遇到问题。
在breezy 上安装xgl我参照这篇文章:Xgl and Compiz under Breezy。
http://ubuntuforums.org/showthread.php?t=133772
但是在执行

代码: 全选

sudo apt-get install libxfont1 gconf-editor libwnck18 libglitz1 libxcomposite1

的时候出错

又是版本问题。
最终问题归结在libxcomposite1这个包上。最新版本必须在xorg7.0上安装。
想找个旧点的版本,找不到。真是郁闷致死啊。

问题:1,ati-driver-installer-8.24.8-x86.run只能在xorg6.8。x上安装,有什么办法在xorg7.0上安装吗?
2,在哪里能下载到比libxcomposite的低版本包?能在breezy上安装的版本?
wolfjiao
帖子: 32
注册时间: 2006-11-06 14:01
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 wolfjiao » 2006-11-28 21:01

怎么没人回答阿。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#3

帖子 zhuqin_83 » 2006-11-29 3:04

xpress 200是什么显卡?
x300?
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
enthumelon
帖子: 86
注册时间: 2006-11-29 10:18
来自: USTC
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 enthumelon » 2006-11-29 10:54

我也有相同的问题,本是ASUS W3Z(x64), 显卡和楼主一样(听朋友讲,从硬件上来讲,好像这种显卡不是真正意义上的独立显卡,而是一个独立的显存罢了),声卡(ali的芯片组)也照样没法识别,从redhat,suse,slackware,到ubintu(包括不同版本的内核)我全部装过,不过安装显卡和声卡驱动时全部有问题。不知怎样办才好。
wolfjiao
帖子: 32
注册时间: 2006-11-06 14:01
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 wolfjiao » 2006-12-18 21:08

显卡驱动总算安装成功了。我是在6.06上安装成功的。

安装完6.06后,立刻升级,



据说,ati 8.24.8驱动是ati xpress 200m 最后一个稳定的版本。高版本的驱动对于ati xpress 200m来说,不合适。
下面是驱动下载网址。


ttp://www.rage3d.com/board/showthread.php?t=33852190
https://a248.e.akamai.net/f/674/9206/0/ ... .8-x86.run
https://a248.e.akamai.net/f/674/9206/0/ ... x86_64.run

进入到驱动程序目录。
用官方源,不要用cn99的源


代码:

sudo gedit /etc/apt/sources.list


应该像下面的列表
代码:

deb http://ubuntu.beryl-project.org/ dapper main

deb http://au.archive.ubuntu.com/ubuntu/ dapper main restricted
deb-src http://au.archive.ubuntu.com/ubuntu/ dapper main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://au.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
deb-src http://au.archive.ubuntu.com/ubuntu/ dapper-updates main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://au.archive.ubuntu.com/ubuntu/ dapper universe
deb-src http://au.archive.ubuntu.com/ubuntu/ dapper universe

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://au.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
deb-src http://au.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu dapper-security main restricted
deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted
deb http://security.ubuntu.com/ubuntu dapper-security universe
deb-src http://security.ubuntu.com/ubuntu dapper-security universe



代码:


sudo apt-get update

sudo apt-get build-dep gcc
sudo apt-get upgrade

sudo apt-get install gcc-3.4 module-assistant build-essential fakeroot dh-make debconf
sudo sh ./ati-driver-installer-8.24.8-x86.run --buildpkg Ubuntu/dapper
sudo dpkg -i fglrx-kernel-source_8.24.8-1_i386.deb
sudo dpkg -i xorg-driver-fglrx_8.24.8-1_i386.deb
sudo apt-get -f upgrade


现在编译核心驱动:
代码:


sudo module-assistant prepare
sudo module-assistant update
sudo module-assistant a-i fglrx
(注:或者
sudo module-assistant prepare
sudo module-assistant update
sudo module-assistant build fglrx
sudo module-assistant install fglrx
sudo depmod -a)


注:此时出现了错误

Package fglrx-kernel-source was not built successfully, see
/var/cache/modass/fglrx-kernel-source*buildlog* for details!

按照参考方法,这样做:
代码:


cd /usr/src
sudo dpkg -i fglrx-kernel-*.deb


代码:


sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv


重启动,驱动应该能正常了。
头像
TualatriX
帖子: 359
注册时间: 2006-11-17 20:07
来自: 杭州/宁波
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 TualatriX » 2006-12-18 21:38

好像想体验XGL,直接用Hiweed这个基于Xubuntu的就能打开了。
但是我不是很喜欢这个轻量级桌面系统。
IMTX:http://imtx.cn/

LDCN(已经关闭):http://linuxdesktop.cn/

Ubuntu Tweak:http://ubuntu-tweak.com/
nj_chris
帖子: 145
注册时间: 2006-12-31 22:41
送出感谢: 0
接收感谢: 0

#7

帖子 nj_chris » 2007-03-17 0:18

下载ati-driver-installer-8.24.8-x86.run后,双击运行吗
头像
Jimmy.Zhou
帖子: 475
注册时间: 2006-12-05 21:51
来自: Vienna, Austria
送出感谢: 0
接收感谢: 0

#8

帖子 Jimmy.Zhou » 2007-03-17 4:16

根据5楼的帖子安装

TualatriX
为什么不用ubuntu的gnome?
Jimmy.Zhou

Acer Extensa 5620G
T5250 + HD 2400 XT + 2G DDR2 +160G SATA + iwp 3945
Ubuntu Intrepid Ibex + Firefox 3
头像
eastflying
帖子: 58
注册时间: 2006-12-26 15:30
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 eastflying » 2007-03-17 4:28

ati radeon xpress 200m是芯片组,其北桥内部集成了X300级别的显示芯片,显存是需要由系统内存提供的,也就是说就是集成显卡,和Intel 945GM集成的GMA950是同一种东东,所以估计同ATI的独立显卡的驱动会有一些不兼容的现象...
栩栩如生

我用沉默告诉你,我不回头...
  
头像
sfree
帖子: 603
注册时间: 2007-03-17 1:24
来自: 湖南长沙
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 sfree » 2007-07-06 20:38

Can't open /ati-driver-installer-8.24.8-x86.run

why?
头像
xyzzy
帖子: 6
注册时间: 2008-05-31 23:25
送出感谢: 0
接收感谢: 0

#11

帖子 xyzzy » 2008-06-01 15:38

我的笔记本也是这个。装 的ubuntu7.10,试过无数种方法装3D桌面,全部以失败告终,有哪位仁兄成功了,请通知一声。谢谢
Uranus
帖子: 156
注册时间: 2005-03-28 0:48
来自: 辽宁抚顺
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 Uranus » 2008-06-01 16:42

xyzzy 写了:我的笔记本也是这个。装 的ubuntu7.10,试过无数种方法装3D桌面,全部以失败告终,有哪位仁兄成功了,请通知一声。谢谢

你把7.10更新成8.04,或者下载个8.04的光盘重新安装。装好后选择受限硬件中的显卡驱动安装,在从新启动你就会看到华丽的3D了。哈,我也是X200
回复

回到 “老旧版本支持”