当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 自定义安装UBUNTU过程及问题
帖子发表于 : 2005-09-24 11:15 

注册: 2005-08-20 13:03
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
笔记本:acer 612txv,声卡、显卡、网卡全部是内置的,intel801。
PIII800,256内存。
1 光盘安装,选择SERVER,安装完毕。
2 sudo su
3 nano /etc/apt/sources.list
删除所有东西,并在加上下面的行:
deb http://archive.ubuntu.org.cn/ubuntu hoary main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-security main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-updates main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu-cn hoary main universe multiverse restricted
deb http://archive.ubuntu.org.cn/backports hoary-backports main universe multiverse restricted
deb http://archive.ubuntu.org.cn/backports hoary-extras main universe multiverse restricted
保存,关闭编辑器
4 系统升级(如果出现需要输入[Y/n] 或 [y/N] 一律输入 y 并 回车):
apt-get update
apt-get dist-upgrade
(出现了部分软件包无法得到的信息)
5 安装X窗口
apt-get install x-windows-system-core
(看到自定义安装DEBIAN,有人建议只装XSERVER-XORG,XBASE-CLIENTS,XFONTS-BASE三个文件就够了;他的文章中写的是XBASE-CLIENT、XFONT-BASE,我按照他写的安装不上,结果只好安装X-WINDOWS-SYSTEM-CORE,过程中发现在UBUNTU中是我写出来的文件名)
6 安装XFCE4
FVWM我也安装过,需要自己定制,好麻烦,为了省事,我还是选择了XFCE4,快速而又简便。
apt-get install xfce4
7 安装浏览器
apt-get install mozilla
(一开始我想安装mozilla-firefox,但是出现无法安装的信息,所以装了mozilla,不过速度好象比firefox快。)
8 安装输入法
apt-get install fcitx
(两个我都装过,个人偏好FCITX中的拼音和联想功能,尤其是选择词的方框大而明显)
9 进入图形界面
startx
(根据自己的计算机设置分辨率,我的是1024*768*60)
以下在图形界面终端下,(如果出现需要输入[Y/n] 或 [y/N] 一律输入 y 并 回车)
10 安装新立得
sudo apt-get install synaptic
11 设置本地local环境:
sudo dpkg-reconfigure locales
确保 zh_CN.UTF-8 被选择,同时也默认local为 zh_CN.UTF-8
12 安装中文语言支持:
sudo apt-get install language-pack-zh language-pack-zh-base language-support-zh
(不知道是在安装中文语言支持时,还是在安装x-windows-system-core时,OPENOFFICE自动安装了,这点很不爽,我本来想自己安装2.0的)
13 安装中文字体:
sudo apt-get install ttf-arphic-newsung
sudo apt-get install ttf-vera-yuan
14 让输入法自动启动
sudo sh -c " echo 'export XMODIFIERS=@im=fcitx ; export GTK_IM_MODULE="fcitx" ; fcitx ' > / etc/X11/Xsession.d/95xinput "
sudo chmod +755 /etc/X11/Xsession.d/95xinput
15 安装编译器
sudo apt-get install nedit
(感觉比gedit好用)
16 设置LC_ALL和其它属性:
sudo nedit /etc/environment
在编辑器里,将内容修改如下:
LANGUAGE="zh_CN:zh:en_US:en"
LC_ALL=zh_CN.UTF-8
LANG=zh_CN.UTF-8
GST_ID3_TAG_ENCODING=GBK
保存,关闭编辑器
推出一下当前会话,即注销一下用户,再登入输入法就有了(按 Ctrl + 空格 键激活输入法)。
17 安装JAVA环境
sudo apt-get install sun-j2re1.5
18 安装unzip
sudo apt-get install unzip
19 安装QQ
wget -c http://lumaqq.linuxsir.org/download/200 ... jre.tar.gz
sudo tar zxvf lumaqq_2004-linux_gtk2_x86_no_jre.tar.gz -C /opt/
wget -c http://lumaqq.linuxsir.org/download/pat ... .13.55.zip
sudo unzip -o lumaqq_2004_patch_2005.05.09.13.55.zip -d /opt/LumaQQ/lib
sudo chown -R root:root /opt/LumaQQ/
sudo chmod -R 755 /opt/LumaQQ/
sudo nedit /usr/share/applications/LumaQQ.desktop
在新增的文件内加入下面这几行
[Desktop Entry]
Name=LumaQQ
Comment=QQ Client
Exec=/opt/LumaQQ/lumaqq
Icon=/opt/LumaQQ/QQ.png
Terminal=false
Type=Application
Categories=Application;Network;
保存编辑过的文件
20 安装多媒体播放驱动
sudo apt-get install w32codecs gstreamer0.8-plugins mozilla-mplayer mplayer-fonts
(装好的是xmms)
21 安装 星际译王
sudo apt-get install stardict stardict-common stardict-cdict-gb stardict-cedict-gb stardict-hanzim stardict-langdao-ce-gb stardict-langdao-ec-gb stardict-oxford-gb stardict-xdict-ce-gb stardict-xdict-ec-gb
22 安装bt软件
sudo apt-get install azureus
23 升级你的内核
sudo apt-get install linux-686
(我的电脑是Inter芯片)
24 安装Email 客户端程序 (Mozilla Thunderbird)
sudo apt-get install mozilla-thunderbird
存在问题
1 mozilla导入bookmarks后,重新启动机器就没有了。
2 xfce4中设置好的东西,重新启动机器就没有了,比如新立得,在添加启动器中输入,当时有,再启动又没有了)
3 有一些软件装不了了。
gimp: 依赖: gimp-data (=2.2.8-1ubuntu1~5.04ubp1) 但是 2.2.2-1ubuntu5 将会被安装.
gaim: 依赖: gaim-data (=1:1.4.0-1ubuntu1~5.04ubp1) 但是 1:1.1.4-1ubuntu4.4 将会被安装
realplayer:安装过程中出现一些问题,最后虽然安装上了,但用不了。
acroread:安装后用不了。
MPLAYER:找不到包
operoffice:自行随包安装。
4 每次启动都是先进入终端,我想是 应该安装XDM。
5 X窗口是否可以只安装三个包?那样会少装好多垃圾。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-09-24 11:30 

注册: 2005-09-21 16:26
帖子: 169
送出感谢: 0 次
接收感谢: 0 次
终于我有个心得,千万不要更新所有的东西。。。。也就是设置中的第四步系统升级中千万不要这样做,很多东西这样一做后都不能用了,比如Gaim,Firefox等,最好还是用新立得手动更新你所需要的东西。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-09-24 12:01 

注册: 2005-08-20 2:42
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
hscui 写道:
终于我有个心得,千万不要更新所有的东西。。。。也就是设置中的第四步系统升级中千万不要这样做,很多东西这样一做后都不能用了,比如Gaim,Firefox等,最好还是用新立得手动更新你所需要的东西。


禁了两个backports就可以了。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-09-24 12:09 

注册: 2005-05-12 10:08
帖子: 310
送出感谢: 0 次
接收感谢: 0 次
自定义安装原来是这样搞。 :P :P


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-09-24 12:20 

注册: 2005-09-21 16:26
帖子: 169
送出感谢: 0 次
接收感谢: 0 次
zkyo 写道:
hscui 写道:
终于我有个心得,千万不要更新所有的东西。。。。也就是设置中的第四步系统升级中千万不要这样做,很多东西这样一做后都不能用了,比如Gaim,Firefox等,最好还是用新立得手动更新你所需要的东西。


禁了两个backports就可以了。


Backports是干什么用的?


页首
 用户资料  
 
6 楼 
 文章标题 : 谁能回答我的问题?
帖子发表于 : 2005-09-24 13:08 

注册: 2005-08-20 13:03
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
楼上几位兄弟的回复使我知道装不上软件的原因了,不过其他几个问题还是没有人回答?
另外,装不上的软件我自己下载安装应该可以吧?不用源里的。那些源这两天是不是在更新或更改目录?
拜托达人们尽快回复,我好重新装一次,把我所需要的全部装好,这样就暂时不用再折腾了:)


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-09-24 13:11 

注册: 2005-09-21 16:26
帖子: 169
送出感谢: 0 次
接收感谢: 0 次
我也不懂啊,和你一样,刚刚才装Ubuntu,准备下午或者晚上重装一次,另外听说中午12点左右和晚上12点左右源都在更新,此时最好不要更新系统。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-09-24 13:16 

注册: 2005-08-20 13:03
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
现在还有问题,用文件管理器打开移动硬盘后,不能双击打开文件,我已经设置了打开程序了,但是还是打不开。WORD文档,MP3,都是这样。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译