[问题]请问为什么每次我用源码安装就会出现如下提示?

为当前最终发行版之前的所有版本提供支持
回复
fox67
帖子: 19
注册时间: 2006-11-19 1:25
送出感谢: 0
接收感谢: 0

[问题]请问为什么每次我用源码安装就会出现如下提示?

#1

帖子 fox67 » 2006-11-29 12:02

checking for C compiler default output file name... configure: error: C compiler cannot create executables

我应该如何解决,谢谢!
hubottle
帖子: 37
注册时间: 2006-07-01 8:58
送出感谢: 0
接收感谢: 0

#2

帖子 hubottle » 2006-11-29 12:47

典型的没有安装gcc编辑器。
从源里装sudo apt-get install gcc
另外你查看一下你是否安装有perl、make,也一并安装上。
编译是需要一些工具的。
fox67
帖子: 19
注册时间: 2006-11-19 1:25
送出感谢: 0
接收感谢: 0

#3

帖子 fox67 » 2006-11-29 16:44

谢谢hubottle的帮助,但是我全都安上了阿,看这个:


lina@uclip:~$ sudo aptitude install gcc
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
创建标签数据库... 完成
将不会安装,升级或者删除任何软件包。
0 个软件包被升级,新安装0 个, 0 个将被删除, 同时 0 个将不升级。
需要获取 0B 的存档。 解包后将要使用 0B。
正在编辑扩展状态信息... 完成
lina@uclip:~$ sudo aptitude install perl
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
创建标签数据库... 完成
将不会安装,升级或者删除任何软件包。
0 个软件包被升级,新安装0 个, 0 个将被删除, 同时 0 个将不升级。
需要获取 0B 的存档。 解包后将要使用 0B。
正在编辑扩展状态信息... 完成
lina@uclip:~$ sudo aptitude install make
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
创建标签数据库... 完成
将不会安装,升级或者删除任何软件包。
0 个软件包被升级,新安装0 个, 0 个将被删除, 同时 0 个将不升级。
需要获取 0B 的存档。 解包后将要使用 0B。
正在编辑扩展状态信息... 完成
lina@uclip:~$ sudo apt-get install gcc
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
gcc 已经是最新的版本了。
The following packages were automatically installed and are no longer required:
imlib11 python-pyogg python-pyvorbis python2.4-pysqlite2 tcltls
python-pysqlite2 docker sox imlib-base
使用 'apt-get autoremove' 来删除它们。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
lina@uclip:~$ sudo apt-get install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
The following packages were automatically installed and are no longer required:
imlib11 python-pyogg python-pyvorbis python2.4-pysqlite2 tcltls
python-pysqlite2 docker sox imlib-base
使用 'apt-get autoremove' 来删除它们。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
lina@uclip:~$ sudo apt-get install make
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
make 已经是最新的版本了。
The following packages were automatically installed and are no longer required:
imlib11 python-pyogg python-pyvorbis python2.4-pysqlite2 tcltls
python-pysqlite2 docker sox imlib-base
使用 'apt-get autoremove' 来删除它们。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
lina@uclip:~$


可还是同样的提示
fox67
帖子: 19
注册时间: 2006-11-19 1:25
送出感谢: 0
接收感谢: 0

#4

帖子 fox67 » 2006-11-30 17:54

没人能解答这问题吗?
回复

回到 “老旧版本支持”