[问题] 修改源并更新升级Ubuntu失败!

为当前最终发行版之前的所有版本提供支持
回复
onlymearmstr
帖子: 27
注册时间: 2006-11-19 13:53
来自: 济南
送出感谢: 0
接收感谢: 0
联系:

[问题] 修改源并更新升级Ubuntu失败!

#1

帖子 onlymearmstr » 2006-11-30 10:09

http://wiki.ubuntu.org.cn/%E5%BF%AB%E9% ... E%E6%8C%87%...
按照上面的方法,运行到sudo apt-get dist-upgrade出现错误:
fll@fll-desktop:/etc/apt$ sudo apt-get dist-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
fglrx-control: 依赖: libqt3-mt (>= 3:3.3.6) 但是它还没有被安装
E: 不能满足依赖关系。不妨试一下 -f 选项。
fll@fll-desktop:/etc/apt$
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 SuperWar3Fan » 2006-11-30 11:30

sudo aptitude -f install
头像
veleking
帖子: 22
注册时间: 2005-09-30 11:40
来自: 北京
送出感谢: 0
接收感谢: 0

#3

帖子 veleking » 2006-11-30 11:40

fglrx-control: 依赖: libqt3-mt (>= 3:3.3.6) 但是它还没有被安装
sudo apt-get -f install 修复
不行就 sudo apt-get remove fglrx-control 把它删掉
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 karron » 2006-11-30 13:01

你要用与你系统匹配的源.不要混用. 设置源之后要 sudo apt-get update 一下,刷新包索引.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
回复

回到 “老旧版本支持”