安装jdk1.5时出现如下错误

为当前最终发行版之前的所有版本提供支持
回复
vbarter
帖子: 60
注册时间: 2006-11-28 18:10
送出感谢: 0
接收感谢: 0
联系:

安装jdk1.5时出现如下错误

#1

帖子 vbarter » 2006-12-01 12:54

代码: 全选

sudo apt-get install java-package
在安装的过程中提示如下信息:

代码: 全选

正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
Reading state information... 完成      
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  java-package: 依赖: debhelper 但是它将不会被安装
E: 无法安装的软件包
于是,我通过系统->系统管理->新立得的软件包管理器 来安装debhelper,但是在标记附加变更时,会提示将删除若干软件包,其中有些软件包非常重要(第一次安装后导致无法登录界面),所以不敢安装。
请问这个问题该怎么解决呢?
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 SuperWar3Fan » 2006-12-01 14:42

sudo apt-get install sun-java5-jdk
vbarter
帖子: 60
注册时间: 2006-11-28 18:10
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 vbarter » 2006-12-01 16:00

非常非常感谢,这个问题困惑了好久,现在终于解决了
回复

回到 “老旧版本支持”