[讨论]can't access tty job control turned off 的解决办法。

为当前最终发行版之前的所有版本提供支持
回复
wucongkun
帖子: 251
注册时间: 2006-11-10 20:27
送出感谢: 0
接收感谢: 0

[讨论]can't access tty job control turned off 的解决办法。

#1

帖子 wucongkun » 2006-12-02 0:14

没有办法 我不知道怎么弄
只好google了。。。
各种办法。。抄下来看看先 。

add "tty0::askfirst:/bin/ash" to etc/inittab
It seems working.

>From: "Jeff \"Tiny\" Warren" <tiny.laser@verizon.net>
>To: Pelle Svensson <pelle2004@hotmail.com>
>CC: busybox@mail.busybox.net
>Subject: Re: [BusyBox] can't access tty: job control turned off
>Date: 24 Sep 2004 09:19:49 -0700
>
>Pelle,
>
>I went over this same problem myself and tried to comprehensively
>document my dev dir,inittab file,bootargs,etc. It is in this months
>archives, "Job control turned off, yet again", see if that helps. My
>setup is similar to yours, the AT91Rm9200 has a ttySA0, but you are
>supposed to use ttyS0 (I don't know if this is the same in your case).
>
>Regards,
>
>Jeff
>
>
>On Fri, 2004-09-24 at 05:56, Pelle Svensson wrote:
> > !!!Please!!!
> >
> > Could anyone explain in detail the necessary steps needed for the
>correct
> > setup of
> > a ARM system using a serial terminal on ttyAM1 (204,16)
> >
> > kernel command line: console=ttyAM1,115200 ...
> >
> > 1. correct setup of /dev entries
> > 1. correct setup of inittab
> >
> >
> > What I can figure in all my attempts is that I'm running the respawn of
>sh
> > as the console
> > in my inittab. When busybox verify the tty it get's the errorno ENOTTY
>(Not
> > a typewrite) error.
> >
> > #inittab
> > ::wait:/sbin/getty -n -l /bin/sh 115200 /dev/console vt100
> >
> > There are hundreds of "can't access tty: job control turned off" in the
> > mailinglist
> > but all fragmented in there description of the correct setup needed.
> >
> > /Thanks
> >

>


Hi Jeff

Thanks for the link to your thread.

Setting up thinks in the correct way solved my problem.
I did miss on the dev entry for the serial port.

kernel command line: console=ttyAM1,115200 ...

indicated using serial port '1' and dev entry was using serial port '0'

mknod -m 666 ttyAM1 204 16

should be

mknod -m 666 ttyAM1 204 17

and then in inittab

ttyAM1::askfirst:/bin/sh


貌似需要:
kernel command line: console=ttyAM1,115200
mknod -m 666 ttyAM1 204 16
in inittab
ttyAM1::askfirst:/bin/sh
[/list]
回复

回到 “老旧版本支持”