关于./configure的一个问题

为当前最终发行版之前的所有版本提供支持
回复
vbarter
帖子: 60
注册时间: 2006-11-28 18:10
送出感谢: 0
接收感谢: 0
联系:

关于./configure的一个问题

#1

帖子 vbarter » 2006-12-03 13:07

代码: 全选

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets $(MAKE)... yes
checking for working aclocal-1.4... missing
checking for working autoconf... missing
checking for working automake-1.4... missing
checking for working autoheader... missing
checking for working makeinfo... missing
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for a BSD-compatible install... /usr/bin/install -c
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for DEPS... configure: error: Package requirements (gtk+-2.0 >= 2.8 glib-2.0 >= 2.2) were not met:

No package 'gtk+-2.0' found
No package 'glib-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DEPS_CFLAGS
and DEPS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

cjj@cjj-laptop:~/Downloads/homebank-3.2.1$ 
我运行./configure以后,出现如上错误,似乎是gtk和glib版本不对,于是我去搜索更新,可是没有发现gtk和glib(我是在ubuntu的gnome环境下的新立得软件包管理器中搜索的)
请问我该如何 ./configure呢?
wweeii
帖子: 21
注册时间: 2006-07-29 2:44
送出感谢: 0
接收感谢: 0

#2

帖子 wweeii » 2006-12-03 13:12

一般./configure提示什么什么找不到的话,你需要安装相应的dev
gtk2.0的dev包是libgtk2.0-dev
glbi2.0的dev包是libglib2.0-dev
vbarter
帖子: 60
注册时间: 2006-11-28 18:10
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 vbarter » 2006-12-03 21:56

非常感谢,学到了
回复

回到 “老旧版本支持”