求助:drcom-client 1.3.2 的问题

为当前最终发行版之前的所有版本提供支持
回复
头像
proahang
帖子: 20
注册时间: 2005-07-25 17:57
送出感谢: 0
接收感谢: 0

求助:drcom-client 1.3.2 的问题

#1

帖子 proahang » 2006-12-03 19:24

学校的校园网现在使用dr.com拨号上网了非常可恶。linux下要上网就只能用drcom-client,但是要使用drcom-client并不是一帆风顺啊,按照这篇帖子的介绍viewtopic.php?t=9651&start=0&postdays=0 ... .com+linux
我在ubuntu 6.06.1下安装了drcom1.3.2,但是执行sudo drcomd时提示如下:drcomd: /lib/libc.so.6: version `GLIBC_2.4' not found (required by drcomd)

整个过程如下:(因为不能上网就只能用ubuntu 6.06.1dvd做源,安装了build-essential gcc-3.4 libssl-dev 以及libc6 libc6-* 和相应版本的kernel header)

ahang@LXBX:/media/storage/drcom-1.3.2/drcom-1.3.2$ cat /proc/version
Linux version 2.6.15-26-amd64-generic (buildd@king) (gcc version 4.0.3 (Ubuntu 4.0.3-1ubuntu5)) #1 SMP PREEMPT Thu Aug 3 02:52:35 UTC 2006


ahang@LXBX:/media/storage/drcom-1.3.2/drcom-1.3.2$ sudo make
make -C drcomc
make[1]: Entering directory `/media/storage/drcom-1.3.2/drcom-1.3.2/drcomc'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/media/storage/drcom-1.3.2/drcom-1.3.2/drcomc'
make -C drcomd
make[1]: Entering directory `/media/storage/drcom-1.3.2/drcom-1.3.2/drcomd'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/media/storage/drcom-1.3.2/drcom-1.3.2/drcomd'
make -C kmod
make[1]: Entering directory `/media/storage/drcom-1.3.2/drcom-1.3.2/kmod'
make -C /lib/modules/2.6.15-26-amd64-generic/build M=/media/storage/drcom-1.3.2/drcom-1.3.2/kmod modules
make[2]: Entering directory `/usr/src/linux-headers-2.6.15-26-amd64-generic'
Building modules, stage 2.
MODPOST
make[2]: Leaving directory `/usr/src/linux-headers-2.6.15-26-amd64-generic'
make[1]: Leaving directory `/media/storage/drcom-1.3.2/drcom-1.3.2/kmod'
ahang@LXBX:/media/storage/drcom-1.3.2/drcom-1.3.2$ sudo make install
make -C drcomc install
make[1]: Entering directory `/media/storage/drcom-1.3.2/drcom-1.3.2/drcomc'
mkdir -p /usr/local/bin/
install -m 755 drcomc /usr/local/bin/
make[1]: Leaving directory `/media/storage/drcom-1.3.2/drcom-1.3.2/drcomc'
make -C drcomd install
make[1]: Entering directory `/media/storage/drcom-1.3.2/drcom-1.3.2/drcomd'
mkdir -p /usr/local/bin/
install -m 700 drcomd /usr/local/bin/
make[1]: Leaving directory `/media/storage/drcom-1.3.2/drcom-1.3.2/drcomd'
make -C kmod install
make[1]: Entering directory `/media/storage/drcom-1.3.2/drcom-1.3.2/kmod'
make -C /lib/modules/2.6.15-26-amd64-generic/build M=/media/storage/drcom-1.3.2/drcom-1.3.2/kmod modules
make[2]: Entering directory `/usr/src/linux-headers-2.6.15-26-amd64-generic'
Building modules, stage 2.
MODPOST
make[2]: Leaving directory `/usr/src/linux-headers-2.6.15-26-amd64-generic'
make -C /lib/modules/2.6.15-26-amd64-generic/build M=/media/storage/drcom-1.3.2/drcom-1.3.2/kmod modules_install
make[2]: Entering directory `/usr/src/linux-headers-2.6.15-26-amd64-generic'
INSTALL /media/storage/drcom-1.3.2/drcom-1.3.2/kmod/drcom.ko
make[2]: Leaving directory `/usr/src/linux-headers-2.6.15-26-amd64-generic'
/sbin/depmod -a 2.6.15-26-amd64-generic
make[1]: Leaving directory `/media/storage/drcom-1.3.2/drcom-1.3.2/kmod'
if [ -a /etc/drcom.conf ]; then \
echo "====================================" && \
echo "" && \
echo "/etc/drcom.conf exists.";\
echo "" && \
echo "You May Need to Edit /etc/drcom.conf" && \
echo "" && \
echo "====================================" \
;\
else\
install -m 600 drcom.conf /etc/drcom.conf && \
echo "====================================" && \
echo "" && \
echo "Do Not Forget To Edit /etc/drcom.conf" && \
echo "" && \
echo "====================================" \
;\
fi\

====================================

/etc/drcom.conf exists.

You May Need to Edit /etc/drcom.conf

====================================
ahang@LXBX:/media/storage/drcom-1.3.2/drcom-1.3.2$ sudo drcomd
drcomd: /lib/libc.so.6: version `GLIBC_2.4' not found (required by drcomd)
ahang@LXBX:/media/storage/drcom-1.3.2/drcom-1.3.2$

俺的ubuntu至今无法上网,郁闷中。。。。希望高手指点
snappy
帖子: 279
注册时间: 2006-03-02 22:34
来自: 广西南宁
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 snappy » 2006-12-05 10:01

应该可以的,用这个软件的人不少,你再好好找点资料吧,我没有用过这个东西,所以也帮不上忙,不过这个肯定能用,我就见过别人用这个上网
Ubuntu8.04
IBM T40 PM 1.5G
1.5G内存
80G硬盘
14.1XGA
显卡 ATI RADEON 7500 32M
56K/1GB/红外/TV-out/无线802.11b
COMBO
gangbei
帖子: 29
注册时间: 2006-10-21 15:04
送出感谢: 0
接收感谢: 0

#3

帖子 gangbei » 2006-12-05 10:34

我现在正在用drcom上网
我是按这篇文章装的
viewtopic.php?t=27078&start=0&postdays= ... ight=drcom
它上面有个重点

修改drcomd文件夹下的一些源文件
把login.c , logout.c , passwd.c ,watchport.c
中的#include <openssl/md5.h> 改成 #include <md5.h>。原因是该版本已经包含了md5.h和md.c文件,已经不需要库里面的了,加了反而
会报错。
希望这个对你有效
回复

回到 “老旧版本支持”