安装e17,太受打击了!!(安装成功,感谢zengsun/yonsan兄弟)

为当前最终发行版之前的所有版本提供支持
回复
lhf8371
帖子: 33
注册时间: 2005-09-19 11:28
送出感谢: 0
接收感谢: 0

安装e17,太受打击了!!(安装成功,感谢zengsun/yonsan兄弟)

#1

帖子 lhf8371 » 2005-09-27 1:37

看了zengsun的文章后,满有信心的下载包,看文档,搞了半天出来个:

lhf@lhfubuntu:~/e17/libs/eet$ ./autogen.sh
Running aclocal...
./autogen.sh: line 8: aclocal: command not found

怎么解决!!


还有个问题,xine-lib怎么安装,apt-cache也找不到,最后用新立得安了个libxine1c2 ,这个对吗?

我从网上下了
libxine1_1.0-1ubuntu3.1_i386
libxine-dev_1.0-1ubuntu3.1_i386
这两个包但装不上,怎么回事!!
报错为:
libxine-dev: Depends: libxine1 (= 1.0-1ubuntu3.1) 但是它将不会被安装
Depends: xlibs-dev 但是它将不会被安装
Depends: slang1-dev 但是它将不会被安装

libxine1: Depends: libmodplug0 (>= 1:0.7-1) 但是它将不会被安装
libxine1c2: Conflicts: libxine1 但是 1.0-1ubuntu3.1 正要被安装

______________________________________________

搞定了!!好酷的界面 :lol:

葛优:做人要厚道,不要那么酷,ok? :twisted:

感谢zengsun/yonsan兄弟的帮助!!!


今天晚上发个帖子,对zengsun兄的那篇文章加点补充
上次由 lhf8371 在 2005-09-30 10:51,总共编辑 3 次。
zengsun
帖子: 334
注册时间: 2005-05-17 14:45
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 zengsun » 2005-09-27 8:31

你先把基本的编译工具都装上,再看我的帖子。
m4
autoconf
automake (1.7 or greater)
libtool
pkg-config
现在还是在学java!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2005-09-27 9:05

e17列。要自己对lin比较熟悉了才玩。如果硬件配置低,那是没办法。其实玩这样的东西,需要自己有勇气的。清楚一点,帮助少,文档少,靠自己。
● 鸣学
lhf8371
帖子: 33
注册时间: 2005-09-19 11:28
送出感谢: 0
接收感谢: 0

#4

帖子 lhf8371 » 2005-09-27 9:25

zengsun 写了:你先把基本的编译工具都装上,再看我的帖子。
m4
autoconf
automake (1.7 or greater)
libtool
pkg-config


zengsun兄,我已经把你帖里的都装上了呀!怎么又冒出这么多?
lhf8371
帖子: 33
注册时间: 2005-09-19 11:28
送出感谢: 0
接收感谢: 0

#5

帖子 lhf8371 » 2005-09-27 9:47

还有,

$./autogen && make && sudo make install

这条命令是一起执行的吗?

我单个运行到make,说没指明目标并且找不到makefile
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2005-09-27 10:04

:lol: 别怕多。
● 鸣学
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 yongyi » 2005-09-27 12:10

ubuntu默认没安装的编译环境的。所以还得安装。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
lhf8371
帖子: 33
注册时间: 2005-09-19 11:28
送出感谢: 0
接收感谢: 0

#8

帖子 lhf8371 » 2005-09-27 12:27

*** The xine-config script installed by xine could not be found
*** If xine was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the XINE_CONFIG environment variable to the
*** full path to xine-config.
configure: error: Xine isn't installed


我担心的事出现了,我不确定自己装没装xine-lib,也不知道知道去哪找包

现在说我Xine没安装,郁闷了,帮助啦!!!
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 yongyi » 2005-09-27 12:40

debian没有xine-lib
简单的办法:
sudo apt-get install xine-ui
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
lhf8371
帖子: 33
注册时间: 2005-09-19 11:28
送出感谢: 0
接收感谢: 0

#10

帖子 lhf8371 » 2005-09-27 13:24

安装了xine-ui,但没用,还是不能./autogen.sh

看到运行有这样的提示

checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking dependency style of g++... none
checking how to run the C++ preprocessor... /lib/cpp
checking for g77... no
checking for f77... no
checking for xlf... no
checking for frt... no
checking for pgf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for f90... no
checking for xlf90... no
checking for pgf90... no
checking for epcf90... no
checking for f95... no
checking for fort... no
checking for xlf95... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for gfortran... no

和这有关吗?
头像
yonsan
帖子: 887
注册时间: 2005-07-01 18:56
来自: 广州市
送出感谢: 0
接收感谢: 3 次

#11

帖子 yonsan » 2005-09-27 14:05

:o

代码: 全选

sudo apt-get install g++
这些用户感谢了作者 yonsan 于这个帖子:
linzhongluerdai (2014-06-24 18:43)
评价: 3.7%
I will be back!
lhf8371
帖子: 33
注册时间: 2005-09-19 11:28
送出感谢: 0
接收感谢: 0

#12

帖子 lhf8371 » 2005-09-27 15:04

zengsun 写了:sudo apt-get install libxine-dev


yonsan 写了:sudo apt-get install g++


谢谢zengsun yonsan 继续安装中......
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 yongyi » 2005-09-27 18:05

唉,你们都行。但为什么我的不行的啊!总是出个黑白的界面。晕菜啊!
希望LZ在zengsun帖子那跟帖总结一下。方便后来的兄弟。
PS:我的是没指望了。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
回复

回到 “老旧版本支持”