[讨论]感慨一下,apt-get真的要小心使用啊

为当前最终发行版之前的所有版本提供支持
回复
overmindoyj
帖子: 21
注册时间: 2006-11-19 0:24
送出感谢: 0
接收感谢: 0

[讨论]感慨一下,apt-get真的要小心使用啊

#1

帖子 overmindoyj » 2006-12-05 12:40

本来我的系统dapper用的好好的,也打开了beryl+xgl了。谁知昨天apt-get upgrade一下,麻烦就来了。
先是firefox升到1.5.0.8,然后上网就时不时的自动关闭了,也没有应用程序崩溃的提示。于是就想找替代产品,上网down了opera9,还是个β版本,速度比firefox快一点,可是打开数个网页的时候cpu占用达到90+,每次都要杀死进程。又下了konqueror,可是在gnome环境下面是英文的,而且打开某个java script网页的时候死活打不开。
于是又想,是不是xgl影响了效果,因为我的xgl打开之后direct rendering就是no了,然后就关了beryl管理器,没有用,把会话里面的启动项目关闭了,重启,也没有用,然后就做了一件大的错事,我sudo apt-get remove beryl,结果就卸载了一大堆东西,重启之后就没有gui了。
噩梦来临,我以前在nvidia网站下过一个9629的nv驱动,然后卸啊,装啊,装完之后startx是可以的,重启之后又进不去,每次都是报x kernel的版本跟x module不一致,因为源里面的nvidia-glx是8776的,所以每次启动,安装驱动,进x;重启,又是command line。
昨天弄到12点都没有搞定,而这,都源于一次apt-get upgrade。
头像
TualatriX
帖子: 359
注册时间: 2006-11-17 20:07
来自: 杭州/宁波
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 TualatriX » 2006-12-05 12:47

不会吧。
这么可怕。
IMTX:http://imtx.cn/

LDCN(已经关闭):http://linuxdesktop.cn/

Ubuntu Tweak:http://ubuntu-tweak.com/
头像
syhan
帖子: 272
注册时间: 2006-09-06 12:24
来自: Southeast University
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 syhan » 2006-12-05 12:53

我干脆就不装beryl了,呵呵,知道有这么个东西就行了
awesome + stalonetrayer + urxvt + rox-filer + feh + SLiM
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#4

帖子 xiehuoli » 2006-12-05 13:44

我很少apt-get upgrade
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
头像
fifawqm
帖子: 11
注册时间: 2006-12-05 16:05
送出感谢: 0
接收感谢: 0

#5

帖子 fifawqm » 2006-12-05 16:15

其实有的东西够用就可以了 并不要追求最新的版本
发现功能不能满足你了 你可以再去升级或找其他的软件替代
zhang10369
帖子: 42
注册时间: 2006-11-17 10:56
送出感谢: 0
接收感谢: 0

#6

帖子 zhang10369 » 2006-12-05 16:45

楼主在做apt-get upgrade 之前
可以先运行一下dpkg --get-selections >package.
然后编辑package这个文档.把你不想升级的软件状态由install改成hold
然后运行dpkg --set-selections <package
再升级就没事了.
头像
xjj
帖子: 156
注册时间: 2006-10-22 20:49
送出感谢: 0
接收感谢: 1 次

#7

帖子 xjj » 2006-12-09 11:53

没有啊,你看着来升级,不用全部升级的。

系统没问题的话。就不用升级了。
回复

回到 “老旧版本支持”