当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装了Ubuntu的ATi驱动为什么有时无法打开3D加速?
帖子发表于 : 2005-09-27 12:52 

注册: 2005-09-15 18:48
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
我的显卡是8500LE,系统是5.04,用的是Ubuntu的驱动。安装步骤如下:
1、sudo apt-get install xorg-driver-fglrx
2、echo fglrx | sudo tee -a /etc/modules
3、sudo sed -i -e 's/"ati"/"fglrx"/' /etc/X11/xorg.conf
4、reboot
重新启动后在终端执行fglrxinfo,提示如下:
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 8500 DDR Generic
OpenGL version string: 1.3.4769 (X4.3.0-8.8.25)
此时3D加速已经打开。但是我选择注消,退到登录界面,然后重新进入后3D加速就失效了,运行fglrxinfo,显示如下:
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
更奇怪的是,如果再注消一次,3D加速又打开了。
我发现两次注消有点不同,第一次是黑屏后直接显示登录界面,第二次在黑屏后会先显示一下字符的Longin,然后再显示GDM界面。而且我发现,这两种切换模式是交替进行的,只要出现第二种情况3D加速就能够打开,这样如果注消后要使用OpenGL就必须注消偶数次。
我用Ubuntu不是很久,不知道这是什么原因,望高手指点。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-09-29 0:49 

注册: 2005-07-26 8:40
帖子: 73
送出感谢: 0 次
接收感谢: 0 次
你的3D没有打开 你的驱动也没有安装成功照你那个方法是不行的.

你需要去ATI下载一个 for xorg6.8的驱动,好像名叫fglrx-6-8-0_8.14.13-2_i386.rpm
代码:
sudo  alien fglrx-6-8-0_8.14.13-2_i386.rpm
转成DEB包
代码:
sudo apt-get install gcc

代码:
sudo apt-get install linux-kernel-header
(同你用的内核版本)
代码:
sudo dpkg -i --force-overwrite fglrx-6-8-0_8.14.13-2_i386.deb


代码:
Ctrl+atl+F1
切换到字符下

代码:
sudo sh /lib/modules/fglrx/build_mod/make.sh

完成之后会叫你运行这个
代码:
sudo sh /lib/modules/fglrx/make_install.sh

完成之后 你可以运行
代码:
fglrxconfig
的向导来设置你的xorg.conf 就是些
完成后 startx 该是就装好了,可以运行

代码:
glxgears


代码:
glxinfo

来测一下 你的8500 FPS该有1000以上

glxinfo的该是这样
代码:
[b]direct rendering: Yes[/b]
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-09-29 0:51 

注册: 2005-07-26 8:40
帖子: 73
送出感谢: 0 次
接收感谢: 0 次
其实这个在这专里的专题里就有,只是写得不大全。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-09-29 8:10 

注册: 2005-09-21 16:26
帖子: 169
送出感谢: 0 次
接收感谢: 0 次
ATI7500Mobile是否也可以这么来安装驱动?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:MSNbot Media 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译