[讨论]grub安装到mbr上是否引起主板自检变慢?

为当前最终发行版之前的所有版本提供支持
回复
头像
enjoyforfun
帖子: 53
注册时间: 2006-11-24 13:27
送出感谢: 0
接收感谢: 0

[讨论]grub安装到mbr上是否引起主板自检变慢?

#1

帖子 enjoyforfun » 2006-12-07 13:12

我不久前装了Ubuntu后发现电脑启动慢了,
仔细看了后才发现是自检变慢了
就是电脑开机到交给操作系统之前的一段时间变长!

以前还没注意,主要是近来看启动了
为了检验我进了M$-dos,运行了fdisk /mbr (以ms的标准重建mbr,或win nt的修复台下fixmbr)

主板自检又变快了!不知何解??
然后我又把grub装回mbr,又变慢了!
如果哪位兄弟能告诉我如何不装到mbr,直接用grub4dos就好了! :)


你们的机子有这个问题么??(对象是以前是win然后才加入linux或装grub的兄弟)
我同学的机子也有这一现象!!
lisir
帖子: 1187
注册时间: 2006-04-29 14:54
来自: 山东
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 lisir » 2006-12-07 19:55

没有感觉,你说的是不是grub有个等待时间啊,你可以设置一下。
如果你指的是机器的主板硬件自检,那不可能的,那时grub还没有接管呢。

我记得原来看过的材料说,机器通电后先进行POST,检测初始化完后,将权力交给grub或ntldr之类的启动管理器,由它选择在主板上的启动分区,然后再交给操作系统。好像是这样的。
学会看置顶帖、精华帖。
学会使用搜索。
常见问题解答和发帖需知
头像
enjoyforfun
帖子: 53
注册时间: 2006-11-24 13:27
送出感谢: 0
接收感谢: 0

#3

帖子 enjoyforfun » 2006-12-09 15:31

但事实上好像影响了

我的是hp的本本,启动后是先看到hp的logo吧!这之后才会给grub等启动管理工具吧!

问题是使用grub后出启动后出现logo前的时间变长!


不用grub后就恢复了!

等待时间那个我还是知道的,绝对不是那个问题!

有需要的话我用手机录像下来给你们看!



是不是grub的载入时间比ntld久啊!
但是这个从我的本本出现logo后就正常,像win的启动管理那样快,就是在出现启动logo前的时间变长!
我同学的台机就是出现完logo 后关于网后的那一页!
他的是onda(昂达)的 c61
头像
choukuangjay
帖子: 274
注册时间: 2006-01-17 14:39
来自: Nanking
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 choukuangjay » 2006-12-09 17:11

不会啊,
主板POST结束之后才去读取硬盘的第一个sector,也就是mbr,然后mbr中的pre-boot(前446Bytes)去看partition table(后66Bytes)种哪个 被表记成active,接着就去读被表记的partition的boot区
ID:死乘把口, Matrix Chou
寨本网 山寨笔记本大本营
头像
enjoyforfun
帖子: 53
注册时间: 2006-11-24 13:27
送出感谢: 0
接收感谢: 0

#5

帖子 enjoyforfun » 2006-12-09 23:09

可是就是这么奇怪!

我无语了!

我心里也是这样暗示的,可惜事实让我无法接受!

怎么就是装grub后就出现,虽然这不能算是大问题,我只是让你们知道有这事
让作者知道!让他看看吧!


不要用自检的顺序理论回帖了,因为事实就是这样,
grub有影响

我的估计是:主板商受M$影响----主板在检测硬盘是否存在时,有测试mbr的动作
-----因为mbr被grub改动了,不像M$或其它主板商设定的模式----检测超时-----但硬盘的确存在
----然后继续启动...





我的主板应该是没看防毒功能的,因为它能在很短的时间进入xp(没grub时)
而且好像新主板默认都没开!
如果开了防毒还好解析点 :D

主板究竟做了啥??
有这方面的xD么?
回复

回到 “老旧版本支持”