永中2007在Edgy下的解决方案

为当前最终发行版之前的所有版本提供支持
回复
Vstar
帖子: 273
注册时间: 2005-10-03 14:13
来自: Tokushima, Japan
送出感谢: 0
接收感谢: 1 次
联系:

永中2007在Edgy下的解决方案

#1

帖子 Vstar » 2006-12-09 12:17

在Edgy下安装永中是一件比较头疼的事,有四个问题可能遇到:
1、安装程序无法执行,运行sudo ./setup后,解压完就没有反应了
2、安装后,进入永中,菜单栏的文字可能会是方块
3、打开文件时,程序崩溃退出
4、无法直接双击或通过右键菜单打开文件名是中文的文件

解决方法:
1、安装时,先将永中解压后,从终端进入解压后的目录,输入
sudo java -jar ./dispose.jar
进行安装
2和3、安装后,进入终端,执行下面命令(就是把系统中的Jre替换永中自带的Jre)
cd /usr/local/Evermore/EIOffice/
sudo rm Jre -R
sudo ln -sf /usr/lib/jvm/java-1.5.0-sun/jre ./Jre
4、修改永中启动器文件
sudo gedit /usr/share/applications/eio.desktop
删掉里面的%u

OK,试一试吧
上次由 Vstar 在 2006-12-09 12:36,总共编辑 4 次。
致虚极,守静笃
Vstar
帖子: 273
注册时间: 2005-10-03 14:13
来自: Tokushima, Japan
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 Vstar » 2006-12-09 12:19

因为正在使用Edgy,所以没有测试在Dapper下是否可行,我想应该也是可以的,大家可以试一下
致虚极,守静笃
头像
tsinghan
帖子: 1677
注册时间: 2005-12-23 19:20
送出感谢: 0
接收感谢: 0

按照楼主的方法搞定了

#3

帖子 tsinghan » 2006-12-15 1:31

按照楼主的方法搞定了 可是有一点 如果装了beryl 要禁用 或者在/etc/environment里添加一行: AWT_TOOLKIT="MToolkit"
然后才能安装好

现在装好了 可惜ppt播放时无法全屏 留下gnome的上下两条bar 楼主,怎么办?
有办法解决吗?
dyspnea
帖子: 42
注册时间: 2006-10-19 15:54
送出感谢: 0
接收感谢: 0

Re: 永中2007在Edgy下的解决方案

#4

帖子 dyspnea » 2006-12-28 22:22

能告知jre 的版本吗?
zhangqiang
帖子: 70
注册时间: 2007-04-02 12:58
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 zhangqiang » 2007-04-21 9:15

似乎这样做了以后就不能用了,启动不了了,为什么呢?盼告!
回复

回到 “老旧版本支持”