为什么我的系统启动要等上5分钟??

为当前最终发行版之前的所有版本提供支持
回复
头像
s5unty
帖子: 22
注册时间: 2006-11-16 8:58
来自: NanJing
送出感谢: 0
接收感谢: 0
联系:

为什么我的系统启动要等上5分钟??

#1

帖子 s5unty » 2006-12-16 15:21

Dec 16 15:01:33 jbm-desktop kernel: [17179695.328000] Buffer I/O error on device hdc, logical block 0
Dec 16 15:01:33 jbm-desktop kernel: [17179699.352000] hdc: dma_intr: status=0x51 { DriveReady SeekComplete Error }
Dec 16 15:01:33 jbm-desktop kernel: [17179699.352000] hdc: dma_intr: error=0x40 { UncorrectableError }, LBAsect=7, sector=0
Dec 16 15:01:33 jbm-desktop kernel: [17179699.352000] ide: failed opcode was: unknown
Dec 16 15:01:33 jbm-desktop kernel: [17179699.352000] end_request: I/O error, dev hdc, sector 0
Dec 16 15:01:33 jbm-desktop kernel: [17179699.352000] Buffer I/O error on device hdc, logical block 0
Dec 16 15:01:33 jbm-desktop kernel: [17179703.384000] hdc: dma_intr: status=0x51 { DriveReady SeekComplete Error }
Dec 16 15:01:33 jbm-desktop kernel: [17179703.384000] hdc: dma_intr: error=0x40 { UncorrectableError }, LBAsect=7, sector=0
Dec 16 15:01:33 jbm-desktop kernel: [17179703.384000] ide: failed opcode was: unknown
Dec 16 15:01:33 jbm-desktop kernel: [17179703.384000] end_request: I/O error, dev hdc, sector 0
Dec 16 15:01:33 jbm-desktop kernel: [17179703.384000] Buffer I/O error on device hdc, logical block 0
Dec 16 15:01:33 jbm-desktop kernel: [17179703.432000] PDC20268: IDE controller at PCI slot 0000:02:03.0
Dec 16 15:01:33 jbm-desktop kernel: [17179703.432000] ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11
Dec 16 15:01:33 jbm-desktop kernel: [17179703.432000] PCI: setting IRQ 11 as level-triggered
我每次开机启动Ubuntu(edgy)的时候,启动时间很长,我按Alt+F1切换到文字界面,看到很多Buffer I/O error。
大概等上5分钟之后,系统便能正常登录了,登录后我查看syslog,发现如上的错误信息,请帮我看看这是什么问题,谢谢!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-12-16 17:23

都是hdc的?岂不是光驱不对头。
● 鸣学
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#3

帖子 zhuqin_83 » 2006-12-17 9:58

光驱挂了。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
s5unty
帖子: 22
注册时间: 2006-11-16 8:58
来自: NanJing
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 s5unty » 2006-12-17 10:48

hdc不一定是光驱阿
IDE1上的第一个设备是hda
IDE1上的第二个设备是hdb
IDE2上的第一个设备是hdc
IDE2上的第二个设备是hdd

当时我把ubuntu安装在IDE2的第一个设备(硬盘)上,所以是hdc阿!
但是当时我记得分区是这样的,我分了一个逻辑分区
逻辑分区中有三个分区,一个是swap,一个是根,还有一个是用户目录
swap在hdc, 6
根在hdc, 7
用户目录在hdc, 8

请高手再给点意见,谢谢!!
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#5

帖子 zhuqin_83 » 2006-12-17 12:33

那岂不是硬盘出问题了?
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
rosn
帖子: 978
注册时间: 2006-01-14 18:33
来自: 广州花都区
送出感谢: 19 次
接收感谢: 3 次
联系:

#6

帖子 rosn » 2006-12-18 18:16

有没有进行过其它修改什么的?或者安装时出过什么问题吗
lomandv
头像
s5unty
帖子: 22
注册时间: 2006-11-16 8:58
来自: NanJing
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 s5unty » 2006-12-19 9:18

第一次安装的时候,没发现安装有什么问题

后来第二次安装,我把光盘放入启动,然后在LiveCD的引导界面,我按Alt+F1,看到了相同的Error

后来我联想到第一次安装时LiveCD引导时间很长的问题,原来在使用LiveCD安装时候就出现了问题。

不过我仍然有疑问,既然是LiveCD,其实是和硬盘无关的!为什么他还会出现哪种错误呢???
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#8

帖子 xiehuoli » 2006-12-19 11:29

这样的问题能不能用fsck修复阿
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
头像
s5unty
帖子: 22
注册时间: 2006-11-16 8:58
来自: NanJing
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 s5unty » 2006-12-20 15:56

其实这是我朋友的机器,因为我平时工作都用ubuntu,觉得不错就推荐他装了。等兴冲冲的装完却出现了这种问题。。。

他的机器也比较少有,内置了3个光驱,外置1个;内置了2块硬盘,继续外置1个。之所以他能接这么多IDE设备,是因为它买了一个PCI-IDE的扩展卡,把一个PCI扩展成2个IDE,这样便能多接4个IDE设备。

现在问题还没解决,准备这周去帮他重装,但心里没底... :(
zhlmmc
帖子: 58
注册时间: 2006-11-21 2:23
送出感谢: 0
接收感谢: 0

#10

帖子 zhlmmc » 2006-12-20 17:58

汗。。。这么多光驱硬盘。。。难道是搞音乐工作的?
头像
spider5
帖子: 351
注册时间: 2005-12-15 21:52
送出感谢: 0
接收感谢: 0

#11

帖子 spider5 » 2006-12-20 22:24

同意楼上的看法。
硬盘可能出问题了,挂到别人电脑上检查一下?
回复

回到 “老旧版本支持”