当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 双核CPU编译程序时的怪问题
帖子发表于 : 2006-12-18 19:02 

注册: 2006-07-24 9:21
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
我是core 2.0G的CPU,
在编译程序时我看到系统监视器对CPU使用状况的监视结果是:
两个核的使用情况成反比,一个用得越高另一个就越低,如果使用一个使用是100%了,另一个就是0%
平时情况都是好的,两个核使用情况都是同时上升同时降低的。
有人可以解释一下为什么?
我使用的是ubuntu6.06
linux-686内核,也装了686-smp
另,是在BERYL XGL下运行的


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-12-18 19:05 
头像

注册: 2005-12-15 21:52
帖子: 351
送出感谢: 0 次
接收感谢: 0 次
能介绍一下楼主的配置么,另外你的beryl是怎么安装上去的。
没写清楚,你的cpu是64位的还是32位的。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-12-18 19:35 

注册: 2006-07-24 9:21
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
配置是
intel core T2500 2.0G 32位
1G memory
ATI x1400 128mb
beryl是直接用以前compiz的源
apt-get装的,按照beryl论坛的一篇howto,不过是和gnome会话分离的
启动xgl会话,fglrxinfo 提示3D加速没有
gnome会话下有


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-12-18 20:09 
头像

注册: 2005-12-15 21:52
帖子: 351
送出感谢: 0 次
接收感谢: 0 次
啊,可惜啊,你的又是32位的,我的64位一直没装成功,还以为找到救星了。 :cry:

你的问题我不清楚,不过听说在多cpu结构上做分布式要使用mips包,平时的应用程序肯定考虑了双核结构。
而你编译的程序没有包含分布式计算库,就和你在双核上跑xp一样的结果,只有一个cpu在使用。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-12-18 21:13 
头像

注册: 2006-11-17 20:07
帖子: 359
地址: 杭州/宁波
送出感谢: 0 次
接收感谢: 0 次
我也是双核CPU,好像没有这个问题。一直比较协调。


_________________
IMTX:http://imtx.cn/

LDCN(已经关闭):http://linuxdesktop.cn/

Ubuntu Tweak:http://ubuntu-tweak.com/


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译