[问题]重装xp后完全参照置顶贴做了,仍然无法修复ubuntu

为当前最终发行版之前的所有版本提供支持
回复
lycoris
帖子: 7
注册时间: 2006-12-04 22:39
送出感谢: 0
接收感谢: 0

[问题]重装xp后完全参照置顶贴做了,仍然无法修复ubuntu

#1

帖子 lycoris » 2006-12-18 19:15

完全按照
sudo su
grub
root (hdx,y)
setup(hdx)
quit
的顺序做了.tab后显示:分区0,1,3,5
0,3为fat分区,1为ext分区,5分区unknown.
故输入root (hd0,1)
setup,quit后重启,出现多重启动菜单,欣喜不已.
选择ubuntu,kernel2.6.15-27-386后,出现一下错误信息
root (hd0,2)
filesystem type unknown, partition type 0xf
kernel /boot/vmlinuz-2.6.15-27-386 root=/dev/hda3 ro quiet splash

error 17:cannot mount seleted partition



请高手指教.
ps.可正常进入windows系统

:?: :?: :?:
头像
spider5
帖子: 351
注册时间: 2005-12-15 21:52
送出感谢: 0
接收感谢: 0

#2

帖子 spider5 » 2006-12-18 19:23

其实这种问题自己手打这么多字不如贴一个

代码: 全选

fdisk -l
的输出结果要清晰。
root (hd0,2) 指向hda3即你的fat32分区,启动不了很正常。
另外hda5/sda5是什么分区,你的swap呢。
lycoris
帖子: 7
注册时间: 2006-12-04 22:39
送出感谢: 0
接收感谢: 0

#3

帖子 lycoris » 2006-12-18 19:41

来了。fdisk -l的结果
附件
Screenshot.png
头像
spider5
帖子: 351
注册时间: 2005-12-15 21:52
送出感谢: 0
接收感谢: 0

#4

帖子 spider5 » 2006-12-18 19:59

哦,只有一个linux分区呀,看来要手动编辑/boot/grub/menu.lst了,
grub install 变更配置文件似乎失败了。
要把第一个登录的(hd0,2)改成(hd0,1)
详细操作到网上找找文章,下面我说的也是

启动到grub界面,按e进入命令行方式,会列出入口ubuntu,kernel2.6.15-27-386的详细配置
把第一行的root (hd0,2)改成root (hd0,1),然后按b,引导linux
进去后立即修改menu.lst。
lycoris
帖子: 7
注册时间: 2006-12-04 22:39
送出感谢: 0
接收感谢: 0

#5

帖子 lycoris » 2006-12-18 20:35

把第一行的root (hd0,2)改成root (hd0,1),然后按b,引导linux ,出现新问题.
没办法抓图了,贴个照片吧.
附件
PICT0011.JPG
lycoris
帖子: 7
注册时间: 2006-12-04 22:39
送出感谢: 0
接收感谢: 0

#6

帖子 lycoris » 2006-12-19 8:56

有知道的兄弟一定要帮偶呀,小弟先谢了.
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 zhan » 2006-12-19 10:09

还需要修改一个地方,看你上面的 kernel 行, root=/dev/hda3 改成 root=/dev/hda2.就是在 grub 启动界面的第二行.
然后再试着启动一下看看.
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
头像
spider5
帖子: 351
注册时间: 2005-12-15 21:52
送出感谢: 0
接收感谢: 0

#8

帖子 spider5 » 2006-12-19 12:43

恩,kernel行也要修改,我看了自己的menu.lst,大家的不一定一致,希望管理员能把问题和解决方法并到置顶里面去。

我给分区指定了标签,所以是LABEL=/的形式。
lycoris
帖子: 7
注册时间: 2006-12-04 22:39
送出感谢: 0
接收感谢: 0

#9

帖子 lycoris » 2006-12-19 13:29

谢谢各位帮忙,我回家试试
wucongkun
帖子: 251
注册时间: 2006-11-10 20:27
送出感谢: 0
接收感谢: 0

#10

帖子 wucongkun » 2006-12-19 14:14

这个......
job control.....
移动硬盘安装以后根分区缺少记号文件也是这样的症状....
lycoris
帖子: 7
注册时间: 2006-12-04 22:39
送出感谢: 0
接收感谢: 0

#11

帖子 lycoris » 2006-12-19 19:34

问题解决,谢谢以上的各位兄弟。也希望跟我遇到同样问题的朋友们good luck。
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 zhan » 2006-12-19 20:45

你可以写出一篇文章谈谈这个问题,与大家分享一下经验。
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
回复

回到 “老旧版本支持”