6.10新立得出了问题(已解决)

为当前最终发行版之前的所有版本提供支持
回复
头像
KyTor
帖子: 222
注册时间: 2006-12-05 22:23
来自: http://www.wengyuanhang.com/
送出感谢: 0
接收感谢: 0
联系:

6.10新立得出了问题(已解决)

#1

帖子 KyTor » 2006-12-20 13:18

看了一下帖子,删除了apt,然后想重新安装apt,放入盘,发现apt并不在
/media/cdrom0/pool/main/a/apt
请问谁知道在哪,怎么安装?


在自己花了大把时间后终于得到解决。
注一:曾经在网上找到一篇解决的方案,大意就是删除掉apt然后重新安装一遍。但发现在6.10盘中根本没有/man/a/apt的目录(也许作者说错了,反正是没有。我不清楚!)(附:http://www.iwxm.net/archives/508)
我重新安装是先在http://ubuntu.cnsite.org/ubuntu/pool/main/a/apt上面下载几个deb文件。(注意我的机子是386,如果你的机子是amd64,要注意选择相应的deb包。)
五个文件吧
apt_0.6.45ubuntu14_i386.deb
apt-doc_0.6.45ubuntu14_all.deb
apt-utils_0.6.45ubuntu14_i386.deb
libapt-pkg-dev_0.6.45ubuntu14_i386.deb
libapt-pkg-doc_0.6.45ubuntu14_all.deb
注意,这并不是最新的版本。我试过用最新的,发现问题就是依赖关系 出现错误,只好选用低版本。反正到时候再更新。

把这几个文件放在同一个文件夹下面。然后在这个目录下用命令
sudo dpkg -i *.deb
新立得又可以用了。(呵呵,马上试试在终端中运行命令,发现不会出现段错误的提示。哈哈哈,得意一下。)
然后通过更新就可以了。至于要怎么更新看wiki里面吧。http://wiki.ubuntu.org.cn/%E5%BF%AB%E9%80%9F%E8%AE%BE%E7%BD%AE%E6%8C%87%E5%8D%97/EdgyEft

最好在终端输入下列一段命令
sudo apt-get install synaptic
哈哈哈,马上就可以打开新立得了。
上次由 KyTor 在 2006-12-20 21:58,总共编辑 2 次。
虔诚的信徒啊!请相信KyTor吧!
http://www.wengyuanhang.com/
------------------
愿上帝赐我平静,接受我无法改变的事;
愿上帝赐我勇气,改变我能够改变的事;
愿上帝赐我智慧,能明辨这两者的差异;
xiechy
帖子: 1074
注册时间: 2006-01-18 15:01
送出感谢: 0
接收感谢: 1 次

#2

帖子 xiechy » 2006-12-20 13:56

上网装。或者,确定你已经mount上了分区。
头像
KyTor
帖子: 222
注册时间: 2006-12-05 22:23
来自: http://www.wengyuanhang.com/
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 KyTor » 2006-12-20 19:45

xiechy 写了:上网装。或者,确定你已经mount上了分区。

写得详细些可以吗?
虔诚的信徒啊!请相信KyTor吧!
http://www.wengyuanhang.com/
------------------
愿上帝赐我平静,接受我无法改变的事;
愿上帝赐我勇气,改变我能够改变的事;
愿上帝赐我智慧,能明辨这两者的差异;
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 BigSnake.NET » 2006-12-20 19:50

没有apt。。。还有dpkg

用dpkg装apt就可以了。。
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
KyTor
帖子: 222
注册时间: 2006-12-05 22:23
来自: http://www.wengyuanhang.com/
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 KyTor » 2006-12-20 19:54

BigSnake.NET 写了:没有apt。。。还有dpkg

用dpkg装apt就可以了。。

要去下apt包?汗死,哪里有官方的最新版?
虔诚的信徒啊!请相信KyTor吧!
http://www.wengyuanhang.com/
------------------
愿上帝赐我平静,接受我无法改变的事;
愿上帝赐我勇气,改变我能够改变的事;
愿上帝赐我智慧,能明辨这两者的差异;
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#6

帖子 BigSnake.NET » 2006-12-20 19:56

源里有。。。
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
KyTor
帖子: 222
注册时间: 2006-12-05 22:23
来自: http://www.wengyuanhang.com/
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 KyTor » 2006-12-20 20:37

BigSnake.NET 写了:源里有。。。

因为直接删除了apt文件夹,现在用其他的命令更新都无法实现。哪位达人能否给个详细的过程?
虔诚的信徒啊!请相信KyTor吧!
http://www.wengyuanhang.com/
------------------
愿上帝赐我平静,接受我无法改变的事;
愿上帝赐我勇气,改变我能够改变的事;
愿上帝赐我智慧,能明辨这两者的差异;
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#8

帖子 BigSnake.NET » 2006-12-20 20:42

^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
KyTor
帖子: 222
注册时间: 2006-12-05 22:23
来自: http://www.wengyuanhang.com/
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 KyTor » 2006-12-20 21:32

BigSnake.NET 写了:http://ubuntu.cn99.com/ubuntu/pool/main/a/apt/

很多

汗死,事实上需要下载几个重要的包就行了。而且有很多版本,我是不大清楚之间的依赖关系。所以只好慢慢调试,发现只能先装……6.45版本的。否则存在很多依赖关系上的错误。
有一点值得提的是,在ubuntu6.10的光盘中并未找到……/main/a/apt的目录,这一点比较痛苦。(如果有的话我就不用那么辛苦去调试/)
虔诚的信徒啊!请相信KyTor吧!
http://www.wengyuanhang.com/
------------------
愿上帝赐我平静,接受我无法改变的事;
愿上帝赐我勇气,改变我能够改变的事;
愿上帝赐我智慧,能明辨这两者的差异;
回复

回到 “老旧版本支持”