[问题]安装 sun-java5-plugin 时会自动同时安装 Firefox,能否取消Firefox安装?

为当前最终发行版之前的所有版本提供支持
回复
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

[问题]安装 sun-java5-plugin 时会自动同时安装 Firefox,能否取消Firefox安装?

#1

帖子 jimmin » 2006-12-22 6:29

首先说一下我系统是Kubuntu 6.06,用的浏览器是官方下载的Firefox2.0中文版。我按照WIKI里安装JAVA Plugin(我到现在还搞不清楚安装这个有什么用,只是照WIKI里装着,毕竟有备无患),出现如下提示:

jimmin@jimmin-desktop:~$ sudo apt-get install sun-java5-plugin
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
将会安装下列额外的软件包:
firefox

建议安装的软件包:
firefox-gnome-support latex-xft-fonts libthai0
下列【新】软件包将被安装:
firefox sun-java5-plugin
共升级了 0 个软件包,新安装了 2 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 7933kB 的软件包。
解压缩后会消耗掉 23.6MB 的额外空间。
您希望继续执行吗?[Y/n]


可以看到装sun-java5-plugin时它自动强制安装firefox,本来这也没什么,但是我用的是Kubuntu 6.06,6.06的源里只有firefox 1.5版,我安装sun-java5-plugin后firefox1.5也被强制安装。

这样系统里就有firefox2.0和1.5共存,总感觉不放心。而且我也怕无意中启动firefox1.5后 .mozilla 配置文件被改,再用firefox2.0启动会出问题(听说firefox各版本间配置文件最好不共用,可能会出现问题)。

我该怎么办?是放弃装sun-java5-plugin吗?sun-java5-plugin的功能是什么,不装sun-java5-plugin会有什么隐患?
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#2

帖子 jimmin » 2006-12-23 9:22

顶!
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 karron » 2006-12-23 11:34

不用安装.就是让你的浏览器能够看一些java applet而已.现在网页上用java applet的已经很少了.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
ericzb
帖子: 441
注册时间: 2006-11-16 21:34
来自: Bridge View
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 ericzb » 2006-12-25 1:13

先装java runtime
在新利得里装gcjwebplugin

其实不装也没什么。
回复

回到 “老旧版本支持”