当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 输入法僵死,与gnome设置守护进程冲突
帖子发表于 : 2006-12-22 18:13 

注册: 2006-09-18 22:29
帖子: 14
地址: nanjing
送出感谢: 0 次
接收感谢: 0 次
我用的6.10 ,在中文local下安装了im-switch 和fcitx3.31,每次 重新启动后,gnome总是 不正常,在进入创口之前会报错,如下显示:
[quote]启动 GNOME 设置守护进程时出错。

主题、声音或者背景设置等可能不会正常工作。

最后的错误信息是:

Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

GNOME 在您下次登录时仍将试图重启动设置守护进程。[/quote]

进程中总有一个fcitx僵死,另一个是好的。用scim也是这样。请教怎么回事!!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-12-22 18:17 

注册: 2006-09-18 22:29
帖子: 14
地址: nanjing
送出感谢: 0 次
接收感谢: 0 次
另外我安装了im-switch,但是启动后没有这个进程,这个是问题么?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-12-22 20:12 

注册: 2006-09-18 22:29
帖子: 14
地址: nanjing
送出感谢: 0 次
接收感谢: 0 次
up!!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-12-23 9:15 

注册: 2006-10-19 9:02
帖子: 1103
送出感谢: 0 次
接收感谢: 0 次
am1216 写道:
另外我安装了im-switch,但是启动后没有这个进程,这个是问题么?


im-swith不适守护进程,而是输入法切换工具。启动后不会存在这个进程的。与其无关。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-12-23 16:50 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
sudo im-switch -s fcitx做过没有?
守护进程是gnome-settings-manager


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-12-25 9:24 

注册: 2006-09-18 22:29
帖子: 14
地址: nanjing
送出感谢: 0 次
接收感谢: 0 次
楼上的大哥们 ,我 用了 im-switch -s fcitx 也试 过 不用 ,没种情况 下 都会 出现 这个问题,只有remove fcitx和im-
switch 的情况下 ,才会 好,真是郁闷 。。。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-12-25 10:37 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
~/.xsession-errors看下,是否有多些的信息提示。


_________________
● 鸣学


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-12-25 19:58 

注册: 2006-09-18 22:29
帖子: 14
地址: nanjing
送出感谢: 0 次
接收感谢: 0 次
代码:
/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/X11R6/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "am1 216"
/etc/gdm/Xsession: Beginning session setup...
Setting IM through im-switch for locale=zh_CN.
Start IM through /home/am1216/.xinput.d/zh_CN linked to /etc/X11/xinit/xinput.d/fcitx.
SESSION_MANAGER=local/hu:/tmp/.ICE-unix/4440

** (gnome-session:4440): WARNING **: Host name lookup failure on localhost.
Gnome-Message: gnome_execute_async_with_env_fds: returning -1

(gnome-panel:4524): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -3 and height 24


就是 这个消息 ,僵死的问题总是不能 解决 ,不过gnome的冲突我搞明白了 ,不是输入法 的问题,我还是 太菜拉阿


页首
 用户资料  
 
9 楼 
 文章标题 : 我只想让中文输入法正常点儿
帖子发表于 : 2006-12-25 20:44 

注册: 2006-09-23 20:25
帖子: 17
地址: chengdu sichuan
送出感谢: 0 次
接收感谢: 0 次
觉得linux的中文字体支持还是有问题,尤其是对新手和那些试图了解它的中国人来说是这样的。尽管现在中文输入法很完善了,但是仍然有的时候,中文显示失败,本地机器上的输入法也经常僵死。 这让人很尴尬。也许,有解决办法,但是,或许不够醒目。
希望能有朋友指点。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-12-26 14:09 
头像

注册: 2005-12-23 19:20
帖子: 1677
送出感谢: 0 次
接收感谢: 0 次
caspases看了我的 我的也是一樣 一個僵死 一個休眠 我暈 這個輸入法 fcitx


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译