[原创] Stardict 的安装

为当前最终发行版之前的所有版本提供支持
回复
头像
arli
帖子: 194
注册时间: 2006-11-24 11:00
来自: 太阳系第3行星
送出感谢: 0
接收感谢: 0
联系:

[原创] Stardict 的安装

#1

帖子 arli » 2006-12-23 11:48

stardict 要在 windows 下安装,目前只能安装 gtk 2.8.18 环境,更高版本的不行。。
以下重点说在 linux 下的安装:

stardict 已经收费了,几个系统 apt-get、emerge 都找不到了。。我找了好几个源只有2.4.7 版本的,该版本不少词库支持有问题(比如金山、wiki 词库之类的必须要 2.4.8 或以上版本)。。

所以只好自己动手编译安装了,以下是我的安装脚本,供参考,注意里面的路径是我自己下载然后刻盘的,因为文件太多,我分成10个目录,所以有 /media/cdrom/d? 这样的目录,自己改成文件所在路径就可以了(主要不是提供安装脚本,是提供步骤):

代码: 全选

echo ui 库
sudo apt-get install libgnomeui-dev

echo 编译  stardict
sudo mkdir -p /tmp/stardict
cd /tmp/stardict
sudo tar -xjvf /media/cdrom/d1/stardict-2.4.8.tar.bz2
./configure
make
make install
sudo rm -rf /tmp/stardict
echo 编译完成

echo 安装词库
mkdir /usr/local/share/stardict/dic
cd /usr/local/share/stardict/dic

echo 简明英汉词典 ...
sudo tar -xjvf /media/cdrom/d9/stardict-powerword_pwqec-2.4.2.tar.bz2
echo 简明汉英词典 ...
sudo tar -xjvf /media/cdrom/d9/stardict-powerword_pwqce-2.4.2.tar.bz2
echo 中文维基百科 ...
sudo tar -xjvf /media/cdrom/d10/stardict-wikipedia-zhwiki-2.4.2.tar.bz2
echo 牛津现代英汉双解词典 ...
sudo tar -xjvf /media/cdrom/d8/stardict-oxford-gb-2.4.2.tar.bz2
echo 汉字码 ...
sudo tar -xjvf /media/cdrom/d8/stardict-hanzim-2.4.2.tar.bz2
echo 朗道汉英字典 ...
sudo tar -xjvf /media/cdrom/d8/stardict-langdao-ce-gb-2.4.2.tar.bz2
echo 朗道英汉字典 ...
sudo tar -xjvf /media/cdrom/d8/stardict-langdao-ec-gb-2.4.2.tar.bz2
echo 高级汉语大词典 ...
sudo tar -xjvf /media/cdrom/d8/stardict-gaojihanyudacidian-2.4.2.tar.bz2

echo 安装语音
cd /usr/share
sudo tar -xjvf /media/cdrom/d10/WyabdcRealPeopleTTS.tar.bz2
上次由 arli 在 2006-12-23 12:04,总共编辑 2 次。
要爱护linux 就象爱护我们的庄稼地一样
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2006-12-23 11:58

官方欧洲源里有2.4.8的。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
arli
帖子: 194
注册时间: 2006-11-24 11:00
来自: 太阳系第3行星
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 arli » 2006-12-23 12:03

zhuqin_83 写了:官方欧洲源里有2.4.8的。
deb http://archive.ubuntu.com/ubuntu/ edgy main restricted multiverse universe
deb-src http://archive.ubuntu.com/ubuntu/ edgy main restricted multiverse universe
deb http://archive.ubuntu.com/ubuntu/ edgy-updates main restricted multiverse universe
deb http://archive.ubuntu.com/ubuntu/ edgy-proposed restricted main multiverse universe
deb-src http://archive.ubuntu.com/ubuntu/ edgy-proposed restricted main multiverse universe
deb-src http://archive.ubuntu.com/ubuntu/ edgy-updates main restricted multiverse universe

我的 sources.list 里有呀。。奇怪我咋只见到2.4.7 的
要爱护linux 就象爱护我们的庄稼地一样
头像
xiaosilent
帖子: 513
注册时间: 2006-05-09 9:59
来自: 四川成都
送出感谢: 1 次
接收感谢: 0
联系:

#4

帖子 xiaosilent » 2006-12-23 12:44

中文官方源里不是就有 2.4.8 么?

还好,我原来在dapper的时候下的词典的安装包还在....
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#5

帖子 zhuqin_83 » 2006-12-23 13:53

dapper下的中文官方源有,但是不可以用在edgy上。

现在想想不会是加拿大的源吧?
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
xiaosilent
帖子: 513
注册时间: 2006-05-09 9:59
来自: 四川成都
送出感谢: 1 次
接收感谢: 0
联系:

#6

帖子 xiaosilent » 2006-12-23 17:45

zhuqin_83 写了:dapper下的中文官方源有,但是不可以用在edgy上。
词典可以用吧? 我就是在edgy下用的以前dapper下的词典呢。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#7

帖子 zhuqin_83 » 2006-12-24 1:36

我是说主程序不行,确包,字典当然哪里都可以,包括win。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
xiaosilent
帖子: 513
注册时间: 2006-05-09 9:59
来自: 四川成都
送出感谢: 1 次
接收感谢: 0
联系:

#8

帖子 xiaosilent » 2006-12-24 11:00

zhuqin_83 写了:我是说主程序不行,确包,字典当然哪里都可以,包括win。
我理解错误,8好意思, :lol: :lol:
回复

回到 “老旧版本支持”