系统升级出错,Mozzila不能用了

为当前最终发行版之前的所有版本提供支持
lxmzju2000
帖子: 3
注册时间: 2005-05-14 22:06
送出感谢: 0
接收感谢: 0

系统升级出错,Mozzila不能用了

#1

帖子 lxmzju2000 » 2005-10-02 9:43

出错信息如下:

lxm@lixm:~$ sudo apt-get upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
下列的软件包将被升级:
mozilla-firefox mozilla-firefox-gnome-support
共升级了 2 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 0B/8856kB 的软件包。
解压缩后会消耗掉 24.7MB 的额外空间。
您希望继续执行吗?[Y/n]y

Preconfiguring packages ...
(正在读取数据库 ... 系统当前总共安装有 71864 个文件和目录。)
正预备替换 mozilla-firefox 1.0.6-1ubuntu1~5.04ubp1 (使用 .../mozilla-firefox_1.0.7-0ubuntu0.1_i386.deb) ...
正在解压缩将用于更替的包文件 mozilla-firefox ...
dpkg:处理 /var/cache/apt/archives/mozilla-firefox_1.0.7-0ubuntu0.1_i386.deb (--unpack)时出错:
正试图覆盖“/var/lib/mozilla-firefox/extensions.d/00classic”,它属于软件包 firefox
dpkg-deb: 子进程 paste 被信号(断开的管道)终止了
正预备替换 mozilla-firefox-gnome-support 1.0.6-1ubuntu1~5.04ubp1 (使用 .../mozilla-firefox-gnome-support_1.0.7-0ubuntu0.1_i386.deb) ...
正在解压缩将用于更替的包文件 mozilla-firefox-gnome-support ...
dpkg:处理 /var/cache/apt/archives/mozilla-firefox-gnome-support_1.0.7-0ubuntu0.1_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/mozilla-firefox/components/libmozgnome.so”,它属于软件包 firefox-gnome-support
dpkg-deb: 子进程 paste 被信号(断开的管道)终止了
在处理时有错误发生:
/var/cache/apt/archives/mozilla-firefox_1.0.7-0ubuntu0.1_i386.deb
/var/cache/apt/archives/mozilla-firefox-gnome-support_1.0.7-0ubuntu0.1_i386.debE: Sub-process /usr/bin/dpkg returned an error code (1)
雅雅
帖子: 310
注册时间: 2005-05-12 10:08
送出感谢: 0
接收感谢: 0

#2

帖子 雅雅 » 2005-10-02 9:54

你完,你完了。现在firefox1.0.6删不掉,1.0.7又安装不了。firefox又不能用。 :oops: :oops:
头像
gnix_oag
帖子: 1994
注册时间: 2005-05-19 18:38
来自: 湖南永州
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 gnix_oag » 2005-10-02 9:59

这个问题要解决较复杂

先要卸载mozilla-firefox

但卸载不了,(就是因为这个升级)

所以我,把源全部#上

再 sudo apt-get update (这样就没有升级了)

再 sudo apt-get remove firefox

现在再把源中的#去掉,

sudo apt-get update

sudo apt-get install mozilla-firefox mozilla-firefox-gnome-support

也记得不清楚了,试试吧
上次由 gnix_oag 在 2005-10-02 10:04,总共编辑 2 次。
hscui
帖子: 169
注册时间: 2005-09-21 16:26
送出感谢: 0
接收感谢: 0

#4

帖子 hscui » 2005-10-02 10:00

。。。。老大难问题了。。。。。
头像
gnix_oag
帖子: 1994
注册时间: 2005-05-19 18:38
来自: 湖南永州
送出感谢: 0
接收感谢: 1 次
联系:

#5

帖子 gnix_oag » 2005-10-02 10:06

一个图
附件
Screenshot.png
lxmzju2000
帖子: 3
注册时间: 2005-05-14 22:06
送出感谢: 0
接收感谢: 0

#6

帖子 lxmzju2000 » 2005-10-02 10:28

雅雅 写了:你完,你完了。现在firefox1.0.6删不掉,1.0.7又安装不了。firefox又不能用。 :oops: :oops:


是啊,幸亏我还有Opera,还可以上来灌水. :lol:
lxmzju2000
帖子: 3
注册时间: 2005-05-14 22:06
送出感谢: 0
接收感谢: 0

#7

帖子 lxmzju2000 » 2005-10-02 10:39

按照gnix_oag的方法做,在安装的时候出了一堆的错,不过最后firefox居然又可以运行了,匪夷所思。不过运气不错。呵呵
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#8

帖子 eexpress » 2005-10-02 20:43

直接强制删除不行吗。强制版本的那套。
● 鸣学
头像
gnix_oag
帖子: 1994
注册时间: 2005-05-19 18:38
来自: 湖南永州
送出感谢: 0
接收感谢: 1 次
联系:

#9

帖子 gnix_oag » 2005-10-02 21:41

也卸载不了,(就是因为这个升级)
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#10

帖子 eexpress » 2005-10-02 21:58

我的都没有ff。要不我可以测试。我就不信自己的东西不能删除,找文件都要删除它。下载的包也删除。
● 鸣学
雅雅
帖子: 310
注册时间: 2005-05-12 10:08
送出感谢: 0
接收感谢: 0

#11

帖子 雅雅 » 2005-10-02 22:49

eexpress 写了:直接强制删除不行吗。强制版本的那套。


强制删除.那离重装就不远了。 :oops:
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#12

帖子 eexpress » 2005-10-02 23:27

才不会重装列。mozilla能影响多大的访问哦
● 鸣学
芳芳郁金香
帖子: 179
注册时间: 2005-10-06 18:49
送出感谢: 0
接收感谢: 0

#13

帖子 芳芳郁金香 » 2005-10-06 18:54

先说我出现的问题:我装了firefox和它代的Mozilla-firefox还有flash插件
我的解决办法是

先卸载flash插件

之后把上面两个firefox和mozilla-firefox都卸载,

再从新安装mozilla-firefox
芳芳郁金香
帖子: 179
注册时间: 2005-10-06 18:49
送出感谢: 0
接收感谢: 0

#14

帖子 芳芳郁金香 » 2005-10-06 19:00

我的 :P
附件
Screenshot.jpg
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#15

帖子 eexpress » 2005-10-06 19:02

就是。好办法肯定有的。
● 鸣学
回复

回到 “老旧版本支持”