编译mplayer发生的错误

为当前最终发行版之前的所有版本提供支持
回复
crump
帖子: 23
注册时间: 2006-11-12 13:00
送出感谢: 0
接收感谢: 0

编译mplayer发生的错误

#1

帖子 crump » 2006-12-24 9:03

遇到了奇怪的错误,因为想自己编译mplayer。
但是./configure --enable-gui的过程中发生了错误

代码: 全选

Checking for Subtitles sorting ... yes 
Checking for XMMS inputplugin support ... no 
Checking for inet6 ... yes 
Checking for gethostbyname2 ... yes 
Checking for GUI ... yes

Error: The GUI requires PNG support, please install libpng and libpng-dev packages.

Check "configure.log" if you do not understand why it failed.
然后查看configure.log 发现

代码: 全选

============ Checking for PNG support ============

#include <png.h>
#include <string.h>
int main(void) {
  printf("png.h : %s\n", PNG_LIBPNG_VER_STRING);
  printf("libpng: %s\n", png_libpng_ver);
  return (strcmp(PNG_LIBPNG_VER_STRING, png_libpng_ver));
}

cc -O4 -march=prescott -mtune=prescott -pipe -ffast-math -fomit-frame-pointer  -I/usr/include      -lXext -lX11  -lpthread -lXv  -o /tmp/mplayer-conf--31585.o /tmp/mplayer-conf--31585.c -lpng -lz -lm
/usr/bin/ld: cannot find -lXv
collect2: ld returned 1 exit status

ldd /tmp/mplayer-conf--31585.o
ldd: /tmp/mplayer-conf--31585.o: No such file or directory

Result is: no 
但我已经安装了libpng,是从libpng官方下载的libpng-1.2.14,不知道是什么原因导致这种错误。我看了Synaptic Package Manager,里面安装了libpng 12-0, 不知道是不是因为这个冲突?还是说这个 -lXv?如果是的话,该如何解决?
rainofchaos
帖子: 140
注册时间: 2006-10-15 12:59
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 rainofchaos » 2006-12-25 17:15

libpng and libpng-dev
libpng-dev 有么?
头像
spider5
帖子: 351
注册时间: 2005-12-15 21:52
送出感谢: 0
接收感谢: 0

#3

帖子 spider5 » 2006-12-25 19:32

-lXv,libxv.so或者libxv.a,属于libxv-dev包。
回复

回到 “老旧版本支持”