或许--内核配置引发的问题

为当前最终发行版之前的所有版本提供支持
回复
LaoLiulaoliu
帖子: 131
注册时间: 2006-10-25 17:50
来自: 南京
送出感谢: 0
接收感谢: 0
联系:

或许--内核配置引发的问题

#1

帖子 LaoLiulaoliu » 2006-12-24 11:17

我把内核编译了一遍,发现最难且没有东西可以指导的地方是配置。
找了好多地方,发现getoo的还是比较全面的,但没有真正全面的。包括英文在内。
我进到新内核2.6.19.1,发现没有声音,打开一个.mp3的文件,显示错误为:

You do not have a decoder installed to handle this file. You might need to install the necessary plugins.

下载alsa,alsa-driver在make时有错,make install 后,alsa-utisl显示没有make文件,具体如下:

make 错误:
make[1]: *** [hwdep.o] Error 2
make[1]: Leaving directory `/home/lotus/alsa-driver-1.0.8/acore'
make: *** [compile] Error 1

make install错误:
make[2]: *** [conf.lo] Error 1
make[2]: Leaving directory `/home/lotus/alsa-lib-1.0.8/src'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/home/lotus/alsa-lib-1.0.8/src'
make: *** [install-recursive] Error 1

make alsa-utils 显示:
make: *** No targets specified and no makefile found. Stop.

安装nvidia驱动,开机进X时有nvidia显示,但没有glx。
不知道是否在配置内核时出了什么问题,还是能够改过来,还望高手指教。
回复

回到 “老旧版本支持”