用不同版本的源会产生什么问题呢?

为当前最终发行版之前的所有版本提供支持
回复
moonchild
帖子: 116
注册时间: 2005-12-25 20:44
送出感谢: 0
接收感谢: 0

用不同版本的源会产生什么问题呢?

#1

帖子 moonchild » 2006-12-24 14:55

比如5.10用6.06或6.10的源
6.06用6.10或5.10的源

诸如此类

会有什么问题么??

不都是deb包么
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2006-12-24 15:14

deb包大多都是从原码编译的阿,不同的平台有不同的编译环境,还有其他的不同。
所以不一定可行。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
moonchild
帖子: 116
注册时间: 2005-12-25 20:44
送出感谢: 0
接收感谢: 0

#3

帖子 moonchild » 2006-12-24 21:03

除了不同的编译器和不同的lib

还有什么不同啊

应该不会有很大问题吧
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 zhuqin_83 » 2006-12-25 1:47

特别是系统部分,其他的源的就不要考虑了,会让你系统都启动不了。
因为越是新的系统,系统某些部分已经更新了,或者采用和以前不同的方法,如果你这么做的话,一个是依赖关系被破坏,另一个是系统无法正常运行。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
littleUbuntu
帖子: 1103
注册时间: 2006-10-19 9:02
送出感谢: 0
接收感谢: 0

#5

帖子 littleUbuntu » 2006-12-25 7:02

moonchild 写了:除了不同的编译器和不同的lib

还有什么不同啊

应该不会有很大问题吧
你还要多大的问题呢?这样还不够大么?这样就足矣引起系统不稳定,频繁崩溃的可能性。建议不要混用dapper和edgy的源,否则引起以上问题不要再来坛子里报冤Ubuntu系统不稳定,容易崩溃等等无聊的说法。

试想,如果能混用的话何必给你分开弄呢?难道那些程序员和维护着头脑迟钝?
moonchild
帖子: 116
注册时间: 2005-12-25 20:44
送出感谢: 0
接收感谢: 0

#6

帖子 moonchild » 2006-12-28 10:02

恩,检讨一下,我的问题说的不够明白

我当然不是说所有软件都用其它的源来进行安装,只是安装一些小应用软件而已
littleUbuntu 写了: 你还要多大的问题呢?这样还不够大么?这样就足矣引起系统不稳定,频繁崩溃的可能性。建议不要混用dapper和edgy的源,否则引起以上问题不要再来坛子里报冤Ubuntu系统不稳定,容易崩溃等等无聊的说法。
“否则”之后的话让人听了很不舒服
。。。。。。。。。。。。。。。
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 karron » 2006-12-28 13:07

小的东西,依赖少的东西一般没有问题.但是不鼓励.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
qdzheng
帖子: 277
注册时间: 2006-12-03 23:00
送出感谢: 0
接收感谢: 0

#8

帖子 qdzheng » 2006-12-28 13:16

小东西还是下源码自己编译好了。
moonchild
帖子: 116
注册时间: 2005-12-25 20:44
送出感谢: 0
接收感谢: 0

#9

帖子 moonchild » 2006-12-28 15:41

ok

谢谢楼上2位的答复
回复

回到 “老旧版本支持”