[问题]求助(急)执行sudo apt-get update出了点问题,请大家快来帮邦我......

为当前最终发行版之前的所有版本提供支持
回复
plasma2006
帖子: 466
注册时间: 2006-10-19 9:17
送出感谢: 0
接收感谢: 0

[问题]求助(急)执行sudo apt-get update出了点问题,请大家快来帮邦我......

#1

帖子 plasma2006 » 2006-12-26 8:33

我在执行sudo apt-get update后出现这种错误,而后不能更新了,如何解决??请大家帮帮忙,谢谢

正在读取软件包列表... 有错误!
E: Dynamic MMap ran out of room
E: 处理 language-pack-kde-ms-base (NewVersion1)时出错
E: Problem with MergeList /var/lib/apt/lists/cn.archive.ubuntu.com_ubuntu_dists_dapper-updates_main_binary-i386_Packages
E: 无法解析或打开软件包的列表或是状态文件。
plasma2006
帖子: 466
注册时间: 2006-10-19 9:17
送出感谢: 0
接收感谢: 0

#2

帖子 plasma2006 » 2006-12-26 8:42

高手在哪里,请出来帮帮我呀。。。。。。。。。。。
plasma2006
帖子: 466
注册时间: 2006-10-19 9:17
送出感谢: 0
接收感谢: 0

#3

帖子 plasma2006 » 2006-12-26 8:54

而且在sudo apt-get install anysoft都会出现这个错误
呜呜,如何解决........................
等待呀。。。。。。。。。。。。
头像
TualatriX
帖子: 359
注册时间: 2006-11-17 20:07
来自: 杭州/宁波
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 TualatriX » 2006-12-26 9:01

Problem with MergeList /var/lib/apt/lists/cn.archive.ubuntu.com_ubuntu_dists_dapper-updates_main_binary-i386_Packages


大概是你的软件列表出问题了。
具体我也不知道怎么弄,你换个源试试。
IMTX:http://imtx.cn/

LDCN(已经关闭):http://linuxdesktop.cn/

Ubuntu Tweak:http://ubuntu-tweak.com/
头像
spider5
帖子: 351
注册时间: 2005-12-15 21:52
送出感谢: 0
接收感谢: 0

#5

帖子 spider5 » 2006-12-26 9:11

其实大家不用想得太复杂,干掉它就行了

sudo rm /var/lib/apt/lists/[filename]
头像
spider5
帖子: 351
注册时间: 2005-12-15 21:52
送出感谢: 0
接收感谢: 0

#6

帖子 spider5 » 2006-12-26 9:17

忘了说,删除后update一下。
purewind
帖子: 452
注册时间: 2006-11-18 15:40
送出感谢: 0
接收感谢: 0

#7

帖子 purewind » 2006-12-26 9:47

跟我昨晚一样,照着5楼的办,好使!
把不能用的源赶紧删掉,或者禁用,然后重新update
plasma2006
帖子: 466
注册时间: 2006-10-19 9:17
送出感谢: 0
接收感谢: 0

#8

帖子 plasma2006 » 2006-12-26 11:02

原来如此,真的感谢各位高人。让我来试一试。
在此感谢
purewind
帖子: 452
注册时间: 2006-11-18 15:40
送出感谢: 0
接收感谢: 0

#9

帖子 purewind » 2006-12-27 1:25

太脆弱了,今天又来了一次。
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#10

帖子 skyx » 2006-12-27 11:16

ubuntu从6.06通地apt-get已经升级到了6.10 ,

我的看法是,国内的源很多东东没有,只有国外才有。
回复

回到 “老旧版本支持”