昨晚从6.10升级到7.04了.

为当前最终发行版之前的所有版本提供支持
回复
blackwolf
帖子: 12
注册时间: 2006-12-21 12:02
送出感谢: 0
接收感谢: 0

昨晚从6.10升级到7.04了.

#1

帖子 blackwolf » 2006-12-30 15:59

昨天晚上将我的u6.10升级到7.04了.
sudo gedit /etc/apt/source.list
搜索所有的edgy,替换成feisty.
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
重启一切正常,没出现不能启动或不能进X的现象.
到现在为止发现的一个问题:
在apt-get upgrade或dist-upgrade时,gnome-app-install总是出错.

代码: 全选

正在设置 gnome-app-install (0.3.1) ...
Caching application data...
Traceback (most recent call last):
  File "/usr/sbin/update-app-install", line 69, in ?
    generate_cache()
  File "/usr/sbin/update-app-install", line 49, in generate_cache
    menu.createMenuCache(options.cache_dir)
  File "/usr/lib/python2.4/site-packages/AppInstall/CoreMenu.py", line 28, in createMenuCache
    menu = xdg.Menu.parse(os.path.abspath(os.path.join(self.menudir, "applications.menu")))
  File "/var/lib/python-support/python2.4/xdg/Menu.py", line 516, in parse
    __parse(doc, filename, tmp["Root"])
  File "/var/lib/python-support/python2.4/xdg/Menu.py", line 537, in __parse
    __parseMenu(child, filename, parent)
  File "/var/lib/python-support/python2.4/xdg/Menu.py", line 691, in __parseMenu
    __parse(child, filename, m)
  File "/var/lib/python-support/python2.4/xdg/Menu.py", line 586, in __parse
    __parseDefaultMergeDirs(child, filename, parent)
  File "/var/lib/python-support/python2.4/xdg/Menu.py", line 762, in __parseDefaultMergeDirs
    __parseMergeDir(os.path.join(dir, "menus", basename + "-merged"), child, filename, parent)
  File "/var/lib/python-support/python2.4/xdg/Menu.py", line 755, in __parseMergeDir
    __mergeFile(os.path.join(value, item), child, parent)
  File "/var/lib/python-support/python2.4/xdg/Menu.py", line 791, in __mergeFile
    __parse(child,filename,parent)
  File "/var/lib/python-support/python2.4/xdg/Menu.py", line 537, in __parse
    __parseMenu(child, filename, parent)
  File "/var/lib/python-support/python2.4/xdg/Menu.py", line 693, in __parseMenu
    parent.addSubmenu(m)
  File "/var/lib/python-support/python2.4/xdg/Menu.py", line 170, in addSubmenu
    submenu += newmenu
  File "/var/lib/python-support/python2.4/xdg/Menu.py", line 79, in __add__
    self.addSubmenu(submenu)
  File "/var/lib/python-support/python2.4/xdg/Menu.py", line 170, in addSubmenu
    submenu += newmenu
  File "/var/lib/python-support/python2.4/xdg/Menu.py", line 79, in __add__
    self.addSubmenu(submenu)
  File "/var/lib/python-support/python2.4/xdg/Menu.py", line 169, in addSubmenu
    if submenu == newmenu:
  File "/var/lib/python-support/python2.4/xdg/Menu.py", line 88, in __eq__
    if self.Name == str(other):
UnicodeEncodeError: 'ascii' codec can't encode characters in position 14-17: ordinal not in range(128)
dpkg:处理 gnome-app-install (--configure)时出错:
 子进程·post-installation script·返回了错误号·1

dpkg:依赖关系问题使得 ubuntu-desktop 的配置工作不能继续:
 ubuntu-desktop 依赖于 gnome-app-install;然而:
  软件包 gnome-app-install 还没有被配置。
dpkg:处理 ubuntu-desktop (--configure)时出错:
 依赖关系问题 - 仍未被配置

在处理时有错误发生:
 gnome-app-install
 ubuntu-desktop
E: Sub-process /usr/bin/dpkg returned an error code (1)
blackwolf
帖子: 12
注册时间: 2006-12-21 12:02
送出感谢: 0
接收感谢: 0

#2

帖子 blackwolf » 2006-12-30 16:26

还有两个问题,wine的ie不能用了,在地址栏里面打任何东西都是乱码。
vmware workstation 装不上了。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2006-12-30 19:22

wine用老版本。我的连edgy代的wine都不好用的。
● 鸣学
xiechy
帖子: 1074
注册时间: 2006-01-18 15:01
送出感谢: 0
接收感谢: 1 次

#4

帖子 xiechy » 2006-12-31 8:15

vmware要对应的内核版本。自己看看下面的lib就好了。你可以用老的内核,新的周边。gnome-app我没有你的问题,但我后来把它删掉了。gnome用的很少。
ygmvla
帖子: 82
注册时间: 2006-11-12 9:39
来自: 湖南祁阳
送出感谢: 0
接收感谢: 0

#5

帖子 ygmvla » 2006-12-31 13:24

呵,我看你升级 不是很成功哟,自己慢慢配置算了吧~
weiboo
帖子: 19
注册时间: 2006-10-27 20:06
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 weiboo » 2007-01-01 21:45

终端输入 sudo dpkg --configure -a
试一下应该可以
头像
chieftain
帖子: 175
注册时间: 2006-02-18 22:53
来自: 啊里不吐纳星球
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 chieftain » 2007-01-04 15:39

版本更新的好快 :o
Don't talk to me about life!
Yo! It's me.
wzhpro
帖子: 53
注册时间: 2006-09-24 9:28
送出感谢: 0
接收感谢: 0

#8

帖子 wzhpro » 2007-02-13 19:36

我和楼主一样
不知道怎么解决
wzhpro
帖子: 53
注册时间: 2006-09-24 9:28
送出感谢: 0
接收感谢: 0

#9

帖子 wzhpro » 2007-02-13 22:42

blackwolf 写了:还有两个问题,wine的ie不能用了,在地址栏里面打任何东西都是乱码。
vmware workstation 装不上了。
我wine的ie正常
vm在设置c header的时候出了点问题,没有继续下去
wzhpro
帖子: 53
注册时间: 2006-09-24 9:28
送出感谢: 0
接收感谢: 0

#10

帖子 wzhpro » 2007-02-14 23:09

I run
sudo apt-get clean
sudo apt-get update
sudo apt-get dist-grade
today, and the problem was fixed
jasper
帖子: 50
注册时间: 2007-02-04 19:39
来自: Delft, The Netherlands
送出感谢: 0
接收感谢: 0

#11

帖子 jasper » 2007-02-15 7:23

最早装ubuntu的时候 edgy正在测试,我就直接装了edgy
这次准备等feisty出正式版了,再升级。
现在的edgy我弄得好用得很。
wh0608
帖子: 28
注册时间: 2006-12-04 3:26
送出感谢: 0
接收感谢: 0

#12

帖子 wh0608 » 2007-02-22 21:08

我也遇到了这样的问题,不过第一条是acpid依赖关系问题。。。。。还有很多?
于是我把acpi acpid都卸载了,再重新安装ubuntu-desktop问题解决。
依窗吻风
帖子: 85
注册时间: 2006-04-20 12:12
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 依窗吻风 » 2007-02-23 2:07

eexpress 写了:wine用老版本。我的连edgy代的wine都不好用的。
正解!我把wine锁定版本了 :em06
回复

回到 “老旧版本支持”