flashplayer9+firefox解决方案

为当前最终发行版之前的所有版本提供支持
回复
solin_y
帖子: 7
注册时间: 2006-11-30 10:29
送出感谢: 0
接收感谢: 0

flashplayer9+firefox解决方案

#1

帖子 solin_y » 2007-01-01 13:01

ubuntu的firefox默认安装的是flashplayer7插件,以至于不能播放网页上的很多flash影片。
通过上网搜集资料以及自己的努力,终于实现了flashplayer9+firefox的完美接合。

首先在网上搜索下载文件FP9_plugin_beta_101806.tar.gz,可以登临如下网站:
http://www.adobe.com/go/fp9_update_b1_i ... inuxplugin
然后执行命令:
tar xvzf FP9_plugin_beta_101806.tar.gz
cd flash-player-plugin-9.0.21.55
sudo rm /usr/lib/firefox/plugins/*flash*
sudo cp libflashplayer.so /usr/lib/firefox/plugins/

可是在中文环境下,关闭Flash页面会出现段错误,会导致firefox自动关闭。所以要想完美使用flashplayer9,必须先切换到英文环境,然后再用命令大开firefox:
export LANG=en_GB.UTF-8
firefox &

这样虽然已经实现了正常使用firefox,但是每次都要打开命令终端进行设置,比较麻烦,所以本人做了一些配置加以改进。
首先在创建一个可执行文件firefox.sh:
touch firefox.sh
chmod +x firefox.sh
vi firefox.sh

下面是文件内容:
#!/bin/sh
export LANG="en_GB.UTF-8"
firefox &
其实就两行,呵呵,实现了自动配置的过程,不过还没结束呢,好戏还在后头呢。
在ubuntu的“应用程序-Internet”下面以及面板上有一个firefox的图形起动快捷方式,下面我依次将上面的创建的可执行文件应用到它们中去,这样每次只要电击图标,就可以实现自动配置了,这样就和原来打开firefox一样。
第一步,修改面板快捷方式
1. 选到面板上的firefox图标然后电击右键,选择属性一栏。
2. 系统会弹出一个提示框,在提示框的“命令(A)“项输入可执行文件firefox.sh的完整路径即可(我的文件放在自己的home目录下所以就是/home/solin/firefox.sh)。
第二步,修改“应用程序-Internet”快捷方式
1. 在命令终端中执行命令:sudo vi /usr/share/applications/firefox.desktop
2. 找到里面的”Exec=firefox %u“行,并将之改成”Exec=/home/solin/firefox.sh“,然后保存

到此,全部工作就结束了。
虽然小菜,也希望对大家有帮助。
头像
ipv6now
帖子: 759
注册时间: 2006-09-30 1:08
来自: QingDao
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 ipv6now » 2007-01-01 13:59

试了这个方法,firefox打开有flash的页面然后关闭标签,确实不会崩溃了
我的firefox是从官网下的2.0.0.1,本来就靠脚本启动,只要加一行就行了。哈哈
头像
ipv6now
帖子: 759
注册时间: 2006-09-30 1:08
来自: QingDao
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 ipv6now » 2007-01-01 14:00

以后可以放心用flash9了,原来都adblock,迫不得已才disable adblock
头像
rouchen888
帖子: 55
注册时间: 2006-11-30 17:13
送出感谢: 0
接收感谢: 0

#4

帖子 rouchen888 » 2007-01-02 0:37

我也要试下,谢谢楼主提供的方法!!
头像
rouchen888
帖子: 55
注册时间: 2006-11-30 17:13
送出感谢: 0
接收感谢: 0

#5

帖子 rouchen888 » 2007-01-02 0:55

这样的话firefox不就是英文的了吗?
头像
ipv6now
帖子: 759
注册时间: 2006-09-30 1:08
来自: QingDao
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 ipv6now » 2007-01-02 1:19

还是中文的,现在为止,只发现一种变化
访问ftp服务器时,原来的文件上传时间显示都是×年×月×日,现在是 日/月/年
例如 原来的2006年12月30日,现在显示为30/12/2006
头像
paul
帖子: 510
注册时间: 2005-09-01 20:48
送出感谢: 0
接收感谢: 0

#7

帖子 paul » 2007-01-02 3:07

恩,这方法不错,可惜我昨天刚把flash plugin换成7的,9的不停崩溃,不修改一下还真没法用。
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#8

帖子 jimmin » 2007-01-02 11:36

楼主说的是修改

代码: 全选

export LANG="en_GB.UTF-8" 
可我看其它人说的是修改

代码: 全选

export XLIB_SKIP_ARGB_VISUALS=1
这两种有什么不同吗?
头像
rouchen888
帖子: 55
注册时间: 2006-11-30 17:13
送出感谢: 0
接收感谢: 0

#9

帖子 rouchen888 » 2007-01-02 11:37

我的怎么改完后,启动起来是英文的菜单啊?
头像
rouchen888
帖子: 55
注册时间: 2006-11-30 17:13
送出感谢: 0
接收感谢: 0

#10

帖子 rouchen888 » 2007-01-02 12:27

不管怎么弄都 是英文的,没办法把配置文件删除,还用原来的FLASH7。
这个命令:export LANG="en_GB.UTF-8,难道不是切换到英文环境了吗,怎么还会是中文的呢,不明白。
换成FLASH7,用新建的firefox.sh启动是英文的,在命令行下执行就是中文的。
solin_y
帖子: 7
注册时间: 2006-11-30 10:29
送出感谢: 0
接收感谢: 0

#11

帖子 solin_y » 2007-01-04 13:24

换成英文环境,当然只能用英文了。不过偶觉得中英文都无所谓,只要网页能正常显示中文就行了。
头像
jackphil
帖子: 59
注册时间: 2006-09-04 23:49
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 jackphil » 2007-01-04 21:54

rouchen888 写了:我的怎么改完后,启动起来是英文的菜单啊?
试试这个
export LC_MESSAGES=zh_CN.utf8
头像
ipv6now
帖子: 759
注册时间: 2006-09-30 1:08
来自: QingDao
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 ipv6now » 2007-01-04 22:34

别用系统带的那个,自己去官网下载个中文版的,想变成英文都变不了
lisir
帖子: 1187
注册时间: 2006-04-29 14:54
来自: 山东
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 lisir » 2007-01-05 22:49

这样上网,可以输入中文吗?至少我根据楼主的步骤操作,发现无法使用fcitx输入中文(当然我下的是从楼主提供的网址转过去下载的,不过与楼主的不太一样,是http://download.macromedia.com/pub/labs/flashplayer9_update/FP9_plugin_beta_112006.tar.gz,应该是比楼主说的新,说是修正了一些bug)。
后来我直接使用firefox启动,也就是没使用export LANG="en_GB.UTF-8" ,就可以输入中文了。不知道scim有没有这问题?

我现在使用这个flash9可以正常显示新浪博客首页,不过在闪客帝国上看flash时,无法听到声音,不知是怎么回事。
===============================================

后来发现使用的不是9而是7,在地址栏输入about:plugins可以发现虽然已经将那个so文件拷贝到/usr/lib/firefox/plugins下,但在firefox中还是7,也就是并没有使用那个文件,这也许是我自己安装firefox的缘故。后来我将文件拷贝到~.mozilla/plugins下,就可以看到是9了,这时可以在闪客帝国上看flash听到声音,但如果不使用export LANG="en_GB.UTF-8"这一句就容易退出。看来是难以两 全了,我就在面板上建了两 个firefox的图标,想用那个用哪个。
学会看置顶帖、精华帖。
学会使用搜索。
常见问题解答和发帖需知
回复

回到 “老旧版本支持”