[分享]IBM ThinPad T60B14 安装手记

为当前最终发行版之前的所有版本提供支持
回复
haitau
帖子: 8
注册时间: 2006-11-21 17:03
来自: shenzhen,guandong,china
送出感谢: 0
接收感谢: 0
联系:

[分享]IBM ThinPad T60B14 安装手记

#1

帖子 haitau » 2007-01-01 18:10

在vmware上已经用了一段时间的ubuntu,这次因为windows xp上购买的正版杀毒软件服务到期,同时开发工作(web开发)也基本在linux环境下进行(centos+apache+tomcat+mysql+eclipse),所以下定决心抛弃windows。

使用自己刻录的6.10的live cd,安装时选中文,分区等等一次过,没有碰到难点。网上说对sata硬盘要先在bios中启用兼容模式才能找到硬盘,但我没有,ubuntu好像直接就认到。

安装完成后,相应的thinkpad一些功能键,如音量调节,屏幕亮度调节,键盘灯,这些应该是直接控制硬件的,所以没有问题。声卡也直接找到驱动装上了,modem也直接装上。

其他硬件,无线网卡暂时用不上,最先要解决的就是显卡驱动,在没有安装驱动前,试图通过修改/etc/X11/xorg.conf来修改分辨率,重新启动后,进不了图形界面,在grup启动界面,按esc,选第二项,boot进入命令行,把配置文件修改回去,重新启动,OK!

这时在[初学者园地]找到的文章“[分享]6.10下的ati驱动安装 12.26.更新”帮了大忙,按照文章中所讲,成功装上了ati(x1400)驱动(我用的是从ati网站上下载来的驱动)。分辨率上去了,也没了拖屏。

这个时候之前一些人提到过的openoffice不能启动的问题我也遇到,只能按照前人的经验,修改xorg.conf中最后自己加的一段section,将值从0改为1,重新启动,ok!
Section "Extensions"
Option "Composite" "1"
EndSection

然后按照各位大侠讲的装了各种常用软件和wqy字体,并一一试用,之间碰到一个问题,无法重现,当时在运行的程序很多,有amule,firefox,终端,Azureus等,硬盘灯狂闪,界面僵死,只能按电源重起。但这个现象之后再没遇到过。不知道当时怎么了。

还有装了flashplugin-nonfree之后,firefox崩溃的问题,最好的方法就是不装这个,通过firefox自己去装flash插件。如果已经装了,除了彻底卸载外,还要删除目录中/usr/lib/mozila/plugins/中的所有的*flash*.so,然后通过firefox上网安装。

现在,已经基本可用了,现在还有些问题要慢慢去解决,当然,如果有人提出解决方法就感激不尽了:
1、cdma1x无线上网,很不幸我没有选用华为等有linux驱动的无线上网卡,而用的是vtion(网讯的v1810),在网上找驱动,没找到,但发现网讯公司在招人做linux驱动。估计我是等不到了。
只有看看这个http://docs.chinalinuxpub.com/read.php?wid=1229文章中讲的有没有用了。

2、有些网站必须要用到ie,如招商的网上银行。只能用wine或vmware来解决了。

3、在安装过程中,一直在用usb鼠标,结果在ubuntu启动过程中就一定要将usb鼠标接上,不然就半路死在那里,要按电源重起。当时也是搞了半天,重起n次,才找到这个毛病。
haitau
帖子: 8
注册时间: 2006-11-21 17:03
来自: shenzhen,guandong,china
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 haitau » 2007-01-01 18:16

对了,在源中找到一些thinkpad的工具,有人用过么,怎么用?找不到说明文档,装了好象没起任何效果。
atery
帖子: 38
注册时间: 2006-08-06 14:49
送出感谢: 0
接收感谢: 0
联系:

Re: [分享]IBM ThinPad T60B14 安装手记

#3

帖子 atery » 2007-01-01 18:55

haitau 写了:相应的thinkpad一些功能键,如音量调节,屏幕亮度调节,键盘灯,这些应该是直接控制硬件的,所以没有问题。

3、在安装过程中,一直在用usb鼠标,结果在ubuntu启动过程中就一定要将usb鼠标接上,不然就半路死在那里,要按电源重起。当时也是搞了半天,重起n次,才找到这个毛病。
恭喜恭喜,我用的是T43 :roll: . 那些功能键应该是要驱动的,直接就能用是因为ubuntu内核带了IBM THINKPAD的按键驱动.我的无线网卡直接就驱动了,可能T60系列换网卡了? 还有那个USB鼠标,你在xorg.conf里面设置了鼠标吗?我的是罗技的我按照官方论坛设置好了就会像你的情况那样.我觉得不方便,有时要拿着电脑到处跑,所以我就吧设置改回默认的,这个问题就不出现了. 源里有很多IBM程序吗?我记得就是tpb吧,你 man tpb看看就知道了,就是OSD显示那些功能按键.
Frankie
帖子: 7
注册时间: 2006-11-11 22:05
送出感谢: 0
接收感谢: 0

#4

帖子 Frankie » 2007-01-01 19:02

Section "Extensions"
Option "Composite" "1"
EndSection
设置为1后,就无法打开显卡的硬件加速了。我用的是安装源里的驱动。

我用的也是t60b14

我把oo完全卸载之后,再重新安装就没有问题了

华为的cdma上网卡也没有驱动的,ec321就是,直接用wvdial设置就可以了。
haitau
帖子: 8
注册时间: 2006-11-21 17:03
来自: shenzhen,guandong,china
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 haitau » 2007-01-01 19:16

Frankie 写了:
我把oo完全卸载之后,再重新安装就没有问题了

华为的cdma上网卡也没有驱动的,ec321就是,直接用wvdial设置就可以了。
怎么完全卸载OO???不知道有哪些组件,在新立德里面把所有oo相关的选项选上后,点应用提示有错误。卸不了啊。

还有wvdia怎么设置??我怎么不行??详细讲讲,谢谢了
craftsh
帖子: 3
注册时间: 2006-12-17 17:43
送出感谢: 0
接收感谢: 0

#6

帖子 craftsh » 2007-01-01 20:51

HOHO,偶的也是B14,不过现在还在vmware里先练练再说
daniums
帖子: 118
注册时间: 2006-12-15 21:55
来自: 重庆
送出感谢: 0
接收感谢: 0

#7

帖子 daniums » 2007-01-01 22:06

我是T42的机器,好像不需要专门的驱动吧。就是显示器的刷新率只有50HZ,没有win里面高啊,不知道有问题没有?
头像
Xtire
帖子: 188
注册时间: 2005-09-11 14:08
来自: N朝古都
送出感谢: 0
接收感谢: 0

#8

帖子 Xtire » 2007-01-03 17:31

偶的也是B14哈哈,水嘀 :lol:
安装6.06没有遇到一点问题,一直在用。以后多交流。 :D
yjhlly
帖子: 1
注册时间: 2007-01-03 19:53
送出感谢: 0
接收感谢: 0

#9

帖子 yjhlly » 2007-01-03 20:37

我的也是t43,但无线网卡驱动不起来啊,能看到,但怎么都上不了网
fjchenq
帖子: 160
注册时间: 2006-12-14 19:14
送出感谢: 0
接收感谢: 0

#10

帖子 fjchenq » 2007-01-03 20:57

我把flash插件删除,firefox就不会出现经常退出!
头像
syhan
帖子: 272
注册时间: 2006-09-06 12:24
来自: Southeast University
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 syhan » 2007-01-04 12:03

我是用的t43,功能键直接在System--》Preference--》Keyboard Shortcut里面改就可以了
awesome + stalonetrayer + urxvt + rox-filer + feh + SLiM
回复

回到 “老旧版本支持”