今天晚上升级了一下ubuntu(6.10->7.04)(成功)

为当前最终发行版之前的所有版本提供支持
weiboo
帖子: 19
注册时间: 2006-10-27 20:06
送出感谢: 0
接收感谢: 0
联系:

今天晚上升级了一下ubuntu(6.10->7.04)(成功)

#1

帖子 weiboo » 2007-01-01 21:51

sudo gedit /etc/apt/source.list
把所有的edgy,替换成feisty.
sudo apt-get update
sudo apt-get upgrade
执行完之后
sudo dpkg --configure -a
sudo apt-get dist-upgrade

这样就可以了
不过可能有个别软件冲突
自己在synaptic里面把冲突的软件删除
再重装一遍就ok了
希望大家也能升级成功
lucker6666
帖子: 27
注册时间: 2006-10-27 10:54
送出感谢: 0
接收感谢: 0

#2

帖子 lucker6666 » 2007-01-01 22:05

历害 不过暂时没必要阿 用的好好的
plasma2006
帖子: 466
注册时间: 2006-10-19 9:17
送出感谢: 0
接收感谢: 0

#3

帖子 plasma2006 » 2007-01-04 18:35

我还在用6.06呢,大家都用7.04了
哈哈
plasma2006
帖子: 466
注册时间: 2006-10-19 9:17
送出感谢: 0
接收感谢: 0

#4

帖子 plasma2006 » 2007-01-04 18:42

能否从6.06升级到7.04呢???????????
头像
KyTor
帖子: 222
注册时间: 2006-12-05 22:23
来自: http://www.wengyuanhang.com/
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 KyTor » 2007-01-04 19:19

我没有成功,汗死……
虔诚的信徒啊!请相信KyTor吧!
http://www.wengyuanhang.com/
------------------
愿上帝赐我平静,接受我无法改变的事;
愿上帝赐我勇气,改变我能够改变的事;
愿上帝赐我智慧,能明辨这两者的差异;
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#6

帖子 skyx » 2007-01-05 0:12

sudo apt-get dist-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在筹划升级... 失败
下列的软件包有不能满足的依赖关系:
openoffice.org-l10n-en-gb: 冲突: openoffice.org-core (>= 2.0.4.1) 但是 2.1-1ubuntu1 正要被安装
openoffice.org-l10n-en-za: 冲突: openoffice.org-core (>= 2.0.4.1) 但是 2.1-1ubuntu1 正要被安装
openoffice.org-l10n-ja: 冲突: openoffice.org-core (>= 2.0.4.1) 但是 2.1-1ubuntu1 正要被安装
openoffice.org-l10n-ko: 冲突: openoffice.org-core (>= 2.0.4.1) 但是 2.1-1ubuntu1 正要被安装
openoffice.org-l10n-zh-cn: 冲突: openoffice.org-core (>= 2.0.4.1) 但是 2.1-1ubuntu1 正要被安装
openoffice.org-l10n-zh-tw: 冲突: openoffice.org-core (>= 2.0.4.1) 但是 2.1-1ubuntu1 正要被安装
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的

从6.10升级可能是我的源里少了什么, 我把提示中的带2.1的全部remove掉后还是这样的提示,想尝鲜都不让啊。
用原来ghost的6.06升级也是上面的提示,楼主把你用的源帖出来吧。
上次由 skyx 在 2007-01-05 0:14,总共编辑 1 次。
no security measure is worth anything if an attacker has physical access to the machine
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#7

帖子 eexpress » 2007-01-05 0:14

KyTor 写了:我没有成功,汗死……
一般在月圆之夜,宝石的能量会发挥到最大,成功率才高。
● 鸣学
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#8

帖子 skyx » 2007-01-05 9:27

一般在月圆之夜
把herd1的iso get下来用iso做源还是升不了,不过还是升级了一点点

sudo apt-cdrom -m -d /cdrom add

现把 /cdrom/ 作为了 CD-ROM 的挂载点
正在鉴别.. [c12ec2aea9fab8529691d9caf40d87de-2]
正在光盘中查找索引文件..
Found 2 package indexes, 0 source indexes, 0 translation indexes and 1 signatures
Found label 'Ubuntu 7.04 _Feisty Fawn_ - Alpha i386 (20061204)'
这张光盘现在的名字是:
“Ubuntu 7.04 _Feisty Fawn_ - Alpha i386 (20061204)”
正在复制软件包列表……gpgv: 于 2006年12月04日 星期一 16时43分21秒 CST 创建的签字,使用 DSA,钥匙号 FBB75451
gpgv: 完好的签字,来自于“Ubuntu CD Image Automatic Signing Key <cdimage@ubuntu.com>”
Reading Package Indexes... 完成
正在写入新的软件包源列表
对应于该光盘的软件包源设置项是:
deb cdrom:[Ubuntu 7.04 _Feisty Fawn_ - Alpha i386 (20061204)]/ feisty main restricted
请对您的光盘套件中的其它光盘重复相同的操作。








sudo apt-get dist-upgrade
sudo apt-get update
忽略 cdrom://Ubuntu 7.04 _Feisty Fawn_ - Alpha i386 (20061204) feisty/main Translation-zh_CN
忽略 cdrom://Ubuntu 7.04 _Feisty Fawn_ - Alpha i386 (20061204) feisty/restricted Translation-zh_CN
正在读取软件包列表... 完成
/etc/apt$ sudo apt-get dist-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在筹划升级... 完成
下列的软件包的版本将保持不变:
g++ g++-4.1 libc6-dev libstdc++6-4.1-dev
下列的软件包将被升级:
dpkg-dev linux-libc-dev
共升级了 2 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 4 个软件未被升级。
需要下载 0B/801kB 的软件包。
解压缩后将会空出 1094kB 的空间。
您希望继续执行吗?[Y/n]


然后还是这样,没办法了
sudo apt-get dist-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在筹划升级... 失败
下列的软件包有不能满足的依赖关系:
openoffice.org-l10n-en-gb: 冲突: openoffice.org-core (>= 2.0.5) 但是 2.1-1ubuntu1 正要被安装
openoffice.org-l10n-en-za: 冲突: openoffice.org-core (>= 2.0.5) 但是 2.1-1ubuntu1 正要被安装
openoffice.org-l10n-zh-cn: 冲突: openoffice.org-core (>= 2.0.5) 但是 2.1-1ubuntu1 正要被安装
openoffice.org-l10n-zh-tw: 冲突: openoffice.org-core (>= 2.0.5) 但是 2.1-1ubuntu1 正要被安装
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的
no security measure is worth anything if an attacker has physical access to the machine
头像
ct
帖子: 2201
注册时间: 2005-04-06 21:15
来自: 安徽黄山
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 ct » 2007-01-06 17:09

把那几个包先删了再升级啊,应该是OOo的中文化还没到2.10吧.
我觉得feisty已经很稳定了,不过可惜我这里有的程序不能以sudo或gksudo方式启动,比如nautilus,gdmsetup.

我的帐号用ff很难登录上,靠,极度痛苦,konqueror却可以,晕.
头像
haige
帖子: 315
注册时间: 2006-03-16 16:29
送出感谢: 0
接收感谢: 0

#10

帖子 haige » 2007-01-06 18:04

weiboo
你用的哪个源升到7.04了
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 zhan » 2007-01-06 18:53

eexpress 写了:
KyTor 写了:我没有成功,汗死……
一般在月圆之夜,宝石的能量会发挥到最大,成功率才高。
哈哈。。
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#12

帖子 skyx » 2007-01-06 22:26

ct 写了:把那几个包先删了再升级啊,应该是OOo的中文化还没到2.10吧.
我觉得feisty已经很稳定了,不过可惜我这里有的程序不能以sudo或gksudo方式启动,比如nautilus,gdmsetup.

我的帐号用ff很难登录上,靠,极度痛苦,konqueror却可以,晕.
是删了啊,把原来用ghost备份的6.06升级提示也是那样的提示,从6.10升级提示也是如此。

花了一晚上下载了iso,没有光驱,没法升级,也没法从硬盘安装!!!
no security measure is worth anything if an attacker has physical access to the machine
weiboo
帖子: 19
注册时间: 2006-10-27 20:06
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 weiboo » 2007-01-07 13:59

我用的是上海交大的源:

deb http://ftp.sjtu.edu.cn/ubuntu/ feisty main multiverse restricted universe
deb http://ftp.sjtu.edu.cn/ubuntu/ feisty-backports main multiverse restricted universe
deb http://ftp.sjtu.edu.cn/ubuntu/ feisty-proposed main multiverse restricted universe
deb http://ftp.sjtu.edu.cn/ubuntu/ feisty-security main multiverse restricted universe
deb http://ftp.sjtu.edu.cn/ubuntu/ feisty-updates main multiverse restricted universe
deb-src http://ftp.sjtu.edu.cn/ubuntu/ feisty main multiverse restricted universe
deb-src http://ftp.sjtu.edu.cn/ubuntu/ feisty-backports main multiverse restricted universe
deb-src http://ftp.sjtu.edu.cn/ubuntu/ feisty-proposed main multiverse restricted universe
deb-src http://ftp.sjtu.edu.cn/ubuntu/ feisty-security main multiverse restricted universe
deb-src http://ftp.sjtu.edu.cn/ubuntu/ feisty-updates main multiverse restricted universe

还有我用的是ubuntu的gnome桌面

祝你好运!!
上次由 weiboo 在 2007-01-07 14:06,总共编辑 1 次。
weiboo
帖子: 19
注册时间: 2006-10-27 20:06
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 weiboo » 2007-01-07 14:03

其实升级完后还是有很多的小问题
比如好多原来的软件程序不能用
有些连接,快捷方式,菜单选项不能用
需要自己再重新配置
头像
TualatriX
帖子: 359
注册时间: 2006-11-17 20:07
来自: 杭州/宁波
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 TualatriX » 2007-01-07 16:04

我还是再等四个月等正式版本发布吧。
IMTX:http://imtx.cn/

LDCN(已经关闭):http://linuxdesktop.cn/

Ubuntu Tweak:http://ubuntu-tweak.com/
回复

回到 “老旧版本支持”