[原创] firefox 安装 flashplayer 9 官版

为当前最终发行版之前的所有版本提供支持
回复
头像
arli
帖子: 194
注册时间: 2006-11-24 11:00
来自: 太阳系第3行星
送出感谢: 0
接收感谢: 0
联系:

[原创] firefox 安装 flashplayer 9 官版

#1

帖子 arli » 2007-01-03 7:28

保存成任意名.sh 执行它就行了

代码: 全选

#!/bin/bash

mkdir -p /tmp/mftmp
cd /tmp/mftmp 

wget --referer=http://www.adobe.com/go/fp9_update_b2_installer_linuxplugin http://download.macromedia.com/pub/labs/flashplayer9_update/FP9_plugin_beta_112006.tar.gz

tar xvf FP9_plugin_beta_112006.tar.gz
cd flash-player-plugin-9.0.21.78
mkdir -p ~/.mozilla/plugins/
cp libflashplayer.so ~/.mozilla/plugins/

cd ~
rm -rf /tmp/mftmp
要爱护linux 就象爱护我们的庄稼地一样
yohu
帖子: 955
注册时间: 2006-12-18 17:04
来自: 福建泉州
送出感谢: 0
接收感谢: 1 次

#2

帖子 yohu » 2007-01-03 8:07

今天你挂了没? :P

昨天特地装了nonfree,结果果然如大家所说的,动不动就挂掉了,还是自带的好,软件不在新,好用就行。
wucongkun
帖子: 251
注册时间: 2006-11-10 20:27
送出感谢: 0
接收感谢: 0

#3

帖子 wucongkun » 2007-01-03 8:11

我直接用apt 安装 non free的
不知道是7还是9
没有出现问题啊
purewind
帖子: 452
注册时间: 2006-11-18 15:40
送出感谢: 0
接收感谢: 0

#4

帖子 purewind » 2007-01-03 8:20

有些网站只支持最新版,新浪的blog就是
Liir
帖子: 3
注册时间: 2007-01-03 2:49
送出感谢: 0
接收感谢: 0

#5

帖子 Liir » 2007-01-03 15:16

感谢~如果想卸载新版的怎么做呢?
头像
arli
帖子: 194
注册时间: 2006-11-24 11:00
来自: 太阳系第3行星
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 arli » 2007-01-03 15:51

Liir 写了:感谢~如果想卸载新版的怎么做呢?
把~/.mozilla/plugins/ 里的文件删掉

我上面的脚本安装的只有一个文件,官方预编译的,我用了它 flash9 很正常。。

至于源里的版本要视 sources.list 文件而定,有加上cn99 的无视签名的那些更新,就可能装的是9 否则只有7

可以在播放flash 时右击会提示版本的

不管如何,推荐按顶楼下载官版的9,就只有一个已编译的文件,简单易用,至少我用的很正常

至于9的好处是有不少的flash 是9 做的(特别是国内的,国外如YouTube都是7),否则用7要么不显示要么没声音
要爱护linux 就象爱护我们的庄稼地一样
Venusxx
帖子: 91
注册时间: 2006-12-08 23:11
送出感谢: 0
接收感谢: 0

#7

帖子 Venusxx » 2007-01-03 19:41

我的是edgy+FF 2.0,用了这个仍然是崩溃……只好又换回flash7
无论多么艰难的现在,终是记忆和过去
头像
ct
帖子: 2201
注册时间: 2005-04-06 21:15
来自: 安徽黄山
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 ct » 2007-01-03 20:27

很关注这个问题,看来这次我又不用再尝试了,楼上的朋友已经牺牲过了。谢谢 :lol:
回复

回到 “老旧版本支持”