6.06依赖问题

为当前最终发行版之前的所有版本提供支持
回复
头像
oydl82
帖子: 1073
注册时间: 2006-09-04 21:38
来自: 中国沙大
送出感谢: 0
接收感谢: 0
联系:

6.06依赖问题

#1

帖子 oydl82 » 2007-01-03 15:27

那天FF突然退出,于是就想把edubuntu6.10里的ff2.0装上去,所以把光盘里面的libnspr4_1.firefox2.0+0dfsg-0ubuntu3_i386.deb和libnss3_1.firefox2.0+0dfsg-0ubuntu3_i386.deb两个包给安装上去了,后来发现一些东东不能用了,用apt-get install firefox一看,出错了,按提示运行apt-get -f install也无法解决,提示如下:
oydl82@oydl82-computer:~$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 失败。
下列的软件包有不能满足的依赖关系:
firefox-gnome-support: 依赖: libc6 (>= 2.4-1) 但是 2.3.6-0ubuntu20 已经安装了
依赖: libglib2.0-0 (>= 2.12.0) 但是 2.10.2-1ubuntu3 已 经安装了
依赖: libgnomevfs2-0 (>= 2.15.90) 但是 2.14.1-0ubuntu8 已经安装了
依赖: libgtk2.0-0 (>= 2.10.3) 但是 2.8.17-1ubuntu5 已经安装了
依赖: libstdc++6 (>= 4.1.1-12) 但是 4.0.3-1ubuntu5 已经安装了
依赖: firefox (= 2.0+0dfsg-0ubuntu3) 但是它还没有被安装 libnspr4: 依赖: libc6 (>= 2.4-1) 但是 2.3.6-0ubuntu20 已经安装了
libnss3: 依赖: libc6 (>= 2.4-1) 但是 2.3.6-0ubuntu20 已经安装了
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的 缘故。
E: 无法更正依赖关系
回复

回到 “老旧版本支持”