[问题]dubuntu 编译问题.

为当前最终发行版之前的所有版本提供支持
回复
lw7254062
帖子: 42
注册时间: 2006-12-16 22:51
送出感谢: 0
接收感谢: 0
联系:

[问题]dubuntu 编译问题.

#1

帖子 lw7254062 » 2007-01-05 11:40

因为旧的核心对硬件的支持不是太好,所以想升内核..在编译开始就出现这样了不知道如何解决...本人是新手..望高手指点下,帮小弟解决.

root@dubuntu:/linux/linux# make xconfig
CHECK qt
*
* Unable to find the QT installation. Please make sure that
* the QT development package is correctly installed and
* either install pkg-config or set the QTDIR environment
* variable to the correct location.
*
sed < scripts/kconfig/lkc_proto.h > scripts/kconfig/lkc_defs.h 's/P(\([^,]*\),.*/#define \1 (\*\1_p)/'
HOSTCC scripts/kconfig/kconfig_load.o
make[1]: *** 没有规则可以创建“scripts/kconfig/qconf.o”需要的目标“scripts/kconfig/.tmp_qtcheck”。 停止。
make: *** [xconfig] 错误 2
yohu
帖子: 955
注册时间: 2006-12-18 17:04
来自: 福建泉州
送出感谢: 0
接收感谢: 1 次

#2

帖子 yohu » 2007-01-05 13:16

参考一下 http://www.ubuntuforums.org/showthread.php?t=157560 ,我就是参考这个来编译的,非常顺利。你可能没装一些开发包。

代码: 全选

sudo apt-get install build-essential bin86 kernel-package libqt3-headers libqt3-mt-dev
lw7254062
帖子: 42
注册时间: 2006-12-16 22:51
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 lw7254062 » 2007-01-05 13:51

我的那个系统装不上网卡驱动我才想升级的...我想用不了那个 apt-get ..还有你那个网址为什么打不开 :shock:
yohu
帖子: 955
注册时间: 2006-12-18 17:04
来自: 福建泉州
送出感谢: 0
接收感谢: 1 次

#4

帖子 yohu » 2007-01-05 14:59

那可能你那边的国际网络还没恢复吧,呵呵,找一下光盘里面看看有没有这几个包,如果没有去http://packages.ubuntu.com/ 找,上不去找个代理上吧。
回复

回到 “老旧版本支持”