[问题]大件事:apt-get不能用了~libmac2和mac包冲突导致

为当前最终发行版之前的所有版本提供支持
回复
头像
felixlu
帖子: 311
注册时间: 2006-11-25 15:27
来自: SZ
送出感谢: 0
接收感谢: 0
联系:

[问题]大件事:apt-get不能用了~libmac2和mac包冲突导致

#1

帖子 felixlu » 2007-01-08 16:50

不知自己哪条筋短路,装了mac又还去选libmac2的包来安装,结果就这样了。
在新立得里面无法取消libmac的标记,老是提示、而且修复也无法进行下去……
sudo apt-get install -f
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在更正依赖关系... 完成
The following packages were automatically installed and are no longer required:
dmsetup
使用 'apt-get autoremove' 来删除它们。
将会安装下列额外的软件包:
libmac2
下列【新】软件包将被安装:
libmac2
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 4 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/65.7kB 的软件包。
解压缩后会消耗掉 193kB 的额外空间。
您希望继续执行吗?[Y/n]y
【警告】:下列的软件包不能通过验证!
libmac2
不经验证就安装这些软件包么?[y/N] y
(正在读取数据库 ... 系统当前总共安装有 105546 个文件和目录。)
正在解压缩 libmac2 (从 .../libmac2_3.99-u4-b5-1~6.10mlk1_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/libmac2_3.99-u4-b5-1~6.10mlk1_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/libmac.so.2.0.0”,它属于软件包 mac
在处理时有错误发生:
/var/cache/apt/archives/libmac2_3.99-u4-b5-1~6.10mlk1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
NoteBook: IBM X40 (1G Hz, 1.25GB, 20G+120GB)
Desktop: APU A6-3670, MSI A75A-G55, 4GB DDR3 1600 x 2
Slackware64 + Win7
头像
felixlu
帖子: 311
注册时间: 2006-11-25 15:27
来自: SZ
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 felixlu » 2007-01-08 19:41

自己顶一下,麻烦给个解决办法,谢谢~
NoteBook: IBM X40 (1G Hz, 1.25GB, 20G+120GB)
Desktop: APU A6-3670, MSI A75A-G55, 4GB DDR3 1600 x 2
Slackware64 + Win7
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2007-01-08 19:48

aptitude试试。黄河边上还有dselect可以呢。删除一个先。
● 鸣学
littleUbuntu
帖子: 1103
注册时间: 2006-10-19 9:02
送出感谢: 0
接收感谢: 0

#4

帖子 littleUbuntu » 2007-01-08 20:00

用dselect删除掉一个
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 hualang0929 » 2007-01-08 20:01

我也试过这样,把出错的那个包删除了之后就可以了
抬头望星空一片晴,我独行,夜已渐寒……
头像
felixlu
帖子: 311
注册时间: 2006-11-25 15:27
来自: SZ
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 felixlu » 2007-01-08 20:05

谢谢!我打开了aptitude,但不知道怎么删除,结果只好又退出去……
突然想到它有提示这是为满足依赖关系而被自动选上的包,
所以把依赖它的Audacious-mac包给删掉,
然后就可以取消这个该死的libmac2了、现在终于正常了,呵呵
吓得我以为昨天刚装的系统现在又要重装呢^o^
NoteBook: IBM X40 (1G Hz, 1.25GB, 20G+120GB)
Desktop: APU A6-3670, MSI A75A-G55, 4GB DDR3 1600 x 2
Slackware64 + Win7
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#7

帖子 eexpress » 2007-01-09 1:00

aptitude在依赖和包管理方面就是强很多的。
别重装,后面还有dselect呢。
● 鸣学
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 SuperWar3Fan » 2007-01-09 16:04

Ubuntu有的时候确实神经错乱,搞的人神经衰弱。。
回复

回到 “老旧版本支持”