[问题]安装声卡驱动在alsaconf里找不到,怎么办?

为当前最终发行版之前的所有版本提供支持
回复
头像
felixlu
帖子: 311
注册时间: 2006-11-25 15:27
来自: SZ
送出感谢: 0
接收感谢: 0
联系:

[问题]安装声卡驱动在alsaconf里找不到,怎么办?

#1

帖子 felixlu » 2007-01-08 22:09

从Realtek网站下载了新的声卡驱动,想升级,
按说明运行安装脚本install的时候它先把我原有的驱动删掉了,
安装过程中一闪而过的信息看到有什么找不到makefile之类的出错提示,
最后一步也没有弹出alsaconf来。
后来想到中间提示的有些目录是在/root下面的,
所以就启用了root用户,用更改用户来登录的时候就登录不了了。
出错提示说找不到一个什么lib~~没能记下来,看名字就是跟声卡驱动有关的东东。
万万没有想到升级失败也会搞到登录不了这么大件事,郁闷。
现在是用另一个系统了,除了重装Ubuntu,还有什么办法可以修复吗?
/bow
上次由 felixlu 在 2007-01-09 1:23,总共编辑 1 次。
NoteBook: IBM X40 (1G Hz, 1.25GB, 20G+120GB)
Desktop: APU A6-3670, MSI A75A-G55, 4GB DDR3 1600 x 2
Slackware64 + Win7
头像
felixlu
帖子: 311
注册时间: 2006-11-25 15:27
来自: SZ
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 felixlu » 2007-01-09 1:23

搞了半天,死活不行……
装了一个build-essential包和n个库以后,可以编译安装驱动了
但是最后在alsaconf里面还是找不到声卡~郁闷
没有声音,就这样用几天再说,实在没有办法也只能重装,呵呵
NoteBook: IBM X40 (1G Hz, 1.25GB, 20G+120GB)
Desktop: APU A6-3670, MSI A75A-G55, 4GB DDR3 1600 x 2
Slackware64 + Win7
头像
felixlu
帖子: 311
注册时间: 2006-11-25 15:27
来自: SZ
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 felixlu » 2007-01-09 1:41

有没有办法让系统自己重新检测我的硬件呢?
在WIKI里看到这个说明,但是照做以后重启,跟不做之前没有什么区别啊,呵呵
是不是还漏了个什么步骤呢?
我怎样才能回到硬件检测 (prob/probing/re-probe)?

* 在第二阶段安装时,Ubuntu 检测了您的硬件和设定了X 。如果您改变了显卡、声卡甚至显示器, 您可能需要再做这。 这样处理:- 'apt-get --purge remove xserver-xfree86' 对于最新版, 这样处理: 'apt-get --purge remove xserver-xorg'
NoteBook: IBM X40 (1G Hz, 1.25GB, 20G+120GB)
Desktop: APU A6-3670, MSI A75A-G55, 4GB DDR3 1600 x 2
Slackware64 + Win7
lisir
帖子: 1187
注册时间: 2006-04-29 14:54
来自: 山东
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 lisir » 2007-01-09 9:08

按说明运行安装脚本install的时候
你有没有在前面加上sudo (注意sudo后面有空格),因为一般安装驱动时,都会安装到home外的其它目录,那些目录你作为普通用户无法写的,所以要以超级用户的身份来执行,也就是在命令前加上“sudo ”,而不是让你重起以root登录。
我怎样才能回到硬件检测 (prob/probing/re-probe)?

* 在第二阶段安装时,Ubuntu 检测了您的硬件和设定了X 。如果您改变了显卡、声卡甚至显示器, 您可能需要再做这。 这样处理:- 'apt-get --purge remove xserver-xfree86' 对于最新版, 这样处理: 'apt-get --purge remove xserver-xorg'
你这样已经把xserver-xorg这个负责显示的给删除 了,当然无法正常登录了,如果你只是安装声卡驱动你不用这样做的!
你现在先把xserver-xorg再重新安装上,在字符界面下用你的普通用户名登录后

代码: 全选

sudo apt-get install xserver-xorg
(它会跟你要密码的,就是你登录用的密码)
使用sudo shutdown -r now重起。
看看能否进入图形界面。
能进去后,再按前面说的,在驱动安装程序前加上sudo 来安装声卡驱动。
学会看置顶帖、精华帖。
学会使用搜索。
常见问题解答和发帖需知
lisir
帖子: 1187
注册时间: 2006-04-29 14:54
来自: 山东
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 lisir » 2007-01-09 9:13

随着你对Linux的理解,你重装系统的机会会越来越少,重装系统来解决问题,是在Windows下养成的习惯,我原来也这样。
要养成在修改配置文件前先备份的习惯。这样如果出问题,也可以直接恢复。
学会看置顶帖、精华帖。
学会使用搜索。
常见问题解答和发帖需知
头像
felixlu
帖子: 311
注册时间: 2006-11-25 15:27
来自: SZ
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 felixlu » 2007-01-10 17:08

呵呵,我本来就是在sudo的情况下执行安装的
现在图形界面没有问题了

唯一没有解决的就是声卡依旧在alsaconf里面找不到
用Realtek的驱动包手动一个个安装,可以完成,但alsaconf检测不到声卡
用alsa上面下载的驱动安装,结果同上。

现在我想知道的就是:有没有不用重装的办法可以让Ubuntu像在全新安装系统的时候一样重新检测我的硬件?
NoteBook: IBM X40 (1G Hz, 1.25GB, 20G+120GB)
Desktop: APU A6-3670, MSI A75A-G55, 4GB DDR3 1600 x 2
Slackware64 + Win7
回复

回到 “老旧版本支持”