[问题]安装nvidia官方驱动.rum失败

为当前最终发行版之前的所有版本提供支持
jun.hunter
帖子: 13
注册时间: 2007-01-12 11:16
送出感谢: 0
接收感谢: 0

[问题]安装nvidia官方驱动.rum失败

#1

帖子 jun.hunter » 2007-01-12 11:40

安装完kubuntu 6.10后,启动时出现了nvidia的logo
启动到kde下,发现屏幕分辨率只有1024x768,而我的显卡和lcd在win下可以到1680x1050
于是进入控制中心调整分辨率,发现最多只支持到1024x768
只好下载了官方的最新的驱动NVIDIA-Linux-x86-1.0-9746-pkg1.run
在kde控制台下sudo sh NVIDIA-Linux-x86-1.0-9746-pkg1.run
提示必须在console下安装,于是重启导文本控制台下执行。
安装结束后,重新启动系统,发现进入不了kde
在控制台下startkde
提示的错误大致如下:
NVIDIA kernel module 1.0_7184
But X module has 1.0_9746

问题:
首先,如何让ubuntu库中的驱动程序支持1680x1050的分辨率?
其次,手工安装官方的驱动失败,该如何解决我出现的错误?

我以前用的比较多的是FC+xfce,所以对kde下的菜单的配置工具不熟,
最好给出命令行的解决方式。
谢谢了
orchia2000
帖子: 107
注册时间: 2006-12-06 1:17
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 orchia2000 » 2007-01-12 12:15

想知道原因吗?我可以告诉你。
sudo apt-get install linux-headers-$(uname -r) build-essential
edgy已经安装好了最新的gcc了,没有装的,自己装上

sudo gedit /etc/default/linux-restricted-modules-common
在最后的双引号里面添加nv两个字,添加后就是“nv”

还有,有时候系统自动升级内核,可能进不了GUI,在文本字符下再安装一边驱动就行了。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2007-01-12 12:25

官方驱动,那种run的。最好别搞。源的nvidia-glx可以用。svn的驱动也是紧跟潮流的。论坛都说明了。

要不等什么1万美元筹款的版本出来再说。
● 鸣学
jun.hunter
帖子: 13
注册时间: 2007-01-12 11:16
送出感谢: 0
接收感谢: 0

#4

帖子 jun.hunter » 2007-01-12 12:25

linux的头文件已经安装好了
gcc make pkcofig等等都是具备的
楼上说的第一点应该不是原因

估计是第二点的缘故
回去试试看
请问第二点中的那个配置文件是做什么的?

谢谢了:)
jun.hunter
帖子: 13
注册时间: 2007-01-12 11:16
送出感谢: 0
接收感谢: 0

#5

帖子 jun.hunter » 2007-01-12 12:29

eexpress 写了:官方驱动,那种run的。最好别搞。源的nvidia-glx可以用。svn的驱动也是紧跟潮流的。论坛都说明了。

要不等什么1万美元筹款的版本出来再说。
关键是用源的nvidia-glx没有办法设置到我需要的分辨率: 1680x1050
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 karron » 2007-01-12 12:33

你尝试自己手动杂xorg.conf里面添加你要的分辨率看看.注意添加到 24位部分.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#7

帖子 eexpress » 2007-01-12 12:40

jun.hunter 写了:
eexpress 写了:官方驱动,那种run的。最好别搞。源的nvidia-glx可以用。svn的驱动也是紧跟潮流的。论坛都说明了。

要不等什么1万美元筹款的版本出来再说。
关键是用源的nvidia-glx没有办法设置到我需要的分辨率: 1680x1050
就楼上说的。我以为你源的不行呢。
● 鸣学
jun.hunter
帖子: 13
注册时间: 2007-01-12 11:16
送出感谢: 0
接收感谢: 0

#8

帖子 jun.hunter » 2007-01-12 12:46

karron 写了:你尝试自己手动杂xorg.conf里面添加你要的分辨率看看.注意添加到 24位部分.
装完系统后就试过了
不行才去下载官方驱动的
头像
5451vs5451
帖子: 345
注册时间: 2006-07-14 18:56
来自: Apple Valley, Planet Tux, Linux System
送出感谢: 0
接收感谢: 0

#9

帖子 5451vs5451 » 2007-01-12 12:49

jun.hunter 写了: 提示的错误大致如下:
NVIDIA kernel module 1.0_7184
But X module has 1.0_9746
我碰到过同样的问题。先把nvidia-glx和linux-restricted-modules卸载掉,再安装官方驱动就好了。
官方驱动装好后,运行nvidia-settings改变分辨率。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#10

帖子 eexpress » 2007-01-12 12:50

你把其他的分辨率都删除,就保留1680x1050呢?全部位深都这样设置。要不,就没办法了。之前要干净恢复源的驱动。
● 鸣学
jun.hunter
帖子: 13
注册时间: 2007-01-12 11:16
送出感谢: 0
接收感谢: 0

#11

帖子 jun.hunter » 2007-01-12 12:52

5451vs5451 写了:
jun.hunter 写了: 提示的错误大致如下:
NVIDIA kernel module 1.0_7184
But X module has 1.0_9746
我碰到过同样的问题。先把nvidia-glx和linux-restricted-modules卸载掉,再安装官方驱动就好了。
官方驱动装好后,运行nvidia-settings改变分辨率。
谢谢,回去就试试看
不晓得装好后能不能上1680x1950
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#12

帖子 eexpress » 2007-01-12 12:56

如果是卸载restricted-modules,不如lz直接使用svn的驱动。一并把beryl的事情都解决了。
● 鸣学
jun.hunter
帖子: 13
注册时间: 2007-01-12 11:16
送出感谢: 0
接收感谢: 0

#13

帖子 jun.hunter » 2007-01-12 13:00

eexpress 写了:如果是卸载restricted-modules,不如lz直接使用svn的驱动。一并把beryl的事情都解决了。
svn的驱动如何装?
给个参考
谢谢了
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#14

帖子 eexpress » 2007-01-12 13:06

# deb http://amaranth.selfip.com edgy lrm #nvidia-beta

不推荐的。论坛有很多帖子说明了svn的(都是beryl惹的祸)。因为svn的都要动内核,安装有次序,如果你使用386内核倒是好。如果使用generic或者smp内核,会强制使用386内核的。还有一点,就是svn版本安装以后,和源的更新就有些牵扯,因为这样超出了源的包版本的范围。

论坛应该还有其他的svn的地址和说明,先看哦。我现在都不用这个了。可能有更好的,新的安全的svn的地址。

所以,建议先试试简单的修改xorg.conf。
● 鸣学
jun.hunter
帖子: 13
注册时间: 2007-01-12 11:16
送出感谢: 0
接收感谢: 0

#15

帖子 jun.hunter » 2007-01-12 13:19

eexpress 写了:# deb http://amaranth.selfip.com edgy lrm #nvidia-beta

不推荐的。论坛有很多帖子说明了svn的(都是beryl惹的祸)。因为svn的都要动内核,安装有次序,如果你使用386内核倒是好。如果使用generic或者smp内核,会强制使用386内核的。还有一点,就是svn版本安装以后,和源的更新就有些牵扯,因为这样超出了源的包版本的范围。

论坛应该还有其他的svn的地址和说明,先看哦。我现在都不用这个了。可能有更好的,新的安全的svn的地址。

所以,建议先试试简单的修改xorg.conf。
谢谢了
在论坛里找到了这个
viewtopic.php?t=30638
准备回去试试看

以前用的fc,后来用了hiweed觉得不错(简洁明快)
但是在家里hiweed的livecd上不了网,装到机器上后还是上不了
于是装了kubuntu
准备装好了驱动之类的就安装xfce4,不用kde了
回复

回到 “老旧版本支持”