[问题]oo2问题请教!(已解决,谢谢关注)

为当前最终发行版之前的所有版本提供支持
回复
gj7548
帖子: 142
注册时间: 2006-10-19 15:22
送出感谢: 0
接收感谢: 0

[问题]oo2问题请教!(已解决,谢谢关注)

#1

帖子 gj7548 » 2007-01-12 17:24

现在oo2.1终于运行正常了,原来是目录的权限设置错误。谢谢大家关注!
现在oo2.1终于可以运行 了,但仍有问题,就是不能以普通身份运行,有如下提示:
[Java framework] Error in function createUserSettingsDocument (elements.cxx).javaldx failed!
[Java framework] Error in function createUserSettingsDocument (elements.cxx).InsertFromHorizontalBitmap - empty image!
是不是java的什么权限设置不够,用sudo 能够运行,请各位继续关注指教!
/usr/lib/openoffice/program/soffice.bin: symbol lookup error: /usr/lib/openoffice/program/libvclplug_gtk680li.so: undefined symbol: _ZN10SalDisplayC2EP9_XDisplaym

** (process:10646): WARNING **: Unknown error forking main binary / abnormal early exit ...

feisty oo2.1 文字处理、电子表格运行时均出现上述提示,已用更新管理器升级不,知何故,请高手指点!
上次由 gj7548 在 2007-01-24 14:34,总共编辑 3 次。
gj7548
帖子: 142
注册时间: 2006-10-19 15:22
送出感谢: 0
接收感谢: 0

#2

帖子 gj7548 » 2007-01-16 11:21

我是用新立得安装的呀,问题仍未解决,高手请指点,附strace如下:
@ubuntu:~$ sudo strace ooffice -calc
Password:
waitpid(-1, /usr/lib/openoffice/program/soffice.bin: symbol lookup error: /usr/lib/openoffice/program/libvclplug_gtk680li.so: undefined symbol: _ZN10SalDisplayC2EP9_XDisplaym

** (process:17861): WARNING **: Unknown error forking main binary / abnormal early exit ...
[{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0) = 17861
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
--- SIGCHLD (Child exited) @ 0 (0) ---
waitpid(-1, 0xbfc08418, WNOHANG) = -1 ECHILD (No child processes)
sigreturn() = ? (mask now [])
rt_sigaction(SIGINT, {SIG_DFL}, {0x807f470, [], 0}, 8) = 0
rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
read(255, "", 77) = 0
exit_group(0) = ?
Process 17860 detached
上次由 gj7548 在 2007-01-22 14:37,总共编辑 1 次。
xiechy
帖子: 1074
注册时间: 2006-01-18 15:01
送出感谢: 0
接收感谢: 1 次

#3

帖子 xiechy » 2007-01-16 17:01

dapper?edgy?feisty?
oo的版本?有没有自己编译?什么都不说……
gj7548
帖子: 142
注册时间: 2006-10-19 15:22
送出感谢: 0
接收感谢: 0

谢谢回复!

#4

帖子 gj7548 » 2007-01-19 10:55

楼上说的是。我用的是 feisty ,oo是2.1版本用新立得安装的,请指教!
我已经用更新管理器升级到最新了,还是不行,不知何故?
谢谢指教!
Linux ubuntu 2.6.20-2-386 #3 Sat Dec 16 12:21:12 UTC 2006 i686 GNU/Linux
xiechy
帖子: 1074
注册时间: 2006-01-18 15:01
送出感谢: 0
接收感谢: 1 次

#5

帖子 xiechy » 2007-01-19 16:25

dist-upgrade了吗?还有没有edgy的old的包?
你的内核是不是自己编译的?

从出错的说明看像是函数连接的符号找不到~~
gj7548
帖子: 142
注册时间: 2006-10-19 15:22
送出感谢: 0
接收感谢: 0

谢谢xiechy

#6

帖子 gj7548 » 2007-01-19 16:53

我是直接装的feisty 安装的是oo2.0,后更新升级时老提示oo升级失败,我就用dpkg删除了openoffice的包,然后用新立得升级到2.10的,出现上面提示,请指教!
估计是符号连接的错误,可能是哪个库的版本不对,但新立得也没查出是哪个依赖问题,不知如何查找相关库文件?
xiechy
帖子: 1074
注册时间: 2006-01-18 15:01
送出感谢: 0
接收感谢: 1 次

#7

帖子 xiechy » 2007-01-19 19:00

在packages.ubuntulinux.org可以查什么文件属于什么包。

找到后aptitude reinstall吧.
dogal
帖子: 900
注册时间: 2006-11-23 13:04
送出感谢: 0
接收感谢: 0

#8

帖子 dogal » 2007-01-20 0:02

看晕了
gj7548
帖子: 142
注册时间: 2006-10-19 15:22
送出感谢: 0
接收感谢: 0

谢谢帮助!

#9

帖子 gj7548 » 2007-01-22 8:56

现在更新管理器升级到最新后,运行OO2.10提示如下:
(process:5109): Gdk-CRITICAL **: gdk_screen_get_font_options: assertion `GDK_IS_SCREEN (screen)' failed
InsertFromHorizontalBitmap - empty image!

(process:5109): Gdk-CRITICAL **: gdk_screen_get_font_options: assertion `GDK_IS_SCREEN (screen)' failed
没有以前的错误提示了,请各位不吝指教!
附件
Screenshot.png
出现如图窗口提示。。
gj7548
帖子: 142
注册时间: 2006-10-19 15:22
送出感谢: 0
接收感谢: 0

哈,能运行了,但仍有问题请教?

#10

帖子 gj7548 » 2007-01-22 9:22

用新立得重新安装oo 组件,用sudo 能运行,但菜单栏吕文全变成了方框,提示
Gdk-CRITICAL **: gdk_screen_get_font_options: assertion `GDK_IS_SCREEN (screen)' failed
截图如下,请各位继续关注指教!
附件
Screenshot.png
错误及出错信息截图。。
回复

回到 “老旧版本支持”