[分享]安装nvidia-glx提示依赖nvidia-kernel-1.0.9631无法安装的完美解决

为当前最终发行版之前的所有版本提供支持
头像
felixlu
帖子: 311
注册时间: 2006-11-25 15:27
来自: SZ
送出感谢: 0
接收感谢: 0
联系:

[分享]安装nvidia-glx提示依赖nvidia-kernel-1.0.9631无法安装的完美解决

#1

帖子 felixlu » 2007-01-13 0:02

楼主1.14更新:本楼的方法纯属巧合,真正的解决方法在3楼


刚装的Edgy,第一次进系统就先改国内的源后直接安装驱动,
提示缺少一个依赖的包(名字太长没记下来),无法完成。
我在重装系统之前先备份了apt本地缓存的所有安装包,找到下面这两个:
linux-image-2.6.17-10-386_2.6.17.1-10.34_i386.deb
linux-restricted-modules-2.6.17-10-386_2.6.17.6-2~release.lupine1_i386.deb
现在手动把它们装上去,重启选择386(不要用默认的generic了)进入系统,
然后再用新立得选nvidia-glx,可以顺利安装了~~哈哈
可是…………怎么我重启X后,
NV的LOGO还是没有出现、刷新率也没有变、屏幕仍然闪得人头晕?
真XX郁闷,白高兴一场了,驱动居然还是没有装上……?!
不死心的我就干脆死马当作活马医了,
把我重装系统之前备份的xorg.conf恢复回去,
重启X_哈哈,TNND这该死的NV驱动总算装好了,beryl也正常~~开心ing

我也只是无意中发现的,今晚就为这个破显卡驱动装了2次系统(第一次我先下载了NV官方的run文件安装,结果进不了X,后来再用上面说的方法安装成功,可惜beryl用不了,足以证明NV官方的run果然如某位DX说的一样不适合用在Ubuntu上~),到底为什么会这样就请各位大侠解释一下了,呵呵~
上次由 felixlu 在 2007-01-14 1:25,总共编辑 2 次。
NoteBook: IBM X40 (1G Hz, 1.25GB, 20G+120GB)
Desktop: APU A6-3670, MSI A75A-G55, 4GB DDR3 1600 x 2
Slackware64 + Win7
orchia2000
帖子: 107
注册时间: 2006-12-06 1:17
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 orchia2000 » 2007-01-13 0:27

duo kan kan luntan liman de wenzhang .
头像
felixlu
帖子: 311
注册时间: 2006-11-25 15:27
来自: SZ
送出感谢: 0
接收感谢: 0
联系:

安装nvidia-glx提示依赖nvidia-kernel-1.0.9631无法安装的完美解决

#3

帖子 felixlu » 2007-01-14 1:18

呵呵,楼上的意思是不是说我装完驱动后忘了执行sudo nvidia-xconfig呢?
这个当时确实是忘了……所以才导致要自己手动替换原来的xorg.conf的,汗自己一个先~

再来说说显卡驱动的完美解决方法:
昨天那样搞好以后、为了搞清楚真正能解决问题的方法,
做好GHOST备份后我就把系统又还原到装显卡驱动之前,
直接安装nvidia-glx提示依赖这个虚拟包:nvidia-kernel-1.0.9631
google之后才在这里
http://packages.ubuntulinux.org/feisty/ ... l-1.0.9631
发现这个虚拟包实际上是由Linux 2.6.20 modules的相关包提供的,
我选择了最新的linux-restricted-modules-2.6.20-5-generic这个包来试,
同时还要下载它所依赖的linux-image-2.6.20-5-generic、linux-restricted-modules-common_2.6.20.1-6_all。
把它们一一装上去以后、重启并选择新装的2.6.20-5进入系统以后,就可以顺利地装上nvidia-glx了,呵呵
最后记得sudo nvidia-xconfig更新一下xorg.conf,别像我昨晚一样忘了:)
用了一天,试过关机、重启都没有再出现进不了X的现象了,所有软件也都已经更新,不会再有影响。

有提到遇到这个问题的相关主题:
viewtopic.php?t=37440
viewtopic.php?t=37192

上面提到的那3个包的下载地址:
http://archive.ubuntu.org.cn/ubuntu/poo ... 7_i386.deb
http://archive.ubuntu.org.cn/ubuntu/poo ... 6_i386.deb
http://archive.ubuntu.org.cn/ubuntu/poo ... -6_all.deb
上次由 felixlu 在 2007-01-18 9:47,总共编辑 1 次。
NoteBook: IBM X40 (1G Hz, 1.25GB, 20G+120GB)
Desktop: APU A6-3670, MSI A75A-G55, 4GB DDR3 1600 x 2
Slackware64 + Win7
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#4

帖子 skyx » 2007-01-14 12:36

实际上楼主又改回去了, 升级时用upgrde,少用dist-upgrad就不会有什么问题,实在是要用dist-upgrade,注意提示信息,小心就没事了
no security measure is worth anything if an attacker has physical access to the machine
头像
zhuangzl
帖子: 78
注册时间: 2006-12-28 13:03
送出感谢: 0
接收感谢: 0

#5

帖子 zhuangzl » 2007-01-15 10:32

按照三楼的方法装了,但进不了桌面了 !郁闷ING,已经重装了三次系统了,还是装不上驱动!
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#6

帖子 BigSnake.NET » 2007-01-15 19:52

開機時多了些無關痛癢的錯誤提示。。。另外把我的hda認成sda了。。

湊合著用吧。。
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
felixlu
帖子: 311
注册时间: 2006-11-25 15:27
来自: SZ
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 felixlu » 2007-01-16 9:54

skyx 写了:实际上楼主又改回去了, 升级时用upgrde,少用dist-upgrad就不会有什么问题,实在是要用dist-upgrade,注意提示信息,小心就没事了
刚装的系统选择安装nvidia-glx就不行啊,判断依赖关系后会提示要你安装386内核的那两个包~最后会出错、说缺少上面提到的那个虚拟包无法完成。
用过upgrade也不行的,我那两天试了很多次。
NoteBook: IBM X40 (1G Hz, 1.25GB, 20G+120GB)
Desktop: APU A6-3670, MSI A75A-G55, 4GB DDR3 1600 x 2
Slackware64 + Win7
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 SuperWar3Fan » 2007-01-16 14:58

没有看见怎么回事!!1
mood2046
帖子: 4
注册时间: 2007-01-16 17:55
送出感谢: 0
接收感谢: 0

下载了deb文件后如何安装

#9

帖子 mood2046 » 2007-01-16 18:05

下载了deb文件后如何安装? :?:
头像
felixlu
帖子: 311
注册时间: 2006-11-25 15:27
来自: SZ
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 felixlu » 2007-01-17 0:39

楼上的,直接双击就可以按提示安装了
NoteBook: IBM X40 (1G Hz, 1.25GB, 20G+120GB)
Desktop: APU A6-3670, MSI A75A-G55, 4GB DDR3 1600 x 2
Slackware64 + Win7
mood2046
帖子: 4
注册时间: 2007-01-16 17:55
送出感谢: 0
接收感谢: 0

#11

帖子 mood2046 » 2007-01-17 14:09

谢谢楼上
我用dpkg -i *.deb装上了
头像
jasonwood
帖子: 116
注册时间: 2006-07-26 8:47
来自: 浙江
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 jasonwood » 2007-01-17 14:13

打开一看,眼前一亮。 果然是一“黄”贴
头像
jasonwood
帖子: 116
注册时间: 2006-07-26 8:47
来自: 浙江
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 jasonwood » 2007-01-17 23:34

刚已试,三个包装好后,重启 grub处倒是多了两项选择,说明安装成功,但装NV显卡驱动时的错误提示是一样的。仍然不成功。
头像
felixlu
帖子: 311
注册时间: 2006-11-25 15:27
来自: SZ
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 felixlu » 2007-01-18 9:49

楼上的,我在3楼漏了一个说明,装完要重启并选择新装的2.6.20进入系统,不要用原来的2.6.17了~~
NoteBook: IBM X40 (1G Hz, 1.25GB, 20G+120GB)
Desktop: APU A6-3670, MSI A75A-G55, 4GB DDR3 1600 x 2
Slackware64 + Win7
头像
coffer
帖子: 673
注册时间: 2006-12-22 21:05
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 coffer » 2007-01-18 13:04

把deb http://www.albertomilone.com/drivers/ed ... gacy/32bit binary/加到你的源里,然后update一下,就可以安装nvidia的最新驱动啦。我之前也是不能安装nvidia的驱动,加了这个源之后,就OK啦。
回复

回到 “老旧版本支持”