装SCIM的问题!

为当前最终发行版之前的所有版本提供支持
回复
头像
uusky
帖子: 159
注册时间: 2006-09-02 10:02
送出感谢: 0
接收感谢: 0
联系:

装SCIM的问题!

#1

帖子 uusky » 2007-01-17 15:32

请问各位高手,我新装了ubuntu 6.10,然后参照了Wiki里面的快速设置指南里面一步步往下做,但是安装了SCIM,怎么按下“ctrl+空格”,能出来输入框,但是只能选择,英文输入法和内码输入。为什么没有智能拼音和五笔等中文输入呢?
我的做法是:
sudo fontconfig-voodoo -f -s zh_CN
sudo apt-get install im-switch libapt-pkg-perl
sudo im-switch -s scim -z default

然后
sudo apt-get install scim-bridge scim-qtimm
sudo gedit /etc/X11/xinit/xinput.d/scim
将默认的 GTK_IM_MODULE=scim 修改为 GTK_IM_MODULE="scim-bridge"。

这样做,有什么问题吗?还请各位大哥指点迷津!
wucongkun
帖子: 251
注册时间: 2006-11-10 20:27
送出感谢: 0
接收感谢: 0

#2

帖子 wucongkun » 2007-01-17 15:42

一开始就听说scim有兼容性的问题
不过无论如何
我都感觉fcitx更好
毕竟是中国人自己开发的东西
scim自称为平台
不过我不准备弄这方面的工作
就要输入中文而已
选择了fcitx
就这么多
fcitx配置很简单 全部都是中文 我很欣慰~
而且 拼音 五笔 仓颉都有
再加上我的系统生活在移动硬盘里
scim就被卸载了
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#3

帖子 xiehuoli » 2007-01-17 17:13

wucongkun 写了:一开始就听说scim有兼容性的问题
不过无论如何
我都感觉fcitx更好
毕竟是中国人自己开发的东西
scim自称为平台
不过我不准备弄这方面的工作
就要输入中文而已
选择了fcitx
就这么多
fcitx配置很简单 全部都是中文 我很欣慰~
而且 拼音 五笔 仓颉都有
再加上我的系统生活在移动硬盘里
scim就被卸载了
晕,人家问问题,都不知道你在说什么了
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#4

帖子 xiehuoli » 2007-01-17 17:18

在SCIM上点鼠标右键,选择设置里面看看五笔和拼音勾上了没有
sudo apt-get install scim-pinyin
这样是安装拼音的
你安装了language-support-zh吗?
安装看看
sudo apt-get install language-support-zh
然后在语言设定哪里看看选择了中文没有
再有办法就是搜索论坛
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
littleUbuntu
帖子: 1103
注册时间: 2006-10-19 9:02
送出感谢: 0
接收感谢: 0

#5

帖子 littleUbuntu » 2007-01-17 17:18

ls,同感
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#6

帖子 dogfox » 2007-01-17 17:24

同感,ls的ls
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#7

帖子 xiehuoli » 2007-01-17 17:27

:em03
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
wucongkun
帖子: 251
注册时间: 2006-11-10 20:27
送出感谢: 0
接收感谢: 0

#8

帖子 wucongkun » 2007-01-17 17:30

:evil:
我的意思是
既然需要一个输入法
干吗不用fcitx
这个比那个好用
而且配置也简单
也不需要install scim-pinyin之类的东西
610里面的scim几乎就是个罪恶
东西可不少
安装完了中文都无法输入
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#9

帖子 dogfox » 2007-01-17 17:33

我觉得scim体积庞大
夹杂了无数对俺无用的垃圾输入法
俺一般是先删为快
然后安装fcitx
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
头像
uusky
帖子: 159
注册时间: 2006-09-02 10:02
送出感谢: 0
接收感谢: 0
联系:

谢谢各位了的帖子了。

#10

帖子 uusky » 2007-01-17 17:41

首先感谢各位了!

这个帖子是在ubuntu里面给大家回复的。可见可以输入中文了。

我使用了这个。
sudo apt-get install scim-chinese

不知道是什么原因,然后重启Xwindows就可以了。其实用什么输入法都不是重要的。关键是学习linux的精髓。当然中文输入便于我们交流。SCIM确实和很多的软件冲突。以前,我装6.06的时候,Adobe Reader用不了,也是它所致!现在Adobe Reader仍然可以用!开心哈!
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#11

帖子 xiehuoli » 2007-01-17 17:41

wucongkun 写了::evil:
我的意思是
既然需要一个输入法
干吗不用fcitx
这个比那个好用
而且配置也简单
也不需要install scim-pinyin之类的东西
610里面的scim几乎就是个罪恶
东西可不少
安装完了中文都无法输入
你首先要跟人家说清楚赛,再说人家是问的SCIM
你那样回答,我能明白你要说什么,但是人家会晕晕赛
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
头像
uusky
帖子: 159
注册时间: 2006-09-02 10:02
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 uusky » 2007-01-17 17:44

但是感觉SCIM里面的智能拼音,我觉得很好用啊!Fcitx更好用吗?
不知道怎么完全删除SCIM,以便后面有什么冲突问题,把它删之!
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#13

帖子 xiehuoli » 2007-01-17 17:48

其实也可以不删除SCIM
安装个im-switch
然后安装FCITX
你想用FCITX就 im-switch -s fcitx
开机就是fcitx了
这个是6.06里面的办法,6.10就高级多了好像是直接im-switch可以选择开机默认的输入法
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
purewind
帖子: 452
注册时间: 2006-11-18 15:40
送出感谢: 0
接收感谢: 0

#14

帖子 purewind » 2007-01-17 18:03

安装的时候连好网络直接就装全了
linux什么最重要?硬件要旧,软件要新!
Ubuntu什么最重要?源要全!网要快!
不是你不明白,是linux变化快
人品也很重要
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#15

帖子 xiehuoli » 2007-01-18 9:05

purewind 写了:安装的时候连好网络直接就装全了
那我看LZ安装过程中先去睡它4.5个小时
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
回复

回到 “老旧版本支持”