当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求救!!高手
帖子发表于 : 2007-01-19 13:39 

注册: 2007-01-19 13:18
帖子: 5
地址: 江苏省苏州市
送出感谢: 0 次
接收感谢: 0 次
Ubuntu10.6 这个系统我都装了5次了,但是ATI X700的显卡就是驱不起来,真是狂晕呀!我是神W320A的本子-k8+AMD3200+521M+ATI X700 128M .根据wiki上的方法
-----------------------------------------------
sudo apt-get update
sudo apt-get install linux-restricted-modules-$(uname -r)
sudo apt-get install xorg-driver-fglrx
sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

重启系统.

确保驱动已经工作:

$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9700 Generic
OpenGL version string: 2.0.5755 (8.24.8)

来源: http://wiki.cchtml.com/index.php/Ubuntu ... tion_Guide

如果您收到如下消息Xlib: extension "XFree86-DRI" missing on display ":1.0, 编辑 /etc/X11/xorg.conf 并在 Section "Module" 字段内添加 load "dri"
----------------------------------------------------

sudo aticonfig --initial
这条命令运行后提示
Nothing to do, terminating.
---------------
sudo aticonfig --overlay-type=Xv
这条命令运行后提示
Warning: Option 'VideoOverlay' doesn't affect running session.
Warning: Option 'OpenGLOverlay' doesn't affect running session.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-1
然后重起就进不去了
我只能再一次运行 sudo dpkg-reconfigure xserver-xorg
选择fglrx,然能进图形系统,
------------------------------------
问题在下面
-----
我运行 fglrxinfo 指令行
提示
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
跟WIki讲的差不多一样
接着我就编辑 /etc/X11/xorg.conf 发现 Section "Module" 字段内已经有 load "dri"
但是3D就是起动不起来
----------------------------------
请高手指点
以下是我的安装过程
---------------------------------------------
root@czz:~# sudo apt-get update
忽略 cdrom://Ubuntu 6.10 _Edgy Eft_ - Release i386 (20061025.1) edgy/main Translation-zh_CN
忽略 cdrom://Ubuntu 6.10 _Edgy Eft_ - Release i386 (20061025.1) edgy/restricted Translation-zh_CN
获取:1 http://ubuntu.cn99.com dapper Release.gpg [189B]
忽略 http://ubuntu.cn99.com dapper/main Translation-zh_CN
忽略 http://ubuntu.cn99.com dapper/restricted Translation-zh_CN
忽略 http://ubuntu.cn99.com dapper/universe Translation-zh_CN
忽略 http://ubuntu.cn99.com dapper/multiverse Translation-zh_CN
获取:2 http://ubuntu.cn99.com dapper-updates Release.gpg [191B]
忽略 http://ubuntu.cn99.com dapper-updates/main Translation-zh_CN
忽略 http://ubuntu.cn99.com dapper-updates/restricted Translation-zh_CN
忽略 http://ubuntu.cn99.com dapper-updates/universe Translation-zh_CN
忽略 http://ubuntu.cn99.com dapper-updates/multiverse Translation-zh_CN
忽略 http://ubuntu.cn99.com dapper Release.gpg
忽略 http://ubuntu.cn99.com dapper/main Translation-zh_CN
忽略 http://ubuntu.cn99.com dapper/restricted Translation-zh_CN
忽略 http://ubuntu.cn99.com dapper/universe Translation-zh_CN
忽略 http://ubuntu.cn99.com dapper/multiverse Translation-zh_CN
命中 http://ubuntu.cn99.com dapper Release
命中 http://ubuntu.cn99.com dapper-updates Release
忽略 http://ubuntu.cn99.com dapper Release
命中 http://ubuntu.cn99.com dapper/main Packages
命中 http://ubuntu.cn99.com dapper/restricted Packages
命中 http://ubuntu.cn99.com dapper/universe Packages
命中 http://ubuntu.cn99.com dapper/multiverse Packages
命中 http://ubuntu.cn99.com dapper/main Sources
命中 http://ubuntu.cn99.com dapper/restricted Sources
命中 http://ubuntu.cn99.com dapper/universe Sources
命中 http://ubuntu.cn99.com dapper/multiverse Sources
命中 http://ubuntu.cn99.com dapper-updates/main Packages
命中 http://ubuntu.cn99.com dapper-updates/restricted Packages
命中 http://ubuntu.cn99.com dapper-updates/universe Packages
命中 http://ubuntu.cn99.com dapper-updates/multiverse Packages
命中 http://ubuntu.cn99.com dapper-updates/main Sources
命中 http://ubuntu.cn99.com dapper-updates/restricted Sources
命中 http://ubuntu.cn99.com dapper-updates/universe Sources
命中 http://ubuntu.cn99.com dapper-updates/multiverse Sources
忽略 http://ubuntu.cn99.com dapper/main Packages
忽略 http://ubuntu.cn99.com dapper/restricted Packages
忽略 http://ubuntu.cn99.com dapper/universe Packages
忽略 http://ubuntu.cn99.com dapper/multiverse Packages
忽略 http://ubuntu.cn99.com dapper/main Sources
忽略 http://ubuntu.cn99.com dapper/restricted Sources
忽略 http://ubuntu.cn99.com dapper/universe Sources
忽略 http://ubuntu.cn99.com dapper/multiverse Sources
命中 http://ubuntu.cn99.com dapper/main Packages
命中 http://ubuntu.cn99.com dapper/restricted Packages
命中 http://ubuntu.cn99.com dapper/universe Packages
命中 http://ubuntu.cn99.com dapper/multiverse Packages
错误 http://ubuntu.cn99.com dapper/main Sources
404 Not Found
错误 http://ubuntu.cn99.com dapper/restricted Sources
404 Not Found
错误 http://ubuntu.cn99.com dapper/universe Sources
404 Not Found
错误 http://ubuntu.cn99.com dapper/multiverse Sources
404 Not Found
下载 2B,耗时 15s (0B/s)
无法下载 http://ubuntu.cn99.com/ubuntu-cn/dists/ ... Sources.gz 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu-cn/dists/ ... Sources.gz 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu-cn/dists/ ... Sources.gz 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu-cn/dists/ ... Sources.gz 404 Not Found
正在读取软件包列表... 完成
E: 有一些索引文件不能下载,它们可能被忽略了,也可能转而使用了旧的索引文件。
root@czz:~# sudo apt-get install linux-restricted-modules-$(uname -r)
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
linux-restricted-modules-2.6.17-10-generic 已经是最新的版本了。
The following packages were automatically installed and are no longer required:
stardict-common libdbus-1-2 libgnutls12 libtasn1-2 libglitz1
使用 'apt-get autoremove' 来删除它们。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 2 个软件未被升级。
root@czz:~# sudo apt-get install xorg-driver-fglrx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
The following packages were automatically installed and are no longer required:
stardict-common libdbus-1-2 libgnutls12 libtasn1-2 libglitz1
使用 'apt-get autoremove' 来删除它们。
下列【新】软件包将被安装:
xorg-driver-fglrx
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 2 个软件未被升级。
需要下载 10.6MB 的软件包。
解压缩后会消耗掉 30.2MB 的额外空间。
获取:1 http://ubuntu.cn99.com dapper/restricted xorg-driver-fglrx 7.0.0-8.25.18+2.6.15.11-1 [10.6MB]
下载 10.6MB,耗时 3m11s (55.2kB/s)
选中了曾被取消选择的软件包 xorg-driver-fglrx。
(正在读取数据库 ... 系统当前总共安装有 94731 个文件和目录。)
正在解压缩 xorg-driver-fglrx (从 .../xorg-driver-fglrx_7.0.0-8.25.18+2.6.15.11-1_i386.deb) ...
正在设置 xorg-driver-fglrx (7.0.0-8.25.18+2.6.15.11-1) ...
root@czz:~# sudo aticonfig --initial
Found fglrx primary device section
Nothing to do, terminating.
root@czz:~#
root@czz:~# sudo aticonfig --initial
Found fglrx primary device section
Nothing to do, terminating.
root@czz:~#
root@czz:~# sudo aticonfig --overlay-type=Xv
Warning: Option 'VideoOverlay' doesn't affect running session.
Warning: Option 'OpenGLOverlay' doesn't affect running session.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-1
root@czz:~# fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)

root@czz:~#


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-01-19 13:58 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
wiki的那个不是针对edgy的,看这里:
http://forum.ubuntu.org.cn/viewtopic.ph ... highlight=


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译