为什么我无法执行make

为当前最终发行版之前的所有版本提供支持
opened
帖子: 18
注册时间: 2007-01-12 14:46
送出感谢: 0
接收感谢: 0

为什么我无法执行make

#1

帖子 opened » 2007-01-20 16:17

如报告以下过程会有这样的提示:
-----------------------------
~/download/gsopcast-0.2.10$ make
make: *** 没有指明目标并且找不到 makefile。 停止。
-------------------------------
我是新手,请大家帮忙指点下。
上次由 opened 在 2007-01-20 16:22,总共编辑 1 次。
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#2

帖子 xiehuoli » 2007-01-20 16:19

安装了吗?
安装下看看呢?
以前好像看见一个帖子也是这样情况
原因是没有安装
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
opened
帖子: 18
注册时间: 2007-01-12 14:46
送出感谢: 0
接收感谢: 0

#3

帖子 opened » 2007-01-20 16:20

还有顺便问下,我在常州的那个CN99源的,好多东西都更新不了。
系统提示有更新可以全失败,不知道为什么。其他源速度就不理想了,比较慢。
opened
帖子: 18
注册时间: 2007-01-12 14:46
送出感谢: 0
接收感谢: 0

#4

帖子 opened » 2007-01-20 16:22

我又试了下,安装了,提示是最新的

-----------------------------
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
make 已经是最新的版本了。
头像
jiangpeng
帖子: 223
注册时间: 2006-07-25 9:33
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 jiangpeng » 2007-01-20 16:29

先要用

代码: 全选

$./configure
生成makefile吧
Take what man makes and use it, But do not worship it, For it shall pass. -- Anonymous

Twitter @jiangpeng
opened
帖子: 18
注册时间: 2007-01-12 14:46
送出感谢: 0
接收感谢: 0

#6

帖子 opened » 2007-01-20 16:37

这个文档里它本身是带有makefile文件的。按时说明也没有要求先进行configure
估计是我太菜了,呵呵。
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#7

帖子 xiehuoli » 2007-01-20 16:43

opened 写了:还有顺便问下,我在常州的那个CN99源的,好多东西都更新不了。
系统提示有更新可以全失败,不知道为什么。其他源速度就不理想了,比较慢。
我最近也是这样的情况,
好像还是因为台湾地震的影响吧
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
头像
ct
帖子: 2201
注册时间: 2005-04-06 21:15
来自: 安徽黄山
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 ct » 2007-01-20 16:51

在ftp里面有个qsopcast,是官方的rpm转的,但是兼容性很好,如果不介意是qt程序,建议使用,效果很好。
opened
帖子: 18
注册时间: 2007-01-12 14:46
送出感谢: 0
接收感谢: 0

#9

帖子 opened » 2007-01-20 17:11

ct 写了:在ftp里面有个qsopcast,是官方的rpm转的,但是兼容性很好,如果不介意是qt程序,建议使用,效果很好。
好的,谢谢,不过本身这个MAKE 的问题还是没有搞清楚。
我再去找找资料。
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#10

帖子 BigSnake.NET » 2007-01-20 17:35

make时当前目录有makefile么。。可读么
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 zhan » 2007-01-20 18:09

提示告诉你了,是因为没有 makefile .
5楼告诉你正确的步骤了,先 ./configure 生成 makefile 然后再 make.
make 默认会顺序找 名字为 GNUmakefile 或 makefile 或 Makefile 的文件,然后按照其中的脚本来执行。

对于一般的编译软件,软件解压后会带一个叫做 README 或 INSTALL 的文件,告诉你要怎么安装,以及需要什么库等等的。
不过通常来说 编译软件就是 ./configure 生成 Makefile ,然后 make 编译,然后 make install 安装。
关于 make 可以 google 一下,有很多相关的资料.
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
opened
帖子: 18
注册时间: 2007-01-12 14:46
送出感谢: 0
接收感谢: 0

#12

帖子 opened » 2007-01-22 9:37

:~/download/chmsee-0.9.6$ ./configure
checking build system type... i686-pc-linux-gnulibc1
checking host system type... i686-pc-linux-gnulibc1
checking target system type... i686-pc-linux-gnulibc1
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
opened@opened-linux:~/download/chmsee-0.9.6$ make
make: *** 没有指明目标并且找不到 makefile。 停止。
-------------------------------------
不知道以上是什么问题。
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 zhan » 2007-01-22 9:51

注意 ,问题是 在 ./configure 的时候已经报错了,看 ./configure 的最后一行。
主要是开发包没有装,编译是需要的头文件等等找不到。子、直接原因是 gcc 编译器没有装好.
先 sudo apt-get install build-essential 装好编译环境,然后需要什么开发库再慢慢找把,./configure 的时候会提示错误的。

btw. chmsee 貌似源里面有的,还有很多爱好者也做过 deb 的,不了解编译的话建议最好还是去找 deb 包来直接安装吧。
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
opened
帖子: 18
注册时间: 2007-01-12 14:46
送出感谢: 0
接收感谢: 0

#14

帖子 opened » 2007-01-22 10:51

OK,谢谢指点。
opened
帖子: 18
注册时间: 2007-01-12 14:46
送出感谢: 0
接收感谢: 0

#15

帖子 opened » 2007-01-22 11:47

继续问,嘿嘿。
我在安装编译环境ESSENTIAL时,按照提示从前往后安装
在安装libc6-dev时出现如下情况。
----------------------------------

下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.3.6-0ubuntu20) 但是 2.4-1ubuntu12.1 正要被安装
E: 无法安装的软件包
------------------------------------
可以知道安装时需要libc6 的2.3.6-0ubuntu2版本,但是我已经安装了较之更新的2.4-1ubuntu12版本。
我感觉这样的设定不合理啊,如果要 uninstall 新版本,也会同时UNINSTALL很多东西。
现在我应该怎么办啊。。。
回复

回到 “老旧版本支持”