OK,kenrel 2.6.20

为当前最终发行版之前的所有版本提供支持
回复
头像
ct
帖子: 2201
注册时间: 2005-04-06 21:15
来自: 安徽黄山
送出感谢: 0
接收感谢: 0
联系:

OK,kenrel 2.6.20

#1

帖子 ct » 2007-01-20 17:08

自从N天前升级了2.6.20的内核后,系统就一直启动不了,无奈,这段时间一直都是用.17的内核。
昨天想想不爽,干脆吧.20的彻底干掉了。
结果一重启,挂了,.17也进不了了。
还好有张hiweed的livecd,进去后chroot,然后拨号,又apt装了下.20。
很美妙的事情,居然.20也可以用了,哈哈。
和很多人的情况一样,硬盘认成了sda了,不过现在的uid方式挂载的好像无所谓what da,了解到好处了。

代码: 全选

ctqucl@feisty:~$ linuxinfo
Linux feisty 2.6.20-5-generic #2 SMP Sat Jan 6 14:50:47 UTC 2007
One AMD Unknown 1536MHz processor, 3076.72 total bogomips, 1011M RAM
System library 2.5.0

:lol:
头像
Stupid kid
帖子: 417
注册时间: 2006-10-18 12:57
送出感谢: 0
接收感谢: 0

#2

帖子 Stupid kid » 2007-01-20 17:38

呵呵,恭喜楼主了,
顺便问一个问题,什么是chroot啊,
以前看debian手册的时候虽然看了,可是被他说的迷迷糊糊的,还请略说一二
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 skyx » 2007-01-20 17:54

貌似升级内核最好自己编绎的。

如果升级全部系统,全新安装吧,这样不会有什么问题,我今天刚刚全新安装7.04,安装完后成功升级,升级后很稳定,没有出错,性能也有很大的提升。
no security measure is worth anything if an attacker has physical access to the machine
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 karron » 2007-01-20 18:43

呵呵,我的feisty是升级上来的,一切正常阿.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#5

帖子 skyx » 2007-01-20 22:28

呵呵,我的feisty是升级上来的,一切正常阿.




但是你升级过程中没有看到警告和错误吗?看了心里就不踏实,你要是没有碰到,那真是太有福了


从老版升级到新系统用起来的确感觉不出什么,我从原来的一个dapper备份(安装的软件少些,没有kde)升级到7.04 ,的确成功了,但从dapper升级到edgy的系统再升级7.04,完成后关机还没结束就挂了。


我从全新安装的7.04上升级,没有看到任何错误 提示,这样用起来放心
no security measure is worth anything if an attacker has physical access to the machine
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 karron » 2007-01-20 23:22

当然有错误,但是我全部解决了.我的机器软件安装得很多,升级的时候解决了好几个问题.

其实不难的,关键是要耐心.没升级完成之前绝对不要重启机器.多dist-upgrade几下,确保升级完成.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
juanzhewudi
帖子: 1114
注册时间: 2006-01-19 11:55
来自: HUST
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 juanzhewudi » 2007-02-04 16:31

2.6.20-5是改成sda才能启动,
好像2.6.20-6又变正常了
yohu
帖子: 955
注册时间: 2006-12-18 17:04
来自: 福建泉州
送出感谢: 0
接收感谢: 1 次

#8

帖子 yohu » 2007-02-04 21:35

因为2.6.20-6在menu.lst里面是以uuid形式挂载,所以无所谓hda还是sda了。
拥有超级牛力的搜索引擎:
http://www.google.com/linux
http://www.google.com/
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#9

帖子 skyx » 2007-02-04 23:20

skyx 写了:貌似升级内核最好自己编绎的。

如果升级全部系统,全新安装吧,这样不会有什么问题,我今天刚刚全新安装7.04,安装完后成功升级,升级后很稳定,没有出错,性能也有很大的提升。


现在看来上面的论调不完全正确,曾经为了在edgy上安装nvidia-glx 9631版驱动,直接安装过20内核的deb文件s,也没发现有什么不对劲的地方
no security measure is worth anything if an attacker has physical access to the machine
l5110
帖子: 75
注册时间: 2005-10-26 19:51
来自: qingdao
送出感谢: 0
接收感谢: 0

#10

帖子 l5110 » 2007-02-10 12:58

晕死,刚刚升级到06,xwindow启动不了了, 真他马的郁闷。。现在只能用05的内核了。
learn to love ...
头像
feeling
帖子: 175
注册时间: 2006-04-29 20:10
来自: 北京·昌平
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 feeling » 2007-02-16 22:52

有没有人通过直接编译2.6.20的内核升级并成功的?
人生若只如初见,何事秋风悲画扇?
shoory
帖子: 123
注册时间: 2006-08-05 12:47
来自: 四川成都
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 shoory » 2007-02-22 11:10

One AMD Unknown 1536MHz processor

神奇了,什么CPU啊
feex
帖子: 85
注册时间: 2005-09-29 1:16
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 feex » 2007-02-26 19:52

dapper用自己编译的2.6.20内核, 默认的内核配置就行, 需要注意的就是如果是sda硬盘的话就必须把scsi驱动编译到内核里, 模块形式不行
回复

回到 “老旧版本支持”