ubuntu能不能用Debian的源更新?

为当前最终发行版之前的所有版本提供支持
回复
wattwang
帖子: 97
注册时间: 2006-10-30 17:10
送出感谢: 0
接收感谢: 0

ubuntu能不能用Debian的源更新?

#1

帖子 wattwang » 2007-01-20 23:40

好像两者source.list里面的写法不一样,
能否?
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 karron » 2007-01-21 10:38

不能.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
xiechy
帖子: 1074
注册时间: 2006-01-18 15:01
送出感谢: 0
接收感谢: 1 次

#3

帖子 xiechy » 2007-01-21 10:52

能。但不安全。有很多包没有问题(例如那些all的包,本来就只是脚本或者数据;也有些没有ubuntu patch过的也可以,例如官方的skype,opera包,只有给debian的,但ubuntu也能用。),但也有很多包不可以。

一般最新版基于debian的unstable,所以就算是有什么软件不如debian新,也差不了太远。如果实在是要,建议apt-get source 然后自己编译deb包。
头像
TheThirdGhost
帖子: 1592
注册时间: 2006-07-23 16:25
来自: 南京
送出感谢: 0
接收感谢: 0

#4

帖子 TheThirdGhost » 2007-01-21 10:57

opera是有给ubuntu用的包的。
xiechy
帖子: 1074
注册时间: 2006-01-18 15:01
送出感谢: 0
接收感谢: 1 次

#5

帖子 xiechy » 2007-01-21 11:37

去官网。只看到debian的源。没有必要重新打包。
虽然在ubuntu的repo里有,但你看看和debian的有没有不同?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2007-01-21 16:47

危险的事情。谁也不确定debian中间的那些包能用。可能某些依赖很少的软件可用。还是用发行版本的源吧。
● 鸣学
回复

回到 “老旧版本支持”