当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : A ridiculours and strange thing
帖子发表于 : 2007-01-22 0:47 

注册: 2007-01-19 13:34
帖子: 26
地址: ZJU
送出感谢: 0 次
接收感谢: 0 次
(Sorry I cannot input Chinese this moment, but I will try to make my expression as grammatically correct and precise as possible.)

5 days ago, I installed 6.06 dapper to my disk, on which existed a Windows XP Pro. I've used GNU/Debian for along time at school, and I just made the /boot a seperated partition as I used to do.
But this morning the f**king Windows went down and I couldn't save it with all possible attemps. I reinstalled the Windows, and then tried to find back my grub and Ubuntu.
I used a CD-ROM to boot my computer into DOS and run the 'grub for DOS', which was the method I had used to save my Debian times and times again in the past.
I was quite sure that the /boot is /dev/hda10, but this command:
grub>find /vmlinuz
returned: Error 15 file not found
I was confused, but
grub>find /boot/vmlinuz
returned the same--of coz I knew the former command was the right one.
Then I tried
grub>root (hd0,9)
and then
grub>find /sbin/init
(hd0,10)
grub>kernel /vmlinuz root=/dev/hda11
of coz, it returned the wrong prompt.

OK, maybe I should use the Live CD!
so I used the live CD, but still a vein! What was the worse:
grub>root (hd0.9)
returned: device not exist.

Now I don't know what's the matter!
and I've just reinstalled my Ubuntu...


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-01-22 9:27 

注册: 2006-01-18 15:01
帖子: 1074
送出感谢: 0 次
接收感谢: 1
引用:
grub>root (hd0.9)

~~~ comma!! you should always try tab to automatically complete the word!

maybe that is not the answer, but I hope it will help to check what's going wrong.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译