新手求助 rpm命令不可用?

为当前最终发行版之前的所有版本提供支持
回复
sxshzzh
帖子: 3
注册时间: 2006-08-25 11:37
送出感谢: 0
接收感谢: 0

新手求助 rpm命令不可用?

#1

帖子 sxshzzh » 2007-01-22 15:43

我用rpm命令安装新软件,无法进行,
提示错误基本为:
bash:rpm command not found
ilove3d
帖子: 24
注册时间: 2007-01-18 22:01
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 ilove3d » 2007-01-22 15:44

deb

alien
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#3

帖子 dogfox » 2007-01-22 15:47

ubuntu不支持rpm
ls正解
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 SuperWar3Fan » 2007-01-22 18:51

sudo apt-get install rpm
feng3243
帖子: 210
注册时间: 2006-08-29 23:08
来自: 广东茂名
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 feng3243 » 2007-01-22 19:00

在linux系统的软件中,有很多是rpm的,这种软件包在Ubuntu不能直接使用,若真的要使用,那要把rpm包转换成deb包

(1)装个将rpm包转换为deb包的小工具alien

apt-get install alien

(2)进入rpm所在的目录,输入命令

alien xxx.rpm(转换为deb包的rpm文件)

即可在本目录下生成一个xxx.deb
然后你双击就行了。
做一个精通linux的高手--不易;
做一个熟练的linux使用者--不难。
头像
ct
帖子: 2201
注册时间: 2005-04-06 21:15
来自: 安徽黄山
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 ct » 2007-01-22 19:10

还是建议不要用rpm包,你需要都包绝大部分都可以找到deb包的,alien确实是不得已的办法。
如果用rpm包习惯了,不如选择采用rpm包的linux发行版了。
purewind
帖子: 452
注册时间: 2006-11-18 15:40
送出感谢: 0
接收感谢: 0

#7

帖子 purewind » 2007-01-23 2:22

不用rpm用deb了
linux什么最重要?硬件要旧,软件要新!
Ubuntu什么最重要?源要全!网要快!
不是你不明白,是linux变化快
人品也很重要
littleUbuntu
帖子: 1103
注册时间: 2006-10-19 9:02
送出感谢: 0
接收感谢: 0

#8

帖子 littleUbuntu » 2007-01-23 8:57

从红帽转来的,忘记rpm,rpm有的Ubuntu基本上都有了。
回复

回到 “老旧版本支持”