当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 程序一打开就自动关闭,怎么办阿?但是用root用户登录就没有问题!
帖子发表于 : 2007-01-23 14:31 

注册: 2007-01-23 14:29
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
程序一打开就自动关闭,怎么办阿?但是用root用户登录就没有问题!
我装了scim,好像正在设置的时候就出了问题,然后所有程序就都自动关闭了,以后再用这个用户登录就是开了什么程序就自动关闭,怎么解决阿!
以root进入,登录终端,

su 普通用户
gedit

后会得到下面的提示

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

cannot open display:
Run 'gedit --help' to see a full list of available command line options.

清大家帮忙看看是怎么回事,急阿!!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-01-23 14:54 

注册: 2007-01-23 14:29
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
在线等回复啊!谢谢各位了!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-01-23 14:58 

注册: 2006-10-19 9:02
帖子: 1103
送出感谢: 0 次
接收感谢: 0 次
没遇到过,只有这一个程序是这样么?别的程序呢?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-01-23 15:02 

注册: 2007-01-23 14:29
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
littleUbuntu 写道:
没遇到过,只有这一个程序是这样么?别的程序呢?

不是只有一个程序,所有程序都不能代开包括终端,但是system monitor可以打开,别的能打开的我还没有发现。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-01-23 15:13 

注册: 2006-10-19 9:02
帖子: 1103
送出感谢: 0 次
接收感谢: 0 次
这样不好判断是什么原因,你用sudo 重新建立一个账户,然后用那个账户登陆到桌面看看有没有这样的问题。

估计是你用户设置过程中出现的问题。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-01-23 15:29 

注册: 2007-01-23 14:29
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我在root用户下用的很正常阿,但是那个用户就不行


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-01-24 8:55 

注册: 2007-01-23 14:29
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
littleUbuntu 写道:
这样不好判断是什么原因,你用sudo 重新建立一个账户,然后用那个账户登陆到桌面看看有没有这样的问题。

估计是你用户设置过程中出现的问题。

我新建了一个用户就正常了,可是我还是想用以前的用户,好多设置都没有了


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-01-24 9:09 

注册: 2006-10-19 9:02
帖子: 1103
送出感谢: 0 次
接收感谢: 0 次
从以前的账户登陆,然后执行一下命令,不要sudo

代码:
cd
rm .Xauthority
touch .Xauthority


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-01-24 9:26 
头像

注册: 2005-10-16 13:24
帖子: 958
地址: 四川成都
送出感谢: 2
接收感谢: 0 次
通俗一点说就是,你的图形界面环境是root的,所以普通用户的程序执行不了


_________________
Thank you Ubuntu Team!!!!
I still can't belive this is free...


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-01-24 9:34 

注册: 2006-10-19 9:02
帖子: 1103
送出感谢: 0 次
接收感谢: 0 次
不是那个意思


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 程序一打开就自动关闭,怎么办阿?但是用root用户登录就没有问题!
帖子发表于 : 2010-07-14 20:13 

注册: 2009-09-01 19:48
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
我也遇到了这个问题,就是开机自启动一个程序,结果程序死掉了,进程也结束了,所以表面上就是一进入系统,就马上注销了。
用其他用户登录当然不受影响,还不知道要怎么解决,那个设置自启动程序的文件在哪里呢?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译