使用内地源搞定edgy(6.10)nvidia-glx 10.9631驱动

为当前最终发行版之前的所有版本提供支持
回复
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

使用内地源搞定edgy(6.10)nvidia-glx 10.9631驱动

#1

帖子 skyx » 2007-01-23 16:13

最近edgy 6.10的源自1月10号后好像一直是个问题,最主要是nvidia驱动的问题
今天帮一个朋友安装edgy,本来我不想装edgy的,但对方非要玩beryl,没办法,那就装吧,去前带了个U盘,其中带了预先准备的NVIDIA-Linux-x86-1.0-9631-pkg1.run NVIDIA-Linux-x86-1.0-9746-pkg1.run两个文件,能否用上我也不清楚

安装6.10完成后便试了U盘中的两个驱动,结果没有一个可以装上,只好设置网络,改源,然后update ,upgrade dist-upgrade,都没什么问题然后再安装u盘上的驱动,也是没有一个可以装上。


这时只好sudo apt-get install nvidia-glx ,安装时好像也没提示什么错误,但sudo nvidia-xconfig后便和元月10号后的情况是一样的,进不了x,只好把原来X11下的conf考回来。

然后参考了

viewtopic.php?t=37491&highlight=nvidia-glx

发现这个贴子中15楼coffer的做法可行
,但这个源是国外的,现在这台电脑上不了国外网,虽然可以找代理,但总感觉代理靠不住。

只好按照这个贴子三楼的做法ghost备份系统后把

http://archive.ubuntu.org.cn/ubuntu/poo ... 7_i386.deb
http://archive.ubuntu.org.cn/ubuntu/poo ... 6_i386.deb
http://archive.ubuntu.org.cn/ubuntu/poo ... -6_all.deb

三个内核相关的down下来,downtehmall 的速度还真快
然后安装这三个deb包,安装完成后 重启选20内核 再安装 NVIDIA-Linux-x86-1.0-9631-pkg1.run NVIDIA-Linux-x86-1.0-9746-pkg1.run 结果这两个还是一个都装不进去

只好sudo apt-get install nvidia-glx ,但还是和以前一样不管用!!!



怎么办?真的有些火了,突然想起几天以前安装feisty时,内核是20的,nvidia驱动也是9631的,这样胆子大一些,反正ghost备份了,把源改为feisty的,再做一次update, 终于成功了。详细过程如下。安装完后再把源改成edgy,再做一次update


sudo apt-get install nvidia-glx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
将会安装下列额外的软件包:
fontconfig-config libc6 libc6-i686 libfontconfig1 libpango1.0-0
libpango1.0-common libpng12-0
建议安装的软件包:
glibc-doc ttf-thryomanes nvidia-kernel-source
下列【新】软件包将被安装:
nvidia-glx
下列的软件包将被升级:
fontconfig-config libc6 libc6-i686 libfontconfig1 libpango1.0-0
libpango1.0-common libpng12-0
共升级了 7 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 676 个软件未被升级。
需要下载 10.5MB/10.7MB 的软件包。
解压缩后会消耗掉 14.2MB 的额外空间。
您希望继续执行吗?[Y/n]y
获取:1 http://debian.ustc.edu.cn feisty/main libc6 2.5-0ubuntu6 [4097kB]
获取:2 http://debian.ustc.edu.cn feisty/main libc6-i686 2.5-0ubuntu6 [1181kB]
获取:3 http://debian.ustc.edu.cn feisty/main libfontconfig1 2.4.1-2ubuntu2 [203kB]
获取:4 http://debian.ustc.edu.cn feisty/main fontconfig-config 2.4.1-2ubuntu2 [140kB]
获取:5 http://debian.ustc.edu.cn feisty/main libpango1.0-common 1.15.2-0ubuntu1 [35.4kB]
获取:6 http://debian.ustc.edu.cn feisty/main libpango1.0-0 1.15.2-0ubuntu1 [332kB]
获取:7 http://debian.ustc.edu.cn feisty/restricted nvidia-glx 1.0.9631+2.6.20.1-3 [4491kB]
下载 10.5MB,耗时 2s (4799kB/s)
正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 99324 个文件和目录。)
正预备替换 libc6 2.4-1ubuntu12 (使用 .../libc6_2.5-0ubuntu6_i386.deb) ...
正在解压缩将用于更替的包文件 libc6 ...
正在设置 libc6 (2.5-0ubuntu6) ...
正在安装新版本的配置文件 /etc/init.d/glibc.sh ...

(正在读取数据库 ... 系统当前总共安装有 99323 个文件和目录。)
正预备替换 libc6-i686 2.4-1ubuntu12 (使用 .../libc6-i686_2.5-0ubuntu6_i386.deb) ...
正在解压缩将用于更替的包文件 libc6-i686 ...
正预备替换 libfontconfig1 2.3.2-7ubuntu2 (使用 .../libfontconfig1_2.4.1-2ubuntu2_i386.deb) ...
正在解压缩将用于更替的包文件 libfontconfig1 ...
正预备替换 fontconfig-config 2.3.2-7ubuntu2 (使用 .../fontconfig-config_2.4.1-2ubuntu2_all.deb) ...
正在解压缩将用于更替的包文件 fontconfig-config ...
正预备替换 libpng12-0 1.2.8rel-5.1ubuntu0.1 (使用 .../libpng12-0_1.2.15~beta5-1_i386.deb) ...
正在解压缩将用于更替的包文件 libpng12-0 ...
正预备替换 libpango1.0-common 1.14.5-0ubuntu1 (使用 .../libpango1.0-common_1.15.2-0ubuntu1_i386.deb) ...
Cleaning up font configuration of pango...
Cleaning up category xfont..
正在解压缩将用于更替的包文件 libpango1.0-common ...
正预备替换 libpango1.0-0 1.14.5-0ubuntu1 (使用 .../libpango1.0-0_1.15.2-0ubuntu1_i386.deb) ...
正在解压缩将用于更替的包文件 libpango1.0-0 ...
选中了曾被取消选择的软件包 nvidia-glx。
正在解压缩 nvidia-glx (从 .../nvidia-glx_1.0.9631+2.6.20.1-3_i386.deb) ...
正在设置 libc6-i686 (2.5-0ubuntu6) ...

正在设置 fontconfig-config (2.4.1-2ubuntu2) ...
正在安装新版本的配置文件 /etc/fonts/fonts.conf ...
正在安装新版本的配置文件 /etc/fonts/fonts.dtd ...

正在设置 libfontconfig1 (2.4.1-2ubuntu2) ...

正在设置 libpng12-0 (1.2.15~beta5-1) ...

正在设置 libpango1.0-common (1.15.2-0ubuntu1) ...
Updating the modules list for Pango-1.6.0...done.
Cleaning up font configuration of pango...
Cleaning up category xfont..
Updating font configuration of pango...
Cleaning up category xfont..
Updating category xfont..

正在设置 libpango1.0-0 (1.15.2-0ubuntu1) ...

正在设置 nvidia-glx (1.0.9631+2.6.20.1-3) ...

sudo nvidia-xconfig

Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'
上次由 skyx 在 2007-01-23 16:44,总共编辑 1 次。
no security measure is worth anything if an attacker has physical access to the machine
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 skyx » 2007-01-23 16:30

虽然内核变了,但把源改为 edgy后,再做upgrade 和dist-upgrade也没提示出错。
no security measure is worth anything if an attacker has physical access to the machine
头像
felixlu
帖子: 311
注册时间: 2006-11-25 15:27
来自: SZ
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 felixlu » 2007-01-25 13:54

呵呵,用了新内核以后,装vmware-player也有些麻烦,vmware-player所依赖的2个包也要手动安装与内核对应的版本才能继续用apt-get安装。
太奇怪了,为什么我那个方法只有我自己能成功?
NoteBook: IBM X40 (1G Hz, 1.25GB, 20G+120GB)
Desktop: APU A6-3670, MSI A75A-G55, 4GB DDR3 1600 x 2
Slackware64 + Win7
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#4

帖子 skyx » 2007-01-25 14:11

为什么我那个方法只有我自己能成功?


有一种可能是你在源好时(1月10号以前)该升级的都升过了



现在源不行,新装的系统升级后可能依赖关系不一定正确

如果官方源可用,用官方源应该没问题。

个人理解
no security measure is worth anything if an attacker has physical access to the machine
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#5

帖子 dogfox » 2007-01-25 14:31

:shock: 好可爱的小白
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
头像
felixlu
帖子: 311
注册时间: 2006-11-25 15:27
来自: SZ
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 felixlu » 2007-01-25 16:37

我重装系统的时候好像已经过了10号,当时也是搞得乱七八糟了
NoteBook: IBM X40 (1G Hz, 1.25GB, 20G+120GB)
Desktop: APU A6-3670, MSI A75A-G55, 4GB DDR3 1600 x 2
Slackware64 + Win7
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#7

帖子 skyx » 2007-01-25 16:52

我重装系统的时候好像已经过了10号,当时也是搞得乱七八糟了
10号后搞得乱七八糟是很正常的事情

10号前搞得乱七八糟是是很不正常的事情
no security measure is worth anything if an attacker has physical access to the machine
回复

回到 “老旧版本支持”