当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu6.10安装apache时出现问题
帖子发表于 : 2007-01-23 17:35 

注册: 2007-01-23 17:27
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我安装的是apache_1.3.37.tar.gz ,在进行到 configure的时候,系统报错不能继续安装了。
这是执行configure后的系统提示:
Configuring for Apache, Version 1.3.37
+ Warning: Your 'echo' command is slightly broken.
+ It interprets escape sequences per default. We already
+ tried 'echo -E' but had no real success. If errors occur
+ please set the SEO variable in 'configure' manually to
+ the required 'echo' options, i.e. those which force your
+ 'echo' to not interpret escape sequences per default.
+ using installation path layout: Apache (config.layout)
Creating Makefile
Creating Configuration.apaci in src
Syntax error --- The configuration file is used only to
define the list of included modules or to set Makefile in src
options or Configure rules, and I don't see that at all:
 `$(SRCDIR)/apaci`
default
default
no
no
no
yes
no
default
no
default
default
望高手帮忙解决一下。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-01-23 17:54 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
你自己编译apache的原因是什么?


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-01-24 9:17 

注册: 2007-01-23 17:27
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
设置安装路径阿。我是这么写的:
shell>./configure \

  --prefix=/usr/local/apache \

  --enable-shared=max \

  --enable-module=rewrite \

  --enable-module=so


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-01-24 11:05 

注册: 2007-01-23 17:27
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
不编译怎么能make 阿。还请大家帮帮忙阿。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-01-24 12:25 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install apache 安装apache1的版本
sudo apt-get install apache2 安装apache2的版本.

直接安装就好了.搞什么自己编译啊.


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-01-24 12:45 

注册: 2007-01-23 17:27
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
karron 写道:
sudo apt-get install apache 安装apache1的版本
sudo apt-get install apache2 安装apache2的版本.

直接安装就好了.搞什么自己编译啊.

仍然出错了。。。。。。。。

dpkg:处理 apache (--configure)时出错:
子进程·post-installation script·返回了错误号·1
在处理时有错误发生:
apache
E: Sub-process /usr/bin/dpkg returned an error code (1)
彻底郁闷了。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-01-24 12:57 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
看看源或者检查别的问题.

一般来说现在都是安装的apache2.

你到本站的wiki或者ubuntu官方wiki(推荐),上去搜索apache.里面有完整的安装lamp的方法.很简单的.不需要自己编译.我个人认为,象这样的大家伙.自己编译的肯定没有人家专业工程师编译的好.


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-01-24 13:18 

注册: 2007-01-23 17:27
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
哦,谢谢阿,我去看看。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:xuyy, Yahoo [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译