[问题][求助]Alacarte菜单编辑器不能运行!(已解决)

为当前最终发行版之前的所有版本提供支持
回复
头像
yumumao
帖子: 171
注册时间: 2006-09-25 3:58
送出感谢: 0
接收感谢: 0

[问题][求助]Alacarte菜单编辑器不能运行!(已解决)

#1

帖子 yumumao » 2007-01-23 18:34

Alacarte菜单编辑器忽然不能运行了,错误提示如下:

代码: 全选

(alacarte:5223): GnomeUI-CRITICAL **: gnome_icon_selection_clear: assertion `gis != NULL' failed

(alacarte:5223): GnomeUI-CRITICAL **: gnome_icon_selection_add_directory: assertion `gis != NULL' failed

(alacarte:5223): GnomeUI-CRITICAL **: gnome_icon_selection_show_icons: assertion `gis != NULL' failed

(alacarte:5223): GnomeUI-CRITICAL **: gnome_icon_selection_clear: assertion `gis != NULL' failed

(alacarte:5223): GnomeUI-CRITICAL **: gnome_icon_selection_add_directory: assertion `gis != NULL' failed

(alacarte:5223): GnomeUI-CRITICAL **: gnome_icon_selection_show_icons: assertion `gis != NULL' failed
Traceback (most recent call last):
  File "/usr/bin/alacarte", line 26, in ?
    main()
  File "/usr/bin/alacarte", line 23, in main
    GnomeFront()
  File "/usr/lib/python2.4/site-packages/Alacarte/GnomeFront.py", line 72, in __init__
    self.loadMenus()
  File "/usr/lib/python2.4/site-packages/Alacarte/GnomeFront.py", line 205, in loadMenus
    self.sys_handler = MenuHandler('settings.menu', self.options)
  File "/usr/lib/python2.4/site-packages/Alacarte/PyXDGMenuHandler.py", line 27, in __init__
    xdg.MenuEditor.MenuEditor.__init__(
  File "/usr/lib/python2.4/site-packages/xdg/MenuEditor.py", line 28, in __init__
    self.parse(menu, filename, root)
  File "/usr/lib/python2.4/site-packages/xdg/MenuEditor.py", line 40, in parse
    self.menu = parse(menu)
  File "/usr/lib/python2.4/site-packages/xdg/Menu.py", line 524, in parse
    __genmenuNotOnlyAllocated(tmp["Root"])
  File "/usr/lib/python2.4/site-packages/xdg/Menu.py", line 856, in __genmenuNotOnlyAllocated
    __genmenuNotOnlyAllocated(submenu)
  File "/usr/lib/python2.4/site-packages/xdg/Menu.py", line 856, in __genmenuNotOnlyAllocated
    __genmenuNotOnlyAllocated(submenu)
  File "/usr/lib/python2.4/site-packages/xdg/Menu.py", line 859, in __genmenuNotOnlyAllocated
    tmp["cache"].addMenuEntries(menu.AppDirs)
  File "/usr/lib/python2.4/site-packages/xdg/Menu.py", line 1022, in addMenuEntries
    self.__addFiles(dir, "", prefix, legacy)
  File "/usr/lib/python2.4/site-packages/xdg/Menu.py", line 1036, in __addFiles
    self.__addFiles(dir, os.path.join(subdir,item), prefix, legacy)
  File "/usr/lib/python2.4/site-packages/xdg/Menu.py", line 1036, in __addFiles
    self.__addFiles(dir, os.path.join(subdir,item), prefix, legacy)
  File "/usr/lib/python2.4/site-packages/xdg/Menu.py", line 1035, in __addFiles
    elif os.path.isdir(os.path.join(dir,subdir,item)) and legacy == False:
  File "/usr/lib/python2.4/posixpath.py", line 65, in join
    path += '/' + b
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 6-7: unexpected end of data
各位遇到过类似的情况么?怎样解决的呢?谢谢了。
上次由 yumumao 在 2007-01-24 23:44,总共编辑 1 次。
头像
yumumao
帖子: 171
注册时间: 2006-09-25 3:58
送出感谢: 0
接收感谢: 0

#2

帖子 yumumao » 2007-01-24 22:54

无人回答,顶一下,这个问题真是蛮讨厌的……
头像
yumumao
帖子: 171
注册时间: 2006-09-25 3:58
送出感谢: 0
接收感谢: 0

#3

帖子 yumumao » 2007-01-24 23:46

我把“~/.config/menus/settings.menu”删掉就行了,(-__-!),不知道什么原因……
回复

回到 “老旧版本支持”