[求助]我的Ubuntu无法更新升级软件包 [己解决]

为当前最终发行版之前的所有版本提供支持
回复
ickbeta
帖子: 7
注册时间: 2007-01-06 15:51
送出感谢: 0
接收感谢: 0
联系:

[求助]我的Ubuntu无法更新升级软件包 [己解决]

#1

帖子 ickbeta » 2007-01-24 10:41

今天软件包更新无法使用了。。。平时只要点更新就会自动检查可以更新的软件然后自己更新的阿,先是说我有另外程序在运行, 然后说
无法升级系统!
请先修复(依赖关系)毁损的软件包
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.


使用 dpkg --configure -a 后说我没有权限
然后使用终端update就出现一堆数据

ickbeta@ickbeta-desktop:~$ sudo apt-get update
Password:
获取:1 ftp://ftp.nerim.net sarge Release.gpg
忽略 http://mirror.lupaworld.com dapper Release.gpg
忽略 http://mirror.lupaworld.com dapper Release
忽略 http://mirror.lupaworld.com dapper/main Packages
获取:2 http://www.elisanet.fi dapper Release.gpg [189B]
忽略 http://mirror.lupaworld.com dapper/restricted Packages
忽略 http://mirror.lupaworld.com dapper/universe Packages
忽略 http://mirror.lupaworld.com dapper/multiverse Packages
命中 http://mirror.lupaworld.com dapper/main Packages
命中 http://mirror.lupaworld.com dapper/restricted Packages
命中 http://mirror.lupaworld.com dapper/universe Packages
命中 http://mirror.lupaworld.com dapper/multiverse Packages
命中 http://www.elisanet.fi dapper Release
忽略 http://www.elisanet.fi dapper/fonts Packages
获取:3 http://security.ubuntu.com dapper-security Release.gpg [191B]
命中 http://security.ubuntu.com dapper-security Release
忽略 http://www.elisanet.fi dapper/fonts Sources
命中 http://security.ubuntu.com dapper-security/main Packages
命中 http://www.elisanet.fi dapper/fonts Packages
获取:4 http://cn.archive.ubuntu.com dapper Release.gpg [189B]
获取:5 http://cn.archive.ubuntu.com dapper-security Release.gpg [191B]
获取:6 http://cn.archive.ubuntu.com dapper-updates Release.gpg [191B]
命中 http://security.ubuntu.com dapper-security/restricted Packages
获取:7 http://wine.budgetdedicated.com edgy Release.gpg [191B]
获取:8 http://cn.archive.ubuntu.com dapper-backports Release.gpg [191B]
命中 http://wine.budgetdedicated.com edgy Release
错误 http://wine.budgetdedicated.com edgy Release

忽略 ftp://ftp.nerim.net sarge Release.gpg
获取:9 http://wine.budgetdedicated.com edgy Release [739B]
忽略 http://wine.budgetdedicated.com edgy Release
命中 http://security.ubuntu.com dapper-security/universe Packages
命中 http://security.ubuntu.com dapper-security/multiverse Packages
命中 http://security.ubuntu.com dapper-security/main Sources
命中 http://security.ubuntu.com dapper-security/restricted Sources
命中 http://security.ubuntu.com dapper-security/universe Sources
命中 http://security.ubuntu.com dapper-security/multiverse Sources
忽略 http://wine.budgetdedicated.com edgy/main Packages
命中 http://wine.budgetdedicated.com edgy/main Packages
命中 http://www.elisanet.fi dapper/fonts Sources
获取:10 ftp://ftp.nerim.net sarge Release
命中 http://cn.archive.ubuntu.com dapper Release
命中 http://cn.archive.ubuntu.com dapper-security Release
获取:11 http://cn.archive.ubuntu.com dapper-updates Release [50.9kB]
忽略 ftp://ftp.nerim.net sarge Release
获取:12 ftp://ftp.nerim.net sarge/main Packages
获取:13 http://us.archive.ubuntu.com edgy Release.gpg [191B]
忽略 ftp://ftp.nerim.net sarge/main Packages
获取:14 ftp://ftp.nerim.net sarge/main Packages
错误 ftp://ftp.nerim.net sarge/main Packages
无法获取文件,服务器响应道“Can't open /debian-marillat/dists/sarge/main/binary-i386/Packages.gz: No such file or directory ” [IP: 62.4.17.14 21]
命中 http://us.archive.ubuntu.com edgy Release
获取:15 ftp://ftp.mowgli.ch sid Release.gpg [481B]
命中 http://us.archive.ubuntu.com edgy/universe Packages
命中 ftp://ftp.mowgli.ch sid Release
错误 ftp://ftp.mowgli.ch sid Release

获取:16 ftp://ftp.mowgli.ch sid Release [2112B]
忽略 ftp://ftp.mowgli.ch sid Release
获取:17 ftp://ftp.mowgli.ch sid/unofficial Packages
忽略 ftp://ftp.mowgli.ch sid/unofficial Packages
命中 ftp://ftp.mowgli.ch sid/unofficial Packages
命中 http://cn.archive.ubuntu.com dapper-backports Release
命中 http://cn.archive.ubuntu.com dapper/main Packages
命中 http://cn.archive.ubuntu.com dapper/restricted Packages
命中 http://cn.archive.ubuntu.com dapper/universe Packages
命中 http://cn.archive.ubuntu.com dapper/multiverse Packages
命中 http://cn.archive.ubuntu.com dapper/main Sources
命中 http://cn.archive.ubuntu.com dapper/restricted Sources
命中 http://cn.archive.ubuntu.com dapper/universe Sources
命中 http://cn.archive.ubuntu.com dapper/multiverse Sources
忽略 http://cn.archive.ubuntu.com dapper-security/main Packages
命中 http://cn.archive.ubuntu.com dapper-security/restricted Packages
命中 http://cn.archive.ubuntu.com dapper-security/universe Packages
命中 http://cn.archive.ubuntu.com dapper-security/multiverse Packages
命中 http://cn.archive.ubuntu.com dapper-security/main Sources
命中 http://cn.archive.ubuntu.com dapper-security/restricted Sources
命中 http://cn.archive.ubuntu.com dapper-security/universe Sources
命中 http://cn.archive.ubuntu.com dapper-security/multiverse Sources
命中 http://cn.archive.ubuntu.com dapper-updates/main Packages
命中 http://cn.archive.ubuntu.com dapper-updates/restricted Packages
命中 http://cn.archive.ubuntu.com dapper-updates/universe Packages
命中 http://cn.archive.ubuntu.com dapper-updates/multiverse Packages
命中 http://cn.archive.ubuntu.com dapper-updates/main Sources
命中 http://cn.archive.ubuntu.com dapper-updates/restricted Sources
命中 http://cn.archive.ubuntu.com dapper-updates/universe Sources
命中 http://cn.archive.ubuntu.com dapper-updates/multiverse Sources
命中 http://cn.archive.ubuntu.com dapper-backports/main Packages
命中 http://cn.archive.ubuntu.com dapper-backports/restricted Packages
命中 http://cn.archive.ubuntu.com dapper-backports/universe Packages
命中 http://cn.archive.ubuntu.com dapper-backports/multiverse Packages
命中 http://cn.archive.ubuntu.com dapper-backports/main Sources
命中 http://cn.archive.ubuntu.com dapper-backports/restricted Sources
命中 http://cn.archive.ubuntu.com dapper-backports/universe Sources
命中 http://cn.archive.ubuntu.com dapper-backports/multiverse Sources
获取:18 http://cn.archive.ubuntu.com dapper-security/main Packages [121kB]
99% [18 Packages gzip 0]
gzip: stdin: not in gzip format


错误 http://cn.archive.ubuntu.com dapper-security/main Packages
子进程 gzip 返回了一个错误号 (1)
下载 54.2kB,耗时 2m38s (343B/s)
无法下载 ftp://ftp.nerim.net/debian-marillat/dis ... ackages.gz 无法获取文件,服务器响应道“Can't open /debian-marillat/dists/sarge/main/binary-i386/Packages.gz: No such file or directory ” [IP: 62.4.17.14 21]
无法下载 http://cn.archive.ubuntu.com/ubuntu/dis ... ackages.gz 子进程 gzip 返回了一个错误号 (1)
W: GPG error: http://wine.budgetdedicated.com edgy Release: 由于没有公钥,下列签名无法进行验证: NO_PUBKEY 58403026387EE263
W: GPG error: ftp://ftp.mowgli.ch sid Release: 由于没有公钥,下列签名无法进行验 证: NO_PUBKEY 9F8E2A98D1A4EDE5
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.




有人能告诉我是怎么会事情,怎么解决吗?谢谢了!
上次由 ickbeta 在 2007-01-24 12:11,总共编辑 2 次。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2007-01-24 10:55

没有权限就要sudo
先看点基础的东西吧。不然尽量不要用命令行。
点击我的签名档好好看看。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
ickbeta
帖子: 7
注册时间: 2007-01-06 15:51
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 ickbeta » 2007-01-24 11:19

的确是的 。。。 不好意思阿 我还是刚用上的 :?
回复

回到 “老旧版本支持”