Firefox打开比较大的页面时,疯狂读写硬盘.

为当前最终发行版之前的所有版本提供支持
回复
uranusi
帖子: 42
注册时间: 2006-12-06 13:26
送出感谢: 0
接收感谢: 0

Firefox打开比较大的页面时,疯狂读写硬盘.

#1

帖子 uranusi » 2007-01-24 20:43

ubuntu用了将近两个月了,之前一直在反复调整硬件驱动等等,最近稳定下来,开始好好用了,却出现了一个问题.
就是当Firefox打开比较大的页面时,比如说有上百张图片的(就是天涯贴图区,拉斯维加斯成人什么展览会的那个帖子),就会开始狂读写硬盘,然后鼠标几乎不能移动,所有按键的反应都延迟到30秒以上.有时候可以一点一点的把鼠标移动到X上关掉Firefox,这样过一会儿就会恢复正常,但有时候没那个耐心就直接强制关机了.

我是512内存,但swap只有200多M.是不是swap太小的问题?或者这事firefox的问题?

另外,使用linux感觉就是界面响应比win要稍微迟缓那么一点点,多任务时,看电影和放音乐最明显,断断续续的情况比windows要严重,win下一般打开大的程序或者文件时,会发生影音断续的情况,但linux下随便干点小事也会出现影音断续的现象,甚至干扰鼠标的移动(win下很少碰到鼠标移动迟缓的现象),这种情况有没有办法通过调整软件获得改善?


说一下我的硬件,
2002年9月买的笔记本电脑,
cpu P4M 1.7G
内存 512M
硬盘 40G
显卡 Geforce 440 Go 32M
这配置现在还能勉强能打打魔兽世界.
原来装的是winxp,用久了审美疲劳,就又装了ubuntu,现在是双系统.
当时装的时候,硬盘只有一个C区,而且只有7G左右的空间,用liveCD启动,选择使用剩余空间安装,ubuntu自动使用了4.3G作为linux的分区,swap自动只分了200多M.
开机就启动beryl,beryl占用大概40M左右的内存,其他乱七八糟的加起来开机内存占用在180M左右.
Firefox一开就又没了40M,随便开几个页面就100多M没了.
yohu
帖子: 955
注册时间: 2006-12-18 17:04
来自: 福建泉州
送出感谢: 0
接收感谢: 1 次

#2

帖子 yohu » 2007-01-24 21:30

强制关机可不是好习惯,损坏系统是小事,损坏硬盘可就得不偿失了。firefox如果没有响应,可以在终端下强制杀死进程。killall firefox或者pkill firefox.
firefox打开图片或者多媒体较多的页面cpu占用是会比较高,另外建议如果系统是拿来用的话,少装一些不实用的美化视觉浪费资源的软件,除非自己机子资源多到用不完。
拥有超级牛力的搜索引擎:
http://www.google.com/linux
http://www.google.com/
uranusi
帖子: 42
注册时间: 2006-12-06 13:26
送出感谢: 0
接收感谢: 0

#3

帖子 uranusi » 2007-01-24 22:55

多谢楼上指教,我也不想强制关机的,问题是不止firefox没有响应了,我连切换控制台都切换不了了。
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#4

帖子 dogfox » 2007-01-24 23:01

:shock: 网址是多少?
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
ghost0
帖子: 364
注册时间: 2006-08-11 0:28
送出感谢: 0
接收感谢: 0

#5

帖子 ghost0 » 2007-01-25 2:27

你没事儿老开着beryl做什么?不用beryl的话 512M内存只要不是做服务器的,好像基本都不会用到 swap
uranusi
帖子: 42
注册时间: 2006-12-06 13:26
送出感谢: 0
接收感谢: 0

#6

帖子 uranusi » 2007-01-25 14:53

那么说是因为我的swap太小了?
就算不开beryl,512m也很容易用光的啊,看图
附件
Screenshot-1.png
回复

回到 “老旧版本支持”